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OVERVIEW

A CMDB (Configuration Management Database) is a repository of information which gathers and links
components of an information system, thus enabling a better understanding of their organization.

Elements of a CMDB are named configuration items (Cl). A configuration item is an instance of entity with
modifiable attributes.

In MEGA 2009 SP5 R7, a tool allows you to import CMDB assets into a MEGA repository.

Import format

Objects to import must be described in an XML file whose structure complies with the format defined by
the XSD file supplied by MEGA.

The MEGA schema allows importing configuration items from different CMDB tools (BMC, HP, etc.) and thus
avoiding discrepancies between versions.

Imported objects
The objects you can import into MEGA are:

e CMDBs
e Configuration items

e Configuration item types

CMmMDB
All elements imported are linked to a CMDB. A CMDB contains configuration items and their type.
Name of the CMDBs contained in the imported file appears in the import wizard. If no CMDB is specified in
the imported file, the wizard automatically creates it.

Configuration items

The different components imported into MEGA are created in the form of configuration items. Then you
can map them with MEGA Architecture objects (Servers, workstations, artifacts, physical assets, etc.). See
“Mapping Cl with MEGA Architecture components”, page 8.

A configuration item can contain other configuration items. The link between an item and its sub-item is
represented by a Configuration Item Composition.

Configuration items properties

The XML file must provide the name of the items to import as well as their properties.
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If certain properties do not exist in MEGA, you can define them in the XML file so that MEGA can create
them and link them to the appropriate items.

New properties appear in a dedicated tab of the item property window. See example page 12.

Identifier

Configuration items imported into MEGA have a CMDB identifier. MEGA memorizes this identifier in order
to recognize all configuration items. When importing items, the wizard checks if they already exist in the
MEGA repository so that it can either create it or update it.

The CMDB identifier is displayed in the property window of the configuration item, under the
Characteristics tab.

Status

As an indication, you can give the Status of the configuration item:

e Active
e Deprecated
¢ Inactive

Contrary to the Delete option, the status definition has no impact on the item. See « Deleted objects», page
4.

Configuration item type

A configuration item is associated to a type. In MEGA, the configuration item type is displayed in the item
property window, under the Characteristics tab.

@ Properties of Configuration Item my server 1 |:||E|[z|

General| Characteristics | COME Properties | Sub Configuration ltem | Comment

Local name: | my server 1 |

CMDE Status: | active v

CMDE Identifier: | al |

Ikem Type:
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Deleted objects

In the XML file you can specify that certain items already imported into MEGA must be deleted (because
they have been removed from the CMDB source for example). To delete them in MEGA, you must check the
Delete in MEGA the objects marked for deletion in XML file option in the import

wizard.
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IMPORTING CMDB DATA INTO MEGA

To import CMDB data into MEGA:

1. Inthe MEGA Desktop, click File > Import > Cmdb (*.xml).

_} Open...
E Sawe  (Chr45
gi Dispatch
&5 Refresh

a( Discard

Impork 4 fi MEGA File (*.magr;*.mae;*. mal;
3

Expark

CMDE (*.xml)

@ Properties Excel Import
Wisio (*.wed; *vdx)

WSDL (* wsdl)

Exit  Alk+F4

The CMDB Import wizard appears.

i CMDB Import - XML File to import

the CMDE data.

This tool allows to'import CMDE data from a xml File, The format of this xml file must be
compliant with the schema published by Mega. Inorder to process, select the =ml file containing —

>

[ |

CMCE File ko Import: | |

Options

Check xml file validity
[(oelete Mega objects marked in xml il

| cancel || hHep |

2. Click the Browse button E] and select the file to be imported.
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Two options are available:

e Check XML file validity: this option checks the validity of the file format which must follows the XML
schema provided by MEGA. If the XML file is not correct, it cannot be imported. A message appears
when the file is not valid. You can get more details by consulting the Error Log File. To access it, click the

Help menu then Technical Support > Error Log File > Edit.

 Delete in MEGA the objects marked for deletion in XML file: if this option is

checked, all CMDB items marked for deletion will be deleted in MEGA at the end of the import.

3. Click Next.

The Import wizard lists the different CMDBs identified in the file. Select those you want to import. If a

CMDB has already been imported into MEGA, its name is indicated in the CMDB MEGA column.

A CMDB is a group of configuration items

& CMDB Import - Select CMDB to Import

_MCE File to Import:
_MCEs detected in the import file:

DEjcmdb-impart-sample. :mil

Z

Mame
&= crdbseo [xoo]
& emdbyyy [yyy]

CMDE Mega
1

[ < Previous J [ Mexk =

Impork

o |

Help

J

4. Click Next.

A dialog box asks you to confirm the import process.

5. Click Yes.

A report displays the result of the import. You can access the full report in the specified path.
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Cmdb File To Import: 9 SPS CP7_R¥cmdbimportfilesample, <mil
crdbs imported; 21z

Report Filepath: STRATION!DBEVADYERTIIREYISERVISER CrndbImport 20120626 18h43, Ext
Report Information:

6. Click Finish.

Displaying CMDB configuration items

Configuration items imported into MEGA appear in a dedicated navigation tree.

E;] Haome Main Objects 3,; Projects &% oMoB
& IR EGA (Tutorial)
=) CMDE
Sl cmdbeee CMDB
=3 Configuration Ikem
B myserverl — Configuration itern
2670y server 1-1
=3 myserver 1 ——— Configuration item
£ my server 1 composition
=3 Configuration Ikem Type
(g pheysical disk.
1 server
I software
= fj crnd by
=) Configuration Ikem Type
F server — Configuration itern type
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MAPPING Cl WITH MEGA ARCHITECTURE COMPONENTS

Configuration items created in MEGA can be mapped with MEGA Architecture concepts. You can map them
with elements of an application or elements of a resource architecture (Artifacts and Physical Assets).

Mapping between objects has to be done manually by the user in the mapping editor.

Property windows of MEGA Architecture concepts display a new page in which you can see the CMDB items
with which they have been mapped.

Mapping editor

To map a configuration item with a MEGA Architecture object:

1.
2.

In MEGA, click the menu Tools > Mapping Editor.

In the mapping editor, click File > Create Mapping Tree.

The Create Mapping Tree dialox box appears.

3
4.
5
6

Create Mapping Tree rz|
Marne: | Mapping |
Cwner | > |
Mature: |CMDB Ikems Mapping i |

Left Dhject Right CObject
|Resnurce Architecture b |
[ 3 | >

[ Cancel H Help ]

Select as Nature the "CMDB Elements Mapping".
In the Left Object frame, select the CMDB that contains the items to map.
In the Right Object frame, select the resource architecture that contains the architecture concepts.

Click OK.

The editor displays on the left the items of the CMDB, and on the right the components of the resource
architecture.
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To create mapping between an item of the CMDB and a component of the resource architecture:

1. Inthe mapping editor, select an item on the left.

2. Select the equivalent object in the architecture on the right.

3. Open the pop-up menu of the second object and select Map.

[ 2 X | o omdbe:

3 phivsical disk.

server

: my server 1
pheysical disk
software

software

[ Call Center @
= r.:) Operabor Equiprient
= {I} Operator Equipment &
2 Artifact Component
=@  Artifact Component
=] @ Operator Station &
Z=1  Application Host
=) Application Host
—=!  Application Host
) X Mail Systen
25 2 Office Syskem Applications
[=- {38 2 Artifack Component
@ Window I
(3 I Operating Sys

Mapping

Property

Marne
Commen...

The mapping is created from the last object selected. In the above example, “my server 1” is mapped with

“Window XP Virtual Server”. The mapping appears in the properties of the “Window XP Virtual Server”
artefact, under the CMDB Mapped Elements tab.

. 3 Properties of Artifact Windows XP Virtual Server

General Characteristics
Objectives and Requirements

Hozted D atabazes

Service and Request Points

- BX

Hosted Applications

Properties Sub-Artifacts

Lifeline Texts

CMDE Mapped Elements

Complements

Cmer |Li|:|rar~;.-' W " Call Center

Zonfiguration Ikem:

By | 4 -
Local name ZMDE Status CMODE Identifier
[ my server 1 Ackive al

You can also display the mapped items in the resource architecture diagram.
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You can display the mapped elements in the resource architecture diagram, by checking the CMDB
Elements option in the diagram Views.

Yiews

Select Al [

Communications
Interactions
Service and Requesk Paoints
Interactions and Communications
Architecture Use
Human Asset
Phrysical Asset
Resource Architectureas
Sikes
External References
Motes

..¢&# CMDE Elemnents

D B O B 1 B B il
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EXAMPLE OF XML FILE

The following extract is an example of an XML file containing CMDB elements to import.

First elements described in the file are CMDBs, which contain configuration item types and configuration
items.

<?xml version="1.0" encoding="UTF-8" 7=
- =zcmdbroot xmins="http://www.mega.com" xmins:xsi="http:/ /www.w3.0org/2001/XMLSchema-instance"

wsechemalocation="http:/ /www.mega.com cmdb.xsd" >
*id:"x){x" cmdbid="xxx" name="cmdbxxx"
Escription /=
- =ciType id="a123" cmdbid="azerty" name="server"=
<description=This is the comment of this configuration item </description=
- <properties:
<property id="123_1" cmdbid="123_a" name="ip adress" type="string" length="15" />
<property id="123_2" cmdbid="123_b" name="purchase date" type="date" format="yyyy/mm/jdd" />
- «property id="123_3" cmdbid="123_c" name="additional information" type="text">
zdescription=This property is used to define additional information </description=
</property =
</properties=
</ciType>
- =ciType id="a456" superid="a123" cmdbid="qsdfgh" name="software" toto="45"=
<description=This is the comment of this configuration item</description:
</ciType>
<ciType id="a789" superid="a123" cmdbid="wxcvbn" name="physical disk" delete="no" /
</types>
- <data=

- =i |!= a cm! !|d="a1" name="my server 1" typeid="a123" status="active" delete="yes":

<description=This server hosts IBM Rational Synergy</descriptionz
<propertyValue name="ip adress" propertyid="123_1">123.456.10.2</propertyValus =
<propertyValue name="purchase date" propertyid="123_2"=2009/04/15</propertyVvalue =
<fci=
- =ci id="b" cmdbid="b1" name="my server 1" typeid="a456" status="active" delete="no" tote="789">
<propertyValue name="ip adress" propertyid="123_1">123.87.10.2=</propertyValue=
<propertyValue name="additional information" propertyid="123_3"=bla bla bla </propertyValue=>
<fciz>
</configurationltems >

=

<composition id="ab" cmdbid="ab" ownerid="a" usedid="b" /=
<composition id="ba" cmdbid="cd" ownerid="b" usedid="a" /=
</compositions =
</data>
</cmdb =
- =cmdb id="yyy" parentid="xxx" cmdbid="yyy" name="cmdbyyy">

For each of these elements, you must define the name, potentially a description (comment), but most of all
its CMDB identifier.

<ciid="a" cmdbid="al" name="my server 1" typeid="a123" status="active" delete="yes">
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Configuration item type

Configuration item types are associated to a CMDB.

If certain properties do not exist in MEGA, you can define them in the XML file so that MEGA can create
them and link them to the appropriate items.

Example of CMDB properties of a configuration item of "Server" type

- «<types>
- <ciType id="al123" cmdbid="azerty" name="server":>
<description=This is the comment of this configuration item</description=
- «<properties>

<property id="123_1" cmdbid="123_a" name="ip adress" type="string" length="15" /=
<property id="123_2" cmdbid="123_b" name="purchase date" type="date" format="yyyy/mm/fdd" />

- =property id="123_3" cmdbid="123_c" name="additional information" type="text">

<description=This property is used to define additional information</description=

</property =

</properties =

Result in MEGA:

® Properties of Configuration ltem my server 1

General | Charactenstics | COME Properties | Sub Configuration ltem | Comment

Ikem Type: |server > |
SErver
ip adress: | 123.456.10.2

purchase date: |15,|'|:|4,|'2EIIII‘3 b

additional information:

TEfp e

Configuration item

List of configuration items contained in a CMDB is described in the <Data> tag.
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Each configuration item refers to a type which has been defined previously in the same CMDB.

<ciid="a" cmdbid="al" name="my server 1" typeid="a123" status="active" delete="yes">

On a configuration item, you can specify values of properties defined on the type it refers to.

Configuration item composition

A configuration item can contain other configuration items. The link between an item and its sub-item is
represented by a Configuration Item Composition.

</configurationltems>

<compositions>
<composition id="ab" cmdbid="ab" ownerid="a" usedid="b" />
<composition id="ba" cmdbid="cd" ownerid="b" usedid="a" />

</compositions>
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