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INTRODUCTION

HOPEX Internal Control is an internal control management solution covering the different phases
of internal control. This solution enables:

 definition of internal control systems with creation of a control library
 execution of controls
 assessment of controls, directly or by assessment campaigns or tests
 management of issues and action plans

HOPEX Internal Control is intended for internal control managers, internal controllers and
business process managers. An interface customized according to profile accompanies
implementation of internal control systems.

 “Internal Control Process", page 10
 “Accessing HOPEX Internal Control", page 12
 “Interface Presentation", page 13
 “About This Guide", page 14
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INTERNAL CONTROL PROCESS

Internal control consists of checking that controls carried out during enterprise
processes have been correctly executed and are efficient.

HOPEX Internal Control covers the different phases of internal control:
• Control Library Definition
• Control Execution
• Control Assessment 
• Control Testing
• Issue and Action Plan Management

Defining the internal control library is a prerequisite for control execution and
assessment activities.

Execution and assessment of controls can be carried out independently.
 Reporting functions are available at all times, either globally or for 
each internal control step.

Control Library Definition

HOPEX Internal Control allows internal control managers to: 
• identify controls 
• contextualize controls in the company repository, that is to connect them 

to the appropriate processes and entities

Control Execution

Controls are regularly executed by managers to check that first level controls are
correctly executed. HOPEX Internal Control allows:

• creation of questionnaires called check-lists
• definition at regular intervals of control execution campaigns
• follow-up and consolidation of control  execution results from reports

 The HOPEX Internal Control solution does not concern first level 
controls executed by operational management during execution of 
enterprise processes.
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Control Assessment

Assessment of relevance of controls in terms of design and efficiency can be carried
out by means of:

• assessment campaigns via questionnaires 
• control tests organized by the internal control department

Issue and Action Plan Management

Issues can be identified from control assessment questionnaires or specified directly
in the solution.

Resolution of issues is formalized by implementation of action plans. Reports assure
efficient follow-up of internal control activities.
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ACCESSING HOPEX INTERNAL CONTROL

The menus and commands available depend on the profile with which you are
connected.

Connecting to the solution

Pour connect to HOPEX, see HOPEX Common Features, "HOPEX desktop",
"Accessing HOPEX (Web Front-End)".

HOPEX Internal Control Profiles

In HOPEX Internal Control , there are, by default, business roles with which
specific activities are associated. 
The business roles used are:

• Internal Control Director 
• Internal Controller
• Business User
• Functional Administrator

Presentation of the solution interface depends on the profile selected by the user on
connection to the application; the tree of menus and functions varies from one
business role to another.

Profiles Tasks

Internal Control Director - Has all internal controller rights
- Validate campaigns
- Prepare test plans
- Validate action plans

Internal Controller - Define controls
- Prepare campaigns
- Execute tests (create work programs, create issues and 
action plans)
- Validate and follow up action plans

Business User (IC) - Complete control execution check-lists
- Answer assessment questionnaires
- Define and create action plans (and create issues)

Functional Administrator - Has all rights on workflows, objects and menus of the solution
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INTERFACE PRESENTATION

The menus and commands available in HOPEX IT Risk Management depend on
the profile with which you are connected. See  “HOPEX Internal Control Profiles",
page 12.

The navigation tabs available at the top of the page relate to the different phases of
internal control:

• Control Library
See “Managing the Control Library", page 27.

• Control Execution
See “Executing controls", page 45.

• Campaign Management
See “Assessing controls", page 57.

• Remediation 
See “Managing Issues and Action Plans", page 109.

• Reports 
See “HOPEX Internal Control Reports", page 117.

 For more details on how to use the interface, see the HOPEX 
Common Features guide.
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ABOUT THIS GUIDE

This guide presents the features of HOPEX Internal Control solution. It follows the
main steps described in paragraph “Internal Control Process", page 10.

 “Guide Structure", page 14
 “Additional Resources", page 14

Guide Structure

This guide comprises the following chapters:
 “Functional administration", page 15: managing the control environment, defining 

calendars required for execution of campaigns, managing teams.
 “Defining the Environment for Solutions", page 463: describes the different 

elements of the environment used in HOPEX solutions.
 “Managing the Control Library", page 27: defining controls and their application 

scope.
 “Executing controls", page 45: managing control execution campaigns.
 “Assessing controls", page 57: directly assessing controls, managing control 

assessment campaigns.
 “Control testing", page 79: preparing, executing and following up tests.
 “Managing Issues and Action Plans", page 109: managing issues and action plans.
 “Glossary", page 167
 “Appendix - Workflows", page 137: presents workflows used in the solution.

Additional Resources

This guide is supplemented by:
• the  HOPEX Common Features guide, which describes the HOPEX 

interface.
 It can be useful to consult this guide for a more detailed general 
presentation of the interface.

• the HOPEX Power Supervisor administration guide.
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FUNCTIONAL ADMINISTRATION

So that the different participants can play their roles, the functional administrator must first create
and manage the elements required for preparation of the tasks for each of them. 

 “Environment Management", page 16: organizational units and processes, for 
example.

 For a complete description of the solutions environment, see 
“Defining the Environment for Solutions", page 463

 “Managing Campaign Calendars", page 18 
 “Managing Teams", page 19 
 “Managing Currencies", page 22
 “Configuring Time Sheets", page 25
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ENVIRONMENT MANAGEMENT

The functional administrator is authorized to update all organizational information.

To access information concerning the environment of the enterprise:
 At top left in the application, click the button corresponding to the 

Environment desktop.

 For a complete description of the solutions environment, see 
“Defining the Environment for Solutions", page 463

Accessing Organization Information

To access information concerning the organization:
1. In the Environment desktop, select  Organization > Tree View.

Trees enable access to all organization entities and processes.
2. Select an object in the tree that interests you.

The properties dialog box of the object appears on the right.
3. Specify properties or connect context objects.

Connecting Environment Objects

To be able to use functionalities of the HOPEX Internal Control solution:
• Processes (organizational or business) should be connected to entities of 

the organization. 
• Controls should be connected to these processes.

For example, to connect processes to an entity:
1. In the Environment desktop, click Organization > Hierarchical View 

> Entities and select an entity.
2. In the properties of the entity, expand the Scope section.
3. In the subtab corresponding to organizational or business processes, 

click Connect.
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4. In the query dialog box that appears, click the Find button, select the 
required process and click Connect.

 To connect controls to processes, you can proceed as described 
above but from a process. HOPEX Internal Control enables simpler 
control scope definition. For more details, see “Scoping Controls", page 
32.
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MANAGING CAMPAIGN CALENDARS

Assessment campaigns are based on calendars divided into calendar periods.
 A campaign calendar enables planning of campaigns and their 
division into periods called calendar periods. Campaign calendars can 
also be used in reports or to plan audits or tests.

A calendar often covers a period of one year, either a fiscal year or a calendar year.
In the latter case, a calendar period can correspond to a quarter.

Creating Calendars 

To create a calendar:
1. In the Control desktop, select Testing > Preparation > Calendars.
2. In the right pane of the window, click New.
3. Enter the Name of the calendar and its begin and end dates.
4. Click OK.

You can then define calendar periods.

Creating Calendar Periods

To create calendar periods:
1. Open the Properties of the calendar.
2. Click the Characteristics tab.
3. In the Calendar Period section, click New.
4. Enter the Name of the calendar period and its begin and end dates.
5. Click OK.
6. Create other calendar periods in the same way.

The calendar is created. It can then be connected to a test plan.

Connecting a Calendar to a Test Plan

To connect a calendar to a test plan:
1. In the Control desktop, select Testing > Plans.
2. Open the properties of the test plan that interests you.
3. Click Characteristics.
4. In the Calendar field, click the arrow and select List to display the list of 

calendars.
5. Select the calendar to be connected to the test plan.
6. Click OK.
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MANAGING TEAMS 

Before planning tests, appropriate teams must be set up and roles and
responsibilities assigned.

Tools are available that enable definition and display of the skills of team members.

Creating Controllers 

To create a controller, you must create a person and associate the "Control Tester"
profile.

 For more information on creation of users and assignment of 
profiles, see the chapter "Managing Users" in the HOPEX Power 
Supervisor guide.

Managing Controller Skills

HOPEX Internal Control enables management and viewing of skills for each
controller. 

To do this, you must previously have defined:
• skill types
• skills list
• skill levels 

Creating skill types

To create a skill type:
1. In the Administration desktop, select Skill Management > Skill 

Types.
2. Click New.
3. Enter a Name for the skill type, for example "Languages".
4. Click OK.

Creating skills

To create a skill:
1. In the Administration desktop, select Skill Management > All Skills.
2. Click New.
3. Enter a Name for the skill, for example "English".
4. Click OK.

The new skill is added to the list of skills.
In properties of the skill you can indicate the Skill Type to which it is
attached, for example "Languages".
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Creating skill levels

You must now create skill levels to be associated with each skill type.

To create a skill level:
1. In the Administration desktop, select Skill Management > Skill 

Levels.
2. Click New.
3. Enter a Name for example "Beginner" for "Languages" skill type.
4. Click OK.
5. In skill level properties, select the Skill Type to which it is attached, 

here "Languages".
6. In Skill Level Internal Value, enter a figure corresponding to the skill 

level, for example "1" for "Beginner" (while "4" could correspond with 
"Experienced" in our example).

 This figure gives a graphic view of the extent of controller skills in 
the test assignment page. 

7. Click Apply.
8. Close skill level properties.

Defining skills for each user

To define the skills of a user:
1. In the Administration desktop, select Skill Management > Manage 

Skills by User.
2. Select a user and click the Properties button.
3. In the properties page, click Skills.

In the page that appears, you can specify user skills as a function of
previously defined skill types and skill levels.

Example of skills

Viewing skills

To view the skills and skill levels available within the team:
 In the Administration desktop, select Skill Management > View 

Users and Skills.
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A list appears. You can sort the list by skill, skill level and user by clicking the header
of the corresponding column.
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MANAGING CURRENCIES

Currencies are used in the framework of tests for completion of expense sheets.

Currency Use Principle

Two currency types should be distinguished:
• central currency
• local currency

Central currency

Central currency is the currency adopted as reference currency.

Local currency 

A local currency is defined for each user. By default it is the same as central
currency. 

Defining Central Currency

To define central currency:
1. In the Administration application (administration.exe) connect to the 

environment in which you wish to work. 
2. Right-click the repository and select Options > Modify.

The repository options window opens.
3. Select the Installation > Currency folder.

The list of currencies available as standard appears on the right.
4. In the Monetary Symbol field, specify the symbol of your consolidation 

currency, for example "$".
5. In the Central Currency field, select your consolidation currency, for 

example "US Dollar".
6. Click OK.
7. Exit the Administration application.
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Defining Local Currency

You can choose a local currency different from the central currency. To do this, you
must connect to HOPEX Windows Front-End with your login.

To modify user local currency:
1. Start HOPEX Windows Front-End and connect with your login.
2. In the desktop, select Tools > Currency and select the currency that 

interests you.
3. Exit HOPEX, dispatching your private workspace.

When you reconnect to Web Front-End with your login, the currency proposed by
default for your expense sheet expenses is the currency you have just defined.

Modifying User Local Currency

Local currencies proposed to users of the application are defined with the HOPEX
Administration application.

To define the list of local currencies:
1. In the folder where HOPEX is installed, launch "Administration.exe" and 

connect with a user that has data administration authorization rights.
2. Select the environment then the repository on which you want to work. 
3. Right-click the repository and select Options.

The repository options window opens.
4. Select the Installation > Currency folder.

The list of currencies available as standard appears on the right.
5. Then select all the currencies that will be used locally by your users.
6. Click OK.
7. Exit the Administration application.

Managing Exchange Rates

Entering an exchange rate

To enter an exchange rate:
1. In the Administration desktop, select Currencies > Exchange Rate.
2. Click New.
3. Select the line created and select Properties.
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4. In the window that appears, enter:
• the Currency Code To.
• the Rate of the source currency related to the final currency.
• the Rate Date Begin.

 Several exchange rate periods can be entered for the same 
currency. When entering expenses, the most recent exchange rate is 
taken into account.
 You must enter the exchange rate in both directions, for example:
• EUR->USD
• USD->EUR

Viewing an exchange rate

To view an exchange rate:
1. In the drop-down lists above the table, select the source and final 

currencies.
2. Click Refresh.

The exchange rates for the selected currency appear.

 To reverse the exchange rate, click button 
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CONFIGURING TIME SHEETS

Time sheets are used in the context of audits/tests.

The functional administrator can configure time sheet default options.

The functional administrator can define:
• number of hours worked per day
• days not worked in enterprise

To configure this data:

1. Click button  at the right of the connection role, then Options.
2. In the window that appears, expand the folders Installation > User 

Management.
3. In the right pane of the window, specify:

• the number of Hours/Day for each auditor.
 Default value is "8".

• days corresponding to weekend
 Default values are "Saturday" and "Sunday".
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MANAGING THE CONTROL LIBRARY

HOPEX Internal Control enables creation of control libraries and connection of controls to objects
in their environment. This enables positioning of controls in their business context.

This "contextualization" allows internal control managers to define adapted controls and
subsequently carry out relevant assessments.

 “Creating Controls", page 28
 “Control Characteristics", page 29
 “Scoping Controls", page 32
 “Managing Controls", page 34
 “Preparing Control Execution", page 37
 “Preparing Control Testing", page 41
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CREATING CONTROLS 

The internal controller, the internal control director and the functional administrator
can create controls.

To create a control:
1. In the Control desktop, select Control Library > Control 

Management > Controls > All Controls.
2. Click New.

The control created appears in the list of controls. You can now specify the
various characteristics from the properties window.

 For more details, see “Control Characteristics", page 29.
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CONTROL CHARACTERISTICS

Different sections are available in the properties of a control.
 To access controls, see “Accessing controls", page 34.

General characteristics

Code

The code enables unique identification of the control.

Control objective

You can enter a comment describing the required objective of setting up the control.

Owner

The control owner is the user responsible for execution of the control.

This field is used when there is only one "Responsible" (in the RACI sense).
 For more details on RACI, see “Responsibilities", page 30.

Key control

When the Key Control check box is selected, the control appears in the list Control
Library > Control Management > Controls > Key Controls list.

Control nature

This characteristic allows you to specify the nature of the control. You can select
from three main internal control types:

• Corrective
• Detective 
• Preventive

Operational cost

This characteristic enables indication of a control cost assessment. 

Execution mode

This characteristic enables specification of how the control is carried out:
• "Automatic"
• "Manual"
• "Semi-automatic"
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Scope

The Scope section of control properties enables connection of controls to other
objects:

• Business process
• Organizational processes
• Entities
• Risks
• Accounts
• Requirement 
• Types of control

Responsibilities 

HOPEX Internal Control enables definition of responsibilities of each participant
related to a control via the RACI matrix:

• Responsible
• Accountable
• Consulted
• Informed

Responsibility levels
The proposed responsibility levels are as follows:

Specifying control responsible users

In the framework of control assessment via campaigns, questionnaire respondents
are Responsibles of control. 

 For more details on assessment campaigns, see “Assessing 
Controls by Questionnaires", page 64

You can connect several "Responsibles" for the same control in different entities.

To specify the person responsible for a control in a given entity:

Scope of 
responsibility

Meaning

Responsible Responsible for execution of required actions.

Accountable Reporting on progress of planned actions and making deci-
sions. 
There is only one "Accountable". 

Consulted Consulted as first priority before an action or decision.

Informed Must be informed after an action or decision.
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1. In the control properties page, expand the Responsibilities section.
 To access controls, see “Listing controls", page 34.

2. Select the Responsible tab.
3. Click the Connect button.

In the dialog box that appears, click the Find button.
4. Select a person in the list that appears and click Connect.

The person appears under the tab concerned. You must now connect the
person to an entity.

5. In the Assignment Location field, select an entity to which the person 
executing the control is attached.

 Ensure that an e-mail address is correctly specified in the 
properties of the person.
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SCOPING CONTROLS

HOPEX Internal Control enables easy control scoping and connection of controls
to:

• entities
• process
• control types
• regulation frameworks

The same control can be assessed in the framework of different contexts (for
example processes or entities). 

To enable this multiple assessment, you must "contextualize" controls, that is
connect them to objects of different contexts.

Several contextualization tools are available to define this application scope.

Scoping Controls via a Matrix

You can create a matrix to connect controls:
• to processes
• to entities

To connect controls to entities:
1. In the Control desktop, select Control Library > Contextualization > 

Matrix Contextualization > Controls per Entity.
2. Click New to create a matrix.
3. Select Add a Row.
4. In the dialog box that opens, click Find.
5. Select the controls that interest you and click OK.
6. Select Add a Column.
7. Use the query tool in the same way to add entities.
8. In the matrix created, select the cells at the intersection of controls and 

entities that interest you.
Links are established between these controls and entities.

To disconnect a control from an entity:
 Click again in the cell concerned.

The green tick disappears. The link between control and entity is deleted.

To remove a row/column:
 Select the line/column and click Remove.

 You can send this matrix to Excel.

 To connect controls to processes, select Control Library > 
Contextualization > Matrix Contextualization > Controls by 
Process.
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Defining scope via lists or trees

By simple drag-and-drop you can connect controls to:
• entities
• control types
• process 
• regulation frameworks

Contextualization from a list

To contextualize controls from a list:
1. In the Control desktop, select Control Library > Contextualization > 

Contextualization > List View.
The screen that appears presents:
• on the left, a list of controls.
• on the right, trees of entities/control types/processes/regulation 

frameworks.
2. Drag-and-drop the desired control to the appropriate tree.

 From this list, you can merge or duplicate controls. For more 
details, see “Merging and Duplicating Controls", page 35.

Contextualization via trees

To contextualize controls from a tree to another tree:
1. In the Control desktop, select Control Library > Contextualization > 

Contextualization > Tree View.
Control trees classified by entities/control types/processes/regulation
frameworks appear.

2. Drag-and-drop from one tree to another tree.
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MANAGING CONTROLS

Accessing controls

By default, controls are visible to all.

You can access these via different lists and trees.

Accessing controls by context

To access controls:
 In the Control desktop, select Control Library > Control Trees.

Controls are classified by:
• entities
• control types
• process 
• regulation frameworks

Listing controls

To list controls:
1. In the Control desktop, select Control Library > Control 

Management > Controls > All Controls.
You obtain the list of all controls. 
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Viewing key controls

To view controls considered as key controls:
 In the Control desktop, select Control Library > Control 

Management > Controls > Key Controls.
Key controls are controls for which the Key Control check box was
selected in the control properties.

Viewing "orphan" controls

To view controls that have not yet been contextualized:
 In the Control desktop, select Control Library > Control 

Management > Controls > Orphan Controls.
Controls that have not been connected to a context object (entity,
process, etc.) appear. These are elements for which scope has not been
defined.

Modifying Controls

By default, controls are visible to all. However, you can modify only those controls
attached to your reference entity or to one of its sub-entities.

 A user is connected to a reference entity in the framework of his/
her assignment. For more details on assignments, see chapter 
"Managing Users" in the HOPEX Power Supervisor guide.

If according to your assignment you are connected to the 
"France" entity, you cannot modify controls that have 
"World" entity context. 

However, if you are connected to the "World" entity, you can 
modify controls that have "France" entity context.

Merging and Duplicating Controls

From list and tree views, controls can be merged and duplicated. 

Merging

In a "bottom-up" approach, similar controls can be submitted to the internal control
director. It is then possible to merge these to produce just a single control. The
control created in this way can be connected to several locations (entities).

To merge two controls:
1. Select Control Library > Contextualization > Contextualization > 

List View.
2. Select two or more controls to be merged.
3. Click Merge.
4. In the merge controls window that appears, select a Target Control from 

the controls you have selected.
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5. Click OK.
The controls initially selected now form a single control.

Target control characteristics retain their value. 
 If no value was specified on the target control, those of the source 
control are transferred. 

All elements connected to the source control are connected to the target control.
The source control is deleted.

Duplicating

You may need to duplicate a control to divide a control into two separate controls
for example.

To duplicate a control:
1. Select Control Library > Contextualization > Contextualization > 

List View.
2. Select the control that you want to duplicate.
3. Click Duplicate.

The duplicated control appears in the list.
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PREPARING CONTROL EXECUTION

To be able to start execution campaigns, you must first:
• specify a steering calendar on controls to be assessed

See “Defining Control Execution Calendars", page 37.
• define control steps on each control

See “Defining questions on controls", page 38.
• define check-list respondents

See “Defining Respondents", page 40.
• connect processes to controls to be executed

See “Connecting Controls to Entity Processes", page 40.

Defining Control Execution Calendars

To define periodicity of control execution, you must specify the steering calendar to
be used.

Specifying a control steering calendar

To specify a steering calendar:
1. In the control properties, select the Execution tab.
2. Select an Execution Frequency.

 This field is for information only.
3. Select a Steering Calendar.

Different steering calendars exist for different execution periodicities:
• daily
• monthly 
• weekly 

 You can create a steering calendar if none of those supplied as 
standard is suitable.

Creating and configuring a steering calendar

To create a steering calendar:
1. Select Control Library > Control Management > Steering 

Calendars > Steering Calendars and click New.
2. In the Steering Date section, click New.
3. Open the steering date properties dialog box and select the Scheduling 

tab.
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4. Specify the information required for starting the campaign including:
• start and end dates for execution campaigns

 Begin and end dates specified on the steering calendar do 
constitute campaign start and end dates. They simply serve to define 
the interval within which assessment sessions can take place.
 It is recommended to use a relative begin date on the steering 
date.

• start date and hour (defined in UTC format).
 For details on possible configurations, see the section concerning 
the scheduler in the technical article "HOPEX Studio".

5. Select Execute at start date & time if you wish to launch the campaign 
execution immediately.

 If the check box is deactivated, the scheduler waits for the next 
recurrent date (and time) to trigger the job.

Viewing controls connected to a steering calendar

To view which control is connected to which steering calendar:
 Select Control Library > Control Management > Steering 

Calendars > Controls Per Steering Calendar.

Defining questions on controls

Before starting execution campaigns, you must define the content of check-lists
used at control execution. It consists in defining questions to ask when executing
controls. 

You can create:
• questions concerning all controls
• questions specific to a control

To do this, you must create control steps on each control. They correspond to check-
list questions/answers. The control steps can be:

• specific: specific to the control itself
• inherited: applicable to all controls, excepting particular conditions

 Conditions can be applied to inherited control steps. For more 
details, see “Conditioning questions", page 39.

Question/answer types

Several question/answer types are available.

OK/NO type questions/answers

The type of question proposed by default at creation of a control step is "OK/NO". 
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Possible answers to this question are:
• OK
• NO
• N/A: Not Applicable

 Only answers of type "OK/NO" are aggregated in execution 
campaign results. Other answer types are considered as for information 
only.

Other question/answer types

Other question/answer types exist. You can for example choose to enter a
comment, figures, dates.

 For more details, see the HOPEX Assessment guide, chapter 
"Assessment Templates".

Creating questions

Questions are defined in HOPEX via control steps.

Two types of control step are available:
• Specific control steps: specific to the current control
• Inherited control steps: applicable to all controls

To create control steps corresponding to check-list questions/answers:
1. In the control properties, select the Execution tab.
2. Expand the Control Steps section.

Two subtabs are available:
• Specific Control Steps
• Inherited Control Steps
When defining control steps specific to the current control, you can at the
same time define control steps applying to all controls. 

 In the Inherited Control Steps subtab, only the inherited control 
steps meeting specified conditions and applying to the current control 
appear. For more details on conditions, see “Conditioning questions", 
page 39.

3. In one of the subtabs, click New.
4. In the Title field, enter a question.
5. Indicate the question type, for example "OK/NO".

 For more details on question types, see “Question/answer types", 
page 38.
 You can reorder control steps to define order of appearance of 
questions in the check-list. To do this, click the Reorder button.

6. Click OK.

Conditioning questions 

You can condition presence of a question in a check-list according to certain criteria.
These criteria are defined in the conditions (called MetaTests) applicable to inherited
control steps. 
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Creating conditions on inherited control steps

To create a condition on inherited control steps:
1. In the properties of a control, expand the Control Steps section and 

select the Inherited Control Steps subtab. 
2. Select an inherited control step.
3. In the Condition section that appears, click New to create a MetaTest.
4. Open the properties of the MetaTest created. 
5. Define the Test Expression.

 You can also create the MetaTest in HOPEX Windows Front-End. 
For more details, see article HOPEX Power Studio, HOPEX Studio - 
Publisher guide, "Creating consistency checks", paragraph "Defining 
an implementation test".

6. Click OK.

Managing inherited control steps and their conditions

To access inherited control steps:
 In the Control desktop, select Control Execution > Check-List 

Preparation > Inherited Control Steps.
All control steps present in the solution appear here.

To access conditions applicable to inherited control steps:
 In the Control desktop, select Control Execution > Check-List 

Preparation > Conditions on Control Steps.
 You can connect a condition to an inherited control step in the 
properties of the latter. 

Defining Respondents

On each control you must define persons responsible for completing execution
check-lists.

To do this, you must define control responsibles, that is "Responsibles" in the RACI
sense of the term. 

 For more details, see “Responsibilities", page 30.

Connecting Controls to Entity Processes

Controls are executed in the framework of organizational/business processes,
connected to organization entities.

To connect controls to processes, see “Scoping Controls", page 32.
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PREPARING CONTROL TESTING

To prepare control testing by the internal control team, you can specify a certain
number of characteristics on controls.

You must also create questions that will be used to generate test sheets. To do this,
you must create testing steps.

 For more details on testing functionalities, see “Control testing", 
page 79.

Defining Testing Methods

To specify control test characteristics:
1. In the properties of a control, select the Assessment tab.

The Testing Method section presents characteristics concerning testing.
2. Specify the Testing Frequency:

• Yearly
• Quarterly
• Bi-Yearly

3. Specify the Testing Method:
• Inquiry 
• Inspection
• Observation
• Re-performance

4. Specify the Testing Population Size: the total number of objects that 
could be controlled (for example: 1000 invoices or 100 contracts).

5. Specify the Testing Sample Size: value inherited by test sheets by 
default. 

 For more details, see “Specifying or modifying the sample size", 
page 97.

Defining Test Sheet Questions

You must define testing steps on controls to be able to generate test sheets used
by internal controllers.

You can:
• initialize testing steps from control steps previously defined on the 

control (used for check-lists in the framework of execution campaigns) 
 For more details on control steps, see “Defining questions on 
controls", page 38.

• add, modify or delete testing steps
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Initializing testing steps 
 Control steps must already exist on the control to be able to 
initialize testing steps. For more details on control steps, see “Defining 
questions on controls", page 38.

To initialize testing steps from control steps:
 Click the icon of a control and select Initialize Testing Steps.

 The menu is grayed if testing steps already exist for this control.
Testing steps (specific or inherited) are created from control steps already
existing on the control. 

Creating testing steps

You may need to create testing steps in addition to those automatically created from
control steps.

 For more details on control steps, see “Creating questions", page 
39.

Two types of testing step are available:
• Specific testing steps: specific to the current control
• Inherited testing steps: applicable to all controls

To create testing steps:
1. In the control properties, select the Execution tab.
2. Expand the Testing Steps section.

Two subtabs are available:
• Specific testing steps
• Inherited testing steps
When defining testing steps specific to the current control, you can at the
same time define testing steps applying to all controls. 

 In the Inherited Testing Steps subtab, only the inherited testing 
steps meeting specified conditions and applying to the current control 
appear. For more details on conditions, see “Conditioning test sheet 
questions", page 42.

3. In one of the subtabs, click New.
4. In the Title field, enter a question.
5. Indicate the question type, for example "OK/NO".

 For more details on question types, see “Question/answer types", 
page 38.
 You can reorder testing steps to define order of appearance of 
questions. To do this, click the Reorder button.

6. Click OK.

Conditioning test sheet questions

You can condition presence of a question in a test sheet according to certain criteria.
These criteria are defined in the conditions (called MetaTests) applicable to inherited
control steps. 
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Creating conditions on inherited testing steps

To create a condition on inherited testing steps:
1. In the properties of a control, expand the Control Steps section and 

select the Inherited Testing Steps subtab. 
2. Select an inherited testing step.
3. In the Condition section that appears, click New to create a MetaTest.
4. Open the properties of the MetaTest created. 
5. Define the Test Expression.

 You can also create the MetaTest in HOPEX Windows Front-End. 
For more details, see HOPEX Power Studio, HOPEX Studio - 
Publisher, "Creating consistency checks", paragraph "Defining an 
implementation test".

6. Click OK.

Managing inherited testing steps and their conditions

To access inherited testing steps:
 In the Control desktop, select Testing > Navigator > Test Sheets > 

Inherited Testing Steps.
All testing steps present in the solution appear here.

To access conditions applicable to inherited testing steps:
 In the Control desktop, select Testing > Navigator > Test Sheets > 

Conditions on Testing Steps.
 You can connect a condition to an inherited testing step in the 
properties of the latter. 
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EXECUTING CONTROLS

Controls are executed periodically by process managers, to check that operational processes have
been executed correctly and that their results comply with expectations. 

Controls are executed in their context, by process and entity. They are presented in the form of
check-lists. These check-lists are questionnaires presenting questions on each control. You can
create your own questions, for all controls or for specific controls.

Automatically generated reports allow control execution progress follow-up and consolidation of
results.

 “Execution Campaign Principle", page 46
 “Creating Execution Campaigns", page 48
 “Starting Execution Campaigns", page 51
 “Completing Control Execution Check-Lists", page 54
 “Managing Execution Check-Lists", page 55
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EXECUTION CAMPAIGN PRINCIPLE

Preparing Execution Campaigns

To be able to create an execution campaign, preparatory work is required at the
level of controls. You must:

• connect processes to controls
 See  “Scoping Controls", page 32.

• define control execution calenders
 You must specify a steering calendar on each control to execute. 
See  “Defining Control Execution Calendars", page 37.

• define questions on controls
 You must specify control steps for all controls or for specific 
controls. See  “Defining questions on controls", page 38.

• define check-list respondents, who are control owners for a specific 
entity. 

 See  “Defining Respondents", page 40.

Control Execution Periodicity

An execution campaign groups several execution sessions. 

Each campaign session groups a set of controls to be executed on the same date. 

Several assessment sessions are created in parallel for each steering calendar type
identified. 

For example:

a session is created each week if a weekly steering calendar 
has been specified on certain controls

a session is started each day if a daily steering calendar 
has been specified on certain controls

Controls are therefore grouped in each session according to the steering calendar
to which they have been connected.

See also: “Automatic session start", page 51.

Assessment Template Specific to Control Execution

Execution campaigns are automatic assessment campaigns with a specific
assessment template. 
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The "Control Execution" assessment template is selected by default at execution
campaign creation. This assessment template:

• prompts you to specify an entity. 
• is used to identify controls used by processes attached to this entity and 

its sub-entities.

Check-list respondents are control owners in an entity or in sub-entities.
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CREATING EXECUTION CAMPAIGNS

The execution campaign creation wizard enables definition of campaign scope.

To create an execution campaign:
1. In the Control desktop, click Control Execution > Campaigns > 

Execution Campaigns.
2. Click New.
3. In the creation window that appears, modify the proposed dates if 

necessary.
The campaign Begin Date marks the start of the execution campaign.

 The "Control Execution" assessment template is selected by 
default. For more details, see “Assessment Template Specific to Control 
Execution", page 46.

4. Click Next.
You will now define the scope of your execution campaign.
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5. In the Assessed Parameters field, find the root entity that interests 
you, using the arrows on the right of the field.
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6. In the preview window, click Refresh the Report.
Elements concerning the assessment campaign appear:
• general information: for example begin and end dates, person 

responsible, number of objects to be assessed, number of 
respondents, number of contexts

• assessed objects (controls)
• context objects (entities and organizational/business processes)
• respondents

 Respondents execute controls. For more details on control 
responsibilities, see “Responsibilities", page 30.

• assessment nodes, presenting objects to be assessed in their context, 
with specified respondent

 If no respondent has been specified on the control, or if no e-mail 
address is associated with the respondent, a red frame appears before 
the assessment node.

7. Click OK.
The campaign appears in the list. 

To preview execution campaign scope, before launching the campaign:
 Open the properties of the campaign and select the Preview and 

Parameters tab.
You can check data such as respondent, email, control scope. If data
seems incorrect or incomplete, you can modify it before starting the
campaign. 

 For a reminder on work control execution preparatory work, see 
“Preparing Control Execution", page 37.
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STARTING EXECUTION CAMPAIGNS

When you have created the execution campaign, you must start it via the workflow.

Starting Execution Campaigns

To start the execution campaign:
 In Control Execution > Campaigns > Campaigns, click the campaign 

you want to start and select Automatic Assessment Campaign (In 
Preparation) > Start.

 "(In Preparation)" corresponds to the current status of the 
automatic execution campaign.

The campaign is started automatically:
• on the begin date specified on the campaign
• at the time indicated on the steering calendar

Start of the execution campaign invokes automatic processing enabling planning
and start of sessions.

 A message indicating that parameterization is not complete might 
appear. This is the case when controls of scope are not connected to a 
steering calendar. However you can start the campaign.

Automatic session start 

Execution sessions are started according to: 
• execution campaign begin and end dates
• begin and end dates and recurrences specified on the steering calendar 

of the controls to be executed
 For more details on steering calendars, see “Defining Control 
Execution Calendars", page 37.

When a due date is reached, HOPEX checks:
• that the campaign has not been closed manually
• that the campaign end date is not expired

If both conditions are met, the next session is scheduled.

Example 1

If the begin date specified on the steering calendar is later than the campaign end
date, controls are not executed.

Example 2

On the steering date it is specified that execution is scheduled everyday at 6am.

The campaign is created and the transition is triggered at 10am.
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If the check box Execute at start date/hour is not selected, the campaign is
launched on the morrow at 6am.

 If the check box is selected, a message indicates scheduling in the 
past is not possible. 

Example 3

The check box Execute at start date/hour is selected.

On the execution campaign, the date of the first scheduled execution is later than
today's date (campaign start date).

In that case, the campaign start date corresponds to the launching of the
assessment session. 

Example 4

Example of scheduling on the steering calendar

The following restult is obtained:



53

Executing controls
Starting Execution Campaigns

Consulting execution campaign schedule

To consult dates and times of next execution of a campaign in progress:
 Open the properties of the campaign and select the Automatic 

Execution tab.
The list of timespots defined by the steering calendar appears.

At each timespot, the execution session scope is recreated. This means that if new
controls have been added, they are taken into account at the next planned
execution session.

The End Date indicated on the campaign defines the effective end of the campaign.
For more details on sessions actually launched, see “Automatic session start", page
51. 

 The dates indicated correspond to the scheduled jobs. A new 
session is created at each job execution. The previous session is closed.
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COMPLETING CONTROL EXECUTION CHECK-LISTS

When the execution campaign has started, you can complete check-lists. To do this,
you must connect with a user with the "Business User (IC)" profile.

Completing a Check-List

To complete check-lists addressed to you:
1. Connect with a user with associated role "Business User (IC)".
2. In the desktop that opens, click Home > My Desktop > 

Questionnaires and Check-Lists > My Control Execution Check-
Lists.

3. In the pane on the right, select an element in the list and click Display 
Check-Lists.

4. In the list that appears, select an object to be assessed and answer the 
check-list questions in the lower frame.

5. Select another object to be assessed and answer the questions.
6. Click the Save button.
7. When you have answered all the questions, in the check-list pop-up 

menu click Automatic Assessment Questionnaire (To Be 
Completed) > Complete.

 You can modify answers for as long as you do not click Complete 
in the Check-List pop-up menu.

Transferring a Check-List 

If you receive a questionnaire in error, you can ask the session manager to transfer
the questionnaire to another person.

To make a transfer request:
1. Select Home > My Desktop > Questionnaires and Check-Lists > 

My Assessment Questionnaires.
 In some of the solutions, the corresponding menu is as follows: 
Home > My Desktop > My Responsibilities > My Assessment 
Questionnaires.

2. Click the icon of a questionnaire and select  Assessment 
Questionnaire (To Be Completed) > Transfer Request.
The questionnaire passes to status "To Reassign".
The manager is informed by e-mail and must reassign the questionnaire
to another person. 

 Transfer requests are exceptional if execution campaign creation 
preparatory work has been correctly carried out.
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MANAGING EXECUTION CHECK-LISTS

Accessing Check-Lists

You can view control execution check-lists at any time.

To access check-lists:
 Select Control Execution > Check-List Follow-Up.

You can view check-lists:
• sent in the framework of the campaign
• completed by respondents
• not yet completed

 For more details on content of these lists, see the HOPEX 
Assessment guide, chapter "Running Assessments", paragraph 
"Managing Questionnaires Sent".

Reassigning Check-Lists

If a transfer request has been addressed to you, you must reassign the check-list
to another user.

 For more details on how to transfer a check-list, see “Transferring a 
Check-List", page 54.

To reassign a check-list:
1. Select Control Execution > Check-List Follow-Up > Uncompleted 

Check-Lists.
2. Select a check-list and open its properties.

 For details, see “Reassigning questionnaires", page 75. The 
principle is the same as for assessment questionnaires.

Following Check-Lists Up

Campaign results

For each executed control, HOPEX Internal Control calculates the percentage of
"OK" steps in the total number of steps. This calculation is executed using an
aggregation schema.

 "N/A" answers are excluded from the total number of steps. This 
rule can however be customized.

Check-list reports 

Reports allow you to follow up check-list progress and results. For more details, see
“Control Execution Reports", page 122.
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Displaying check-lists measures

To view check-list measures as well as the corresponding questionnaires:
1. In the properties of a control, select the Execution tab.
2. Expand the Check-list Measures section.
3. Right-click a node to display the questionnaire.

Displaying the aggregated measures

To display measures from aggregation nodes:
1. In the properties of a control, select the Execution tab.
2. Expand the Execution section.

The list of aggregated measures appears.
 Only the functional administrator and the internal control director 
can view this list.
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ASSESSING CONTROLS

Controls can be assessed in terms of their design/efficiency. Assessment can be carried out directly
on controls or remotely via questionnaires.

 This chapter explains how to start assessments. 
To configurer these, see the HOPEX Assessment guide, 
"Assessment Templates" chapter".

 “Direct assessment", page 58
 “Assessing Controls by Questionnaires", page 64
 “Computing Assessment Results", page 77

 HOPEX Internal Control also allows internal controllers and 
auditors to assess questionnaires on site. For more details, see “Control 
testing", page 79.
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DIRECT ASSESSMENT 

HOPEX Internal Control enables direct assessment of controls in terms of design
and efficiency:

• one by one, in the properties page of the control, using measures.
see “Control Direct Assessment", page 58.

• globally, using a multiple assessment table.
see “Assessing multiple controls simultaneously", page 60.

This is an "expert view" assessment.
 You can assess controls for which you have editing rights. For more 
details, see “Modifying Controls", page 35.
 HOPEX Internal Control also enables assessment of risks. For 
more details, see “Risk Assessment", page 62.

Control Direct Assessment

Direct assessment context

Direct assessment is carried out for all context objects available in the Scope
section of control properties:

• Organizational processes
• Business processes
• Entities

 For more details on control contextualization see also “Scoping 
Controls", page 32.

Assessing controls

To directly assess a control:
1. Open the properties of a control.
2. Select the Assessment tab, then click Assess.
3. In the wizard that appears, select nodes to be assessed.

 An assessment node comprises:
• an object to assess
• one or several context objects (entities, processes, operations), if 

necessary
4. Click Next.

You can now select values that characterize this control (contextualized)
in terms of:
• design
• effectiveness

 Other questions can be asked if your administrator has configured 
the questionnaire supplied as standard.
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5. In the Control Design field, indicate whether the control is:
• adequate 
• inadequate 

6. In the Control Effectiveness field, indicate whether the control is:
• effective 
• ineffective 

 Values are applied to all selected assessment nodes.
7. Specify the measure date in the calendar.

By default this is today's date. You can select a date earlier than today's
date.

8. Click OK.
Control measures are created for each assessment node (ie. the control
in a particular context).

You can create several measures on different dates in the same way. As you create
measures, the list can become lengthy. In this case, it can be useful to group
measures by date in order to easily find those that interest you.

 To group by date, click the arrow at extreme right of the header of 
the Date column and select Group by this field.

Consulting assessment answers

The manager can view answers entered by the respondent when performing direct
assessment. He/she can also decide to modify values calculated from these answers
if he/she considers them inappropriate.

To view answers used to calculate assessed characteristics values:
 In the Assessment tab of the assessed object properties, right-click the 

measurement that interests you and select Display Node.
 This menu is not available in the context of multiple assessment.

Answers used as the basis for calculation of values appear. They are in
read-only only.

The responsible/manager can decide to modify values resulting from answers. 



60

4

To modify assessed characteristics values:
1. Open the properties of the assessment you want to modify.
2. Modify values in the Signed Value column for each assessed 

characteristic value.
These values replace values calculated from answers given by the
respondent.

 Initial values are visible in the Calculated Value column.

 The values specified in the Signed Value column are not used in 
reports supplied by default. You can however call a MEGA professional 
to include these values in your questionnaires.

Assessing multiple controls simultaneously

If you have to assess several controls, it can be quicker to use the multiple
assessment table. This table allows you to specify the same value for several
assessment nodes of different controls.

 An assessment node comprises:
• an object to assess
• one or several context objects (entities, processes, operations), if 

necessary

To assess multiple controls simultaneously:
1. Select Control Library > Direct Assessment > Multiple Assessment 

Table.
2. Click Connect Controls to be Assessed.

The wizard that appears proposes a tree of entities to which processes
and controls are attached.
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3. Select an entity.
The tree expands automatically and allows you to select objects assessed
in their context. 
An object is assessed in the context of elements of the branch from the
object up to the root.

In the above example, if you select the "Manage Human 
Resources" process, all controls and context objects 
located at a lower level are selected, as well as all parent 
context objects up to the tree root.

 If you deselect a node of a branch, only the child elements of this 
branch are deselected.

4. Click OK.
The list of controls to be assessed in a particular context appears.

5. In the Control Design field, indicate whether the control is:
• adequate
• inadequate

6. In the Control Effectiveness field, indicate whether the control is:
• effective
• ineffective

7. When values have been specified, select the assessed nodes and click 
Validate Assessment.
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8. Modify the effective measure date  if necessary and click OK.
 By default the measure date is today's date. You can select a date 
earlier than today's date.

The Control Level is automatically calculated from the specified
characteristics.

 The control level shows "Pass" if the control is considered to be 
both:
• effective
• adequate

Validation automatically creates an assessment in the Assessment tab
of the control properties.

Assessing controls on different dates

You can at any time decide to assess controls that have already undergone a first
assessment. 

To reassess controls in their context:
1. Select Control Library > Direct Assessment > Multiple Assessment 

Table.
2. Click Connect Controls to be Assessed.
3. Select from the proposed tree the assessment nodes previously 

assessed.
 For more details, see “Assessing multiple controls simultaneously", 
page 60.

A dialog box asks you to reselect controls to be assessed.
4. Select Yes.

The previous values corresponding to each assessment node are
proposed.

5. Keep these previous values or modify them as required, then click 
Validate.

6. Enter a date for the new measure and click OK.
The most recent measure values appear in the multiple assessment table.

The different control measures appear in the Assessment tab of the properties of
each control.

Risk Assessment

You can create risk measurements to globally assess a risk on a set of objects of the
organization to which it is connected (entities and processes).

To create a risk measurement:
1. Select a risk and open its properties.
2. Select the Assessment tab.
3. Click the Evaluate button.
4. In the wizard that appears, select nodes to be assessed.

 An assessment node comprises:
• an object to assess
• one or several context objects (entities and processes), if 

necessary



63

Assessing controls
Direct assessment

5. Click Next.
You can now select values that characterize this risk (contextualized) in
terms of:

• Impact: characterizes impact of the risk when it occurs.
• "Very Low"
• "Low"
• "Medium"
• "Very High"
• "High"

• Likelihood: characterizes probability that the risk will occur.
• "Rare"
• "Possible"
• "Likely"
• "Probable"
• "Certain"

6. Specify the risk measurement date.
7. Click OK.
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ASSESSING CONTROLS BY QUESTIONNAIRES

HOPEX Internal Control enables assessment of your controls using standard
questionnaires. 

The assessment questionnaires are sent to appropriate respondents.

Assessment Principle

 Assessment is a mechanism enabling sending of questionnaires to 
an identified population to obtain assessments (qualitative or 
quantitative) on identified objects. The assessment is then 
supplemented by results analysis tools.

Concepts overview

Assessment session
 An assessment session is an assessment carried out over a 
determined time period. When an assessment session is published, a 
questionnaire is sent to targeted users.

Questionnaire

Assessment  questionnaires are sent to appropriate respondents.
 A questionnaire proposes a list of predefined questions that can be 
applied to a control.

Assessment campaign

With HOPEX Internal Control, an assessment session is started in the context of
an assessment campaign.

 A campaign enables grouping of several sessions.

Assessment Steps

Preparing the work environment

Before starting an assessment campaign, you must first prepare the work
environment. Check that you have:

• connected controls to processes 
See “Scoping Controls", page 32.

• connected processes to organization entities
See “Connecting Environment Objects", page 16.

• defined questionnaire respondents and specified an e-mail for each
See “Specifying control responsible users", page 30.
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Starting a campaign and assessment sessions

For an example of the different steps in starting an assessment campaign, see
“Steps of assessment workflow with campaign", page 44.

 To discover all the possibilities offered by HOPEX, see “Workflows 
Linked to Assessments", page 142.

 “Creating Assessment Campaigns", page 65
 “Creating Assessment Sessions", page 67
 “Deploying Assessment Campaigns", page 68

 Deploying the assessment campaign is optional. If you are not 
deploying the assessment campaign, go directly to “Validating 
Assessment Campaigns", page 70.

 “Defining assessment campaign scope", page 69
 “Planning Assessment Campaigns", page 69
 “Validating Assessment Campaigns", page 70
 “Deploying Assessment Sessions", page 70
 “Defining assessment session scope", page 71
 “Validating Assessment Sessions", page 71
 “Starting Assessment Sessions", page 72

 It is not necessary to manually execute deployment, validation and 
launch if you choose to launch the assessment session immediately 
after you created it or if you schedule it from the creation wizard. See  
“Variations in the Launch of Assessment Sessions", page 21.

When assessment sessions have been started, you can proceed with the following:
 “Completing Questionnaires", page 73
 “Following Up Session and Questionnaire Progress", page 74
 “Closing the assessment session", page 76

Creating Assessment Campaigns

 A campaign enables grouping of several sessions.

You can create an assessment campaign:
• From a template

Creating a campaign from a template allows:
• use of the same template in all assessment sessions.
• definition and planning of sessions by distributing elements to be 

assessed between different sessions.
• without a template

In the case of creation of a campaign without using a template, a template
can be specified at the time of creation of each session.

 This section presents assessment campaign creation using the 
"Control Assessment" assessment template supplied as standard. 
Possibilities offered by assessment campaigns without using a template 
are described in the HOPEX Assessment guide.
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To create an assessment campaign:
1. In the Control desktop, select Assessment Campaigns > Campaigns 

> Campaigns > Campaigns.
The list of campaigns appears in the edit area.

2. Click New.
The campaign creation page appears.

3. In the Campaign Type field, select "With Template".
4. Select the "Control Assessment" Assessment Template.
5. Modify the Calendar if required.

 The calendar serves to initialize begin and end dates of the 
assessment campaign. 

6. Specify the Begin Date and the End Date.
7. Click Next.
8. In the Scope Selection page, select an entity.

 The tree automatically expands if the Automatic Expand box is 
selected.

The tree allows you to select controls assessed in their context. 
An object is assessed in the context of elements of the branch from the
object up to the root.

In the above example, if you select the "Manage Human 
Resources" process, all controls and context objects 
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located at a lower level are selected, as well as all parent 
context objects up to the tree root.

 If you deselect a node of a branch, only the child elements of this 
branch are deselected.

9. Click Next.
10. In the preview window, click Refresh the Report.

Elements that will be assessed appear.
In particular, you can view:
• assessed characteristics (defined in the assessment template)
• assessed objects (controls)
• context objects (processes or entities)
• assessment nodes which correspond to controls placed in their context 

objects, associated with respondents.
11. Click OK.

Creating Assessment Sessions

 An assessment session is an assessment carried out over a 
determined time period. When an assessment session is published, a 
questionnaire is sent to targeted users.

Creating Assessment Sessions 

To create an assessment session:
1. Open the properties of the campaign and select the Sessions page.
2. In the Assessment Sessions section, click New.

You may choose to launch the assessment session later, without
specifying when.

3. To do this, in the session launch window, select “not now”
 This option enables you to complete the assessment session with 
data, for example with the session owner and the assessment dates. In 
the framework of an assessment campaign with template, the session 
template is specified by default. It cannot be modified. For more details 
on creation of assessment sessions without template (ad-hoc or 
advanced mode), see “Creating Ad-Hoc Assessment Sessions", page 25 
or “Creating Expert Assessment Sessions", page 27.
 You may choose to launch the assessment session now or to 
schedule it. See  “Creating and launching assessment sessions", page 
68. 

4. Click the Save button.
5. You can create other assessment sessions in the same way.

 The assessment sessions created will be used to plan the 
assessment campaign, that is to distribute between the different 
assessment sessions the objects to be assessed in their context. See  
“Planning Assessment Campaigns", page 69.

Viewing Assessment Sessions

To view assessment sessions with planned assessment dates in a Gantt chart:
 In the properties of an assessment campaign, select the Sessions tab 

and expand the Gantt section. 
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Creating and launching assessment sessions

See  “Creating Assessment Sessions", page 67.

You may create an assessment session and choose to launch it:
• "now”

If you choose this option, you will be able to see the assessment session
being launched. This option enables to execute the following workflow
transitions at the same time:
• deploy: “Deploying Assessment Sessions", page 70
• validate: “Validating Assessment Sessions", page 71
• start: “Starting Assessment Sessions", page 72

• after saving, in batch mode (“as soon as possible”)
• later, specifying the date and hour in UTC format (“planned”)

Deploying Assessment Campaigns

Deploying an assessment campaign consists of indicating in advance the objects to
be assessed at the level of each session of the campaign.

 This step is optional. If you are not deploying the assessment 
campaign, go directly to “Validating Assessment Campaigns", page 70

To deploy a campaign:
1. In the list of campaigns, click the icon of the campaign you created and 

select Assessment Campaign (In Preparation) > Deploy.
2. In the deployment window, indicate that you want to deploy the 

campaign now.
 A window asks if you want to deploy the campaign:
• now
• as soon as possible (after dispatch)
• at a later date

3. Click OK.
Assessment nodes are created. 

 An assessment node comprises:
• an object to assess
• a respondent (or an assignment, which is a respondent associated 

with a particular profile)
• one or several context objects if necessary (entities and processes)

You can now define assessment campaign scope. See  “Defining assessment
campaign scope", page 69.
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Defining assessment campaign scope

Having deployed the assessment campaign, you must:
• define the scope, that is select the assessment nodes you want to include 

in your campaign.
• specify respondents.

 For more details on assessment nodes, see “Deploying Assessment 
Campaigns", page 68

Defining assessment campaign scope

To define campaign scope:
1. In the properties of the campaign, select the Effective Scope tab.

The list of assessment nodes from your deployment appears. 
2. Select the values you want to remove from the campaign and click the 

Unvalidate button.

Specifying respondents

To add or modify respondents:
 Select the elements that interest you and click Set Respondent.

Planning Assessment Campaigns

When campaign scope has been defined and assessment sessions created, you can
plan the campaign.

This consists of distributing assessments between the different assessment
sessions.

To plan the campaign:
1. In the properties of the assessment campaign, select the Planning tab.

 The Planning tab is visible only when assessment sessions have 
been created.
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2. In the right pane, select the assessment sessions in which you want to 
assess which control in its context (process or entity).

 If you don't see the previously created assessment sessions, click 
the Refresh button.

 Respondents are specified at step “Defining assessment campaign 
scope", page 69.

Validating Assessment Campaigns

When you have planned the assessment campaign, you can validate it.

The effect of assessment campaign validation is to freeze its parameters (for
example scope or planning).

To validate the campaign:
 Click the campaign icon and select Assessment Campaign (In 

Preparation) > Validate.

You can now prepare start of assessment sessions.

Deploying Assessment Sessions

Having planned and validated your campaign, you can deploy assessment sessions.

Deployment enables computing of all possible assessment nodes for the session. 
 An assessment node comprises:
• an object to assess
• a respondent (or an assignment, which is a respondent associated 

with a particular profile)
• one or several context objects if necessary (entities and processes)

The session manager can then review this list.



71

Assessing controls
Assessing Controls by Questionnaires

To create the list of assessment nodes of a session:
1. Open the properties page of the campaign and select the Session tab.
2. In the Assessment Session section, right-click the session that 

interests you and select Assessment Session (In Preparation) > 
Deploy.

 An intermediate window asks if you want to execute the 
deployment now, as soon as possible (after dispatch) or at a scheduled 
date.

This operation can take several minutes.

Defining assessment session scope

Having deployed the assessment session, you can:
• define the scope, that is select the assessment nodes you want to include 

in your session.
• specify respondents.

 If you have defined the scope on the assessment campaign, you do 
not necessarily need to redefine it on the assessment session. For more 
details, see “Defining assessment campaign scope", page 69.

Defining assessment session scope

To access the list of calculated assessment nodes:
 Open the properties of the assessment session and select the Effective 

Scope tab.
From this list you can duplicate, validate, invalidate or delete elements to
be assessed, and assign a respondent.

Specifying respondents

To add or modify respondents:
 In the Effective Scope tab of session properties, select the elements 

that interest you and click Define Respondent.

Validating Assessment Sessions

The effect of assessment session validation is to generate questionnaires, without
however sending these to addressees. 

Generating questionnaires

To generate questionnaires:
1. Open the properties page of the campaign and select the Session tab.
2. In the Assessment Session section, click the session that interests 

you, then Assessment Session > Validate.
All questionnaires are created with status "To send". This operation can
take several minutes. 
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You can now view questionnaires that have been generated.

Viewing Generated Questionnaires

To view generated questionnaires:
1. In the properties of an assessment session, select the Questionnaires 

tab.
2. Select the row relating to the assessment session and click Display 

Questionnaires.
3. Open each of the questionnaires to display the associated assessment 

nodes and questions.
 If questionnaire presentation is unsatisfactory, the functional 
administrator can modify it at this stage. 
For more details see the HOPEX Assessment guide, "Assessment 
Template" chapter. 
In the solution, questionnaire templates are available in the tab 
concerning campaign management > Preparation > Questionnaire 
Templates.

The questionnaire supplied as standard for the "Control Assessment" assessment
template proposes questions concerning:

• control efficiency/design level 
• possible improvements

 At this stage you can still modify presentation of questionnaires. 

 It is recommended that the assessment session be validated just 
before starting the session. If you validate too early, information 
concerning respondents could be incorrect.

Regenerating Questionnaires

You may need to regenerate the questionnaires if for example you decide to modify
respondents before starting the assessment session. 

To regenerate questionnaires:
 Right-click the assessment session concerned and select Assessment 

Session (To Start) > Regenerate Questionnaires.

Starting Assessment Sessions

The effect of starting an assessment session is to send questionnaires to
respondents.

To send questionnaires to respondents:
1. Select  Assessment Campaigns > Campaigns > Campaigns.

The list of campaigns appears in the navigation tree.
2. Select the campaign that interests you and click Properties.

Properties of the campaign appear in the edit area.
3. In the Sessions section, click the session that interests you, then 

Assessment Session > Start.
The session activation page appears.
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4. Click the Save button at top of the page.
The assessment questionnaires are sent to respondents defined in the
assessment session perimeter. 

 A questionnaire proposes a list of predefined questions that can be 
applied to a control.

Completing Questionnaires 

The steps described here concern questionnaire respondents.
 For more details on questionnaire processing steps, see 
“Questionnaire Generic Workflow", page 111.

Accessing Assessment Questionnaires

After starting an assessment session, questionnaire addressees receive a
notification.

To complete questionnaires:
1. Select Home > My Desktop > Questionnaires and Check-Lists > 

My Assessment Questionnaires.
The list of questionnaires to be completed appears.

2. Select the questionnaire that interests you and click Display 
Questionnaire.

3. Select the questions and reply to these in the lower part of the window.
4. Click Save.
5. Close the questionnaire display window.
6. Click the questionnaire in the questionnaires list and select Assessment 

Questionnaire (To Be Completed) > Submit Answers.
 Questionnaires are visible from this menu as long as the 
assessment session is not closed. If the assessment session is closed, 
you can consult them in the Questionnaires tab of the assessment 
session.

Requesting questionnaire transfer

If you receive a questionnaire in error, you can ask the session manager to transfer
the questionnaire to another person.

To make a transfer request:
1. Select Home > My Desktop > Questionnaires and Check-Lists > 

My Assessment Questionnaires.
 In some of the solutions, the corresponding menu is as follows: 
Home > My Desktop > My Responsibilities > My Assessment 
Questionnaires.
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2. Click the icon of a questionnaire and select  Assessment 
Questionnaire (To Be Completed) > Transfer Request.
The questionnaire passes to status "To Reassign".
The manager is informed by e-mail and must reassign the questionnaire
to another person. 

 Transfer requests are exceptional if execution campaign creation 
preparatory work has been correctly carried out.

Following Up Session and Questionnaire Progress

Consulting Session Results

To consult progress of an assessment session:
 Open the properties of the assessment session and select the Reports > 

Follow-Up tab.
 For more details on this report, see “Campaign Result Tree", page 
125.

Validating Assessment Questionnaires

To access the list of assessment questionnaires completed by respondents:
1. In the Control desktop, select Assessment Campaigns > Campaigns 

> Questionnaire Follow-Up > Answered Questionnaires.
The list of completed questionnaires appears. 
Note that workflow status has passed to "To Be Validated".

2. Select the questionnaire that interests you and click Display 
Questionnaires.
Content of the questionnaire appears in a new tab. You can view answers.

3. Close the questionnaire display window.
4. If you consider that the questionnaire has been correctly completed, click 

its icon and select Assessment Questionnaire (To Be Validated) > 
Validate.
The questionnaire is closed and results are automatically calculated.

Asking a respondent to modify answers

If answers to a questionnaire are not suitable, you can ask the respondent to modify
these.

To make a modification request:
1. Click Assessment Campaigns > Campaigns > Questionnaire 

Follow-Up > Answered Questionnaires.
2. Click the icon of a questionnaire and select Assessment Questionnaire 

(To Be Validated) > Ask For Modification.
 The respondent can modify his/her answers. See  “Completing 
Questionnaires", page 73.
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Viewing assessment campaign reports

Reports specific to assessment campaigns are available. For more details, see
“Control Assessment Reports", page 125.

Reassigning questionnaires

If a respondent has made a transfer request, you must reassign the questionnaire.

To reassign a questionnaire:
1. From the list of questionnaires sent, select a questionnaire.

 The questionnaires are accessible from different menus according 
to the desktop used:
• With the MEGA solution, you can access the questionnaires using 

the Campaign Management navigation tab.
• On the assessment questionnaire laptop, the questionnaires are 

accessible from the My Questionnaires navigation pane.
2. Open the properties dialog box of the questionnaire concerned and select 

the Reassignment tab.

 This tab only appears when the questionnaire has "To Reassign" 
status.

3. Select all nodes to be assessed and click the Reassign button.
4. Using the search page that opens, select a questionnaire and click OK. 

 If person assignments have been specified (for example, the 
questionnaire should be sent to a person in the context of a business 
role in particular), you can reassign the questionnaire in the section 
provided for this purpose.

The new respondent appears in the Correspondent column.
5. Select the icon of the questionnaire and select Assessment 

Questionnaire (To be Reassigned) > Reassign.
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The new respondent receives an e-mail. He/she can complete the questionnaire,
status of which is again "In Progress", then submit answers.

Closing the assessment session

You can close the session at any time.

To close an assessment session:
1. Open the properties page of the campaign and select the Session tab.
2. In the Assessment Session section, right-click the session that 

interests you and select Close.
All questionnaires are automatically closed. This operation can take
several minutes.

 Results are valid only if the session is closed.
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COMPUTING ASSESSMENT RESULTS

 For more details on aggregation, see “Aggregation Schemas", page 
100.

For MetaAttribute update, the value of the most recent assessment is taken into account
(direct assessment or through campaign).

Metaattribute Computed / Not 
Computed Explanations

Control Design (IC) Computed through the 
[Internal Control - Control 
Attributes] macro

- if assessment node, value computed 
from the assessed characteristic "Control 
Design" (IC).

- if aggregation node, value computed 
from assessed characteristic "Average per-
centage of Pass Control Level".

Control Effectiveness 
(IC)

Computed through the 
[Internal Control - Control 
Attributes] macro

- if assessment node, value computed 
from the assessed characteristic "Effec-
tiveness”.

- if aggregation node, value computed 
from the assessed characteristic "Average 
percentage of Pass Control Level".

Control level (IC) Computed through the 
[Internal Control - Com-
puted Control Attributes] 
macro

Rounded result obtained from the formula:
Control Design (IC) * Control Effectiveness 
(IC)

Control Execution 
Value (IC)

Not computed
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CONTROL TESTING

Control tests can be carried out to complement operational management reviews. These tests
consist of carrying out an internal audit on controls.  HOPEX Internal Control allows internal
controllers to:

 execute tests on site by completing test sheets
 assess these executed tests
 assess controls in terms of design and efficiency by means of questionnaires.
 implement action plans to improve controls for which issues have been identified
 complete expense sheets and time sheets

The testing process consists of three phases:

 “Preparing Tests", page 80
 “Executing Tests", page 95
 “Test Follow-Up", page 105
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PREPARING TESTS

Functionalities described here essentially concern the internal control director or the
functional administrator. 

The lead controller intervenes to define the work program, which enables:
• execution of test activities 
• assessment of controls by means of questionnaires 

Preparation of tests consists of creating a test plan and tests, and planning these
before controllers intervene in the field.

To prepare tests:
 In the Control desktop, select Testing > Preparation.

Creating a Test Plan 

The test plan is prepared by the internal control director.

The plan is generally defined on a period of one year. This plan contains all tests to
be executed in the year. 

 An audit or test plan is the description of the scope and planning of 
audits or tests executed in the framework of this plan. It is carried out in 
accordance with standards and practices. It comprises a description of 
the approach and the planning schedule. It comprises several audits or 
tests carried out during a given period.
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To create a plan:
1. In the Control desktop, select Testing > Preparation > All Plans.
2. In the dialog box that appears, click the New button.

The new plan appears.
3. Open the properties of the plan.
4. In the Characteristics tab, modify the Name of the plan.
5. Select the Nature of the plan:

• Audit
• Test
• Mixed

 If you have only the HOPEX Internal Control solution, the plan 
nature is automatically specified and cannot be modified. 
 Depending on the selected nature, a Tests and/or Audits tab 
appears in the properties of the plan.
 If you selected "Test" or "Mixed" values, an assessment campaign 
is created at validation of the plan. This will enable generation of 
questionnaires to internal controllers for assessment of controls. For 
more details, see “Assessing Controls", page 98.

6. Select the Calendar of the plan. 
7. Modify the Begin Date and the End Date if necessary.

 The Status is defined automatically by the workflow.
8. Click Save.

The plan is created. 

You can now create tests directly in the plan page. 

Planning Tests

Tests are planned by the internal control director.
 A test is assigned to a controller in the framework of a plan.

Creating a test

To create a test:
1. Click Testing > Preparation > All Plans.
2. Open the properties of the plan that will include the test to be created.
3. Click Tests.
4. Click New.

The new test appears under the plan. 
 To define characteristics of the test, see “Defining test properties", 
page 82.
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Accessing tests

To access tests of a test plan:
 Click Testing > Plans and expand a plan.

The tests (or audits, depending on the plan nature selected) 
corresponding to the plan appear. 

 You can also access the list of tests via the menu Testing > 
Preparation > All Tests.

Defining test properties

You can specify certain information on tests.

General characteristics

General characteristics of the test are:
• Name: test name.
• Code: you can assign a code to the test.
• Included in the Initial Plan: this attribute is defined automatically 

according to plan status at the time of creation of the test. It indicates if 
the test was present at plan creation, or if it was added later.

• Entity controlled
• Lead Controller: lead controller name.
• Main Control Correspondent
• Objective of the test.
• Category of the test: 

• "Compliance"
• "Efficiency"

• Status: this attribute is defined automatically and modified at workflow 
transitions.

Justification and workload

In this section you can enter the following characteristics:
• Justification of the test
• Origin: follow-up, specific, recurrent, etc.
• Priority: priorities can be specified for tests. You can select tests to be 

integrated in the plan based on this priority criterion.
• Estimated Duration (days).
• Estimated Number of Resources 
• Estimated Workload 

 The following characteristics are automatically calculated:
• Effective Workload (Hours): calculated from the effective 

workload defined on time sheets or on activities if no time sheet 
has been entered.

• Estimated Number of Resources 

Scope

You can connect business or organizational processes to the test.



83

Control testing
Preparing Tests

These can be used to automatically generate the test work program . 
 For more details, see “Creating work programs automatically", 
page 90.

Summary

In Summary of the completed test, you can indicate:
• Its Key Strengths
• Its Key Weaknesses
• Evaluation: good overall level, can be improved, etc.

Milestones

In the Milestones section, you can indicate a Planned Begin Date and a Planned
End Date. These dates constitute audit milestones.

 You can choose to enter milestones at a later stage.

Users

In the Users section, you can specify test participants:
• Test Controller: controllers having been previously defined, you can 

connect but not create controllers. See  “Assigning resources to tests", 
page 87.

• Person tested
• Other Participant in Test (for information only)

Skills

You can specify skills required by controllers to execute tests.

To define skills required for the test:
 In the Skills frame, click New or Connect to create a skill or connect an 

existing skill.

When assigning controllers to a test, you will be able to compare skills of controllers
with skills required for the test. For more details on the report providing this
information, see “Assigning a resource to a test", page 87. 

Creating "template" tests

"Template" tests are work programs specially prepared to be applied to new tests. 

This status is exclusively reserved for tests of a plan which is itself defined as a
template. It applies automatically to existing tests of the template plan, and is
proposed at creation of a new test on this same plan. 

To define a test plan as a template:
1. Click Testing > Preparation > All Plans.

The list of plans appears in the edit window.
2. Click the icon of the plan in question and select To Be Validated > Set 

As Template.
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Selecting tests to be executed

HOPEX Internal Control provides the internal control director with decisional help
in selecting tests to be executed. 

You can sort tests according to certain criteria, in order to:
• view previous tests
• find tests planned but not finally executed

Viewing the test coverage report

HOPEX Internal Control supplies a report providing information on the number of
tests executed on each entity between two dates. It indicates entities that require
testing, and enables generation of the corresponding tests.

To access this report:
1. Click Testing > Decisional Reports > Entity Coverage.
2. In the edit window, select a begin date and end date.
3. If required, select the score obtained by the test or its status.

4. Refresh the report by clicking the Refresh button  at the bottom of 
the report.

For each tested entity the report presents: 
• The number of tests executed between the two dates (effective begin 

and end dates)
• The name of the last test
• The end date of the last test (effective end date), or its state if it is still in 

progress
• The score of the last test

To generate tests corresponding to one or several entities:
 Select the entity or entities that interest you and click the Generate 

Tests button.
A wizard asks you to choose a plan. The tests are generated.

Consulting test histories

Consulting the history of tests can simplify your choice of tests to be executed. 

In the list of tests of a test plan, you can consult assessments of the test.

You can sort tests based on this criterion, allowing you to create tests on appropriate
entities.

To group tests by assessment:
1. In menu Testing > Plans, select the test plan that interests you and 

click Properties.
Test plan properties appear.

2. Click Tests.
The list of tests in the plan appear.
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3. Click the "Evaluation" column title.
 If the column does not appear, you can display it using the arrow 
located at extreme right of a column header. 

Tests are then sorted by this criterion.
An arrow associated with the column enables ascending or descending
sort order.

Consulting tests not executed

Tests can remain in "Published" status never to be executed, due to another test
being of higher priority. 

Tests published or in progress can also be canceled via the workflow.

Grouping tests by status enables identification of those that must be recreated on a
subject. 

To find tests not executed of a previous test plan:
1. In menu Testing > Plans, select the plan that interests you.

Properties of the plan appear with the list of tests it contains.
2. Click the "Status" column title.

Tests are then sorted by this criterion.
An arrow associated with the column enables ascending or descending
sort order.

Test assessment and status are defined in its properties. For more details, see
“Defining test properties", page 82.

Viewing previous test expenses

A report allows you to view expenses of previous audits.

To access this report: 
1. Click Testing > Decisional Reports > Expenses Report.
2. (Mandatory) Select a Plan.
3. (Optional) Specify parameter values that interest you from among:

• audits
• expenses categories
• controllers

 If you do not select a value for tests/categories/controllers, all 
tests/categories/controllers of the plan are taken into account.

Selecting tests to be integrated in the test plan

Tests can be created. They are not active until validated. These tests are accessed
from menu Testing > Preparation > Potential Tests. Certain are part of the
definitive plan, while others are discarded.

HOPEX Internal Control proposes tools simplifying selection of tests to be
integrated in the plan.

Discarding tests

Potential tests considered of low priority can be discarded via the workflow.
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To discard a test:
1. Click Testing > Preparation > Potential Tests.

The list of potential tests is displayed in the edit area.
2. Click the icon of the test to be discarded and select To Be Validated > 

Discard. 

The test is discarded but not deleted. It could serve as a template for a new test the
following year.

Validating tests 

You can validate tests:
• globally, at validation of the test plan
• individually

Validated tests:
• disappear from the Testing > Preparation > Potential Tests menu.
• appear in the Testing > Preparation > Tests to be Published menu.

Planning tests using a Gantt chart

A report allows the internal control director to plan the different tests of a test plan. 

To display this report:
1. Under Testing > Plans, select the plan in question.

The plan properties appear in the edit area.
2. In its properties select the Schedule tab.

A Gantt chart describes tests of the plan.

By default, planning relates to the current year, but you can view audits over a more
precise period.

You can redefine the Gantt chart display period:
• by selecting a calendar period. 
• or specific begin and end dates.

You can modify test dates in the diagram:
• by moving the period begin or end dates using the mouse.
• by clicking the center of the period and by moving the mouse to 

simultaneously move the begin and end dates.

Zoom and reframing functions at the right of the chart allow you to customize
display.

 Zoom in on calendar

 Zoom out

 Reframing
 You can also zoom within the Gantt chart using the mouse wheel.

You can add tests from this chart.
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Assigning resources to tests

Before assigning a resource to a test, you can view its availability and skills.

Viewing resource availability 

To view resources available with necessary skills for a test:
1. Open the properties of the test plan concerned.
2. Select the Assign Resources tab.

By default, the report presents tests of the test plan over the year. You
can display those of a particular period.

3. In the table at top left, select a test.
4. In the table at top right, select a resource of which you wish to display 

availability.
 You can select several resources.

5. In the lower frame "Assign Resources", click the Refresh button .

Two charts present:
• Skills required by the test and skills of the selected resource.
• Availability of the resource on test dates. 

The color of the test period depends on the number of resources assigned
to it related to the estimated number of resources:
• Green if the test has a sufficient number of resources
• Orange if resources are insufficient
• Red if no resources are assigned

 These two charts should be refreshed separately.

Assigning a resource to a test

To assign a resource to a test:
1. In the Assign Resources tab of the test plan properties, in the top left 

frame, select the required test.
2. In the frame at top right, select a person.
3. Click the Assign button.

 To remove a controller from the test, carry out the same 
procedure, but click the Unassign button.

Specifying a lead controller for a given test

To specify the lead controller on a test:
1. Open the properties of the test concerned.
2. Specify the Lead Controller field.

Sending the Notification Letter

After having completed the specifications required for execution of a test, the
internal control director can send a notification letter informing controlled persons
of the test.

 For more details on participants, see “Users", page 83.
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Sending this notification letter is not included in the workflow. It precedes the next
step in the workflow which consists of publishing the test. See  “Publishing tests",
page 88.

Creating notification letters

To create the test notification letter:
 Click the icon of the test and select Deliverables > Notification Letter.

A message asks if you want to open or save the file. The document
presents the comment entered in characteristics of the test.

When the document has been saved, you can open and modify it. 

You can also connect it to the test as a business document, under the "notification
letters" category.

Connecting the notification letter to the test

The file is generated from test content, but is not connected by default to the test. 

To connect the notification letter to the test and make it a business document:
1. Open properties of the test.
2. Select the Documents tab.
3. Click the New button.

The Creation of Business Document dialog box appears.
4. Indicate the business document name.
5. In File Location, click the Browse button.

The File Location dialog box appears.
6. Click Browse and select the file.
7. Click Upload.
8. In the document creation dialog box, in Document Pattern, select 

"Notification Letter".
9. Click OK.

The document appears in the list of documents attached to the test.

Validating tests

When the internal control director decides that a test should be executed as part of
the test plan, he/she validates the test.

 An assessment session is created. This will enable generation of 
questionnaires to internal controllers for assessment of controls. For 
more details, see “Assessing Controls", page 98.

Publishing tests

HOPEX Internal Control enables preparation of tests and only making these
public to controllers when planning is completed.

To access the list of tests to be published:
1. Click Testing > Preparation > Tests to be Published. 

They are status "In Preparation".

To make a test public:
1. Right-click the icon of the test.



89

Control testing
Preparing Tests

2. Select To Be Published > Publish.

Test status changes to "Published".

Having been published, tests appear in the work program of controllers.

Preparing Tests

Supervision of test progress is assured by the lead controller. In the test preparation
phase, he/she establishes the work program and assigns activities to controllers.

Work program creation prerequisites

So that the work program can be generated:
• processes (organizational or business) must be connected to the entity
• controls must be connected to processes

Work program content

HOPEX Internal Control enables automatic creation of a work program structure
from:

• the tree of processes connected to the entity, or
• the processes specified in the test scope

 If no process has been specified in the test scope, all processes 
connected to the entity will appear in the work program.
 To connect processes to an entity, see “Scoping Controls", page 32.

 The entity is represented by the test.

Test theme

A theme corresponds to a process.

Themes can be used to group test activities and workpapers, that is to organize test
content. 

Test activity

A test activity corresponds to a control.

It is the basic element of the test. It enables assignment of responsibility to the
controller. 

Environment objects Objects created in the 
work program

Process (organizational or business) Test theme

Control (connected to process) Test activity
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Workpaper

A workpaper comprises points to be checked on a given subject in the course of an
audit or test activity.

A workpaper is generated for each generated test activity. For more details, see
“Creating workpapers", page 96.

Creating work programs automatically

To create a work program automatically:
 Click the icon of the test and select Generate Work Program.

This command will duplicate the tree of processes for the entity in the
scope of the test.

If processes are explicitly specified in the test scope, only these processes will be
automatically generated in the work program structure.

Completing the work program manually

The lead controller can complete the test manually to specify its content. He/she can
add or remove themes/activities in the Work Program tab of the test.

 From this tree, the controller can create workpapers and issues. For 
more details, see “Executing Tests", page 95.
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Creating themes

To create a theme:
1. In the properties of a test, select the Work Program tab.
2. Click the icon of the test and select New > Test Theme.

The theme created appears in the tree of the work program.
3. Display properties of the theme.

You can:
• modify its name
• select a parent test theme (if you want to create a tree of themes)
• connect the test theme to a process
• enter a comment

4. Click OK.
You can view the tree of themes and sub-themes created. You can now
create activities and workpapers. 

Creating activities

A test activity is a test element relating to a control. 

To create an activity:
1. In the properties of a test, select the Work Program tab.
2. Click the icon of the test (or theme) and select New > Test Activity.

The activity created appears in the tree of the work program.
3. Display properties of the activity.
4. Enter the name of the activity.
5. Connect the activity to a Theme if you want the activity to be located 

under a theme in the tree.
6. Connect the test activity to a control.
7. Select the Owner of the test activity, who can be a controller or the lead 

controller of the current test.
8. Indicate the Estimated Workload.

 You can later manually enter the effective workload on this activity.
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9. Click OK.

Assigning activities 

For each activity, the lead controller specifies:
• Start and end dates
• Estimated workload
• Controller responsible for execution

To enter this data:
1. In the properties of the test, select the Activities tab.
2. Open the properties of the test activity concerned.
3. In the Test Activity Owner field, using the right-pointing arrow, select 

a controller from among the candidate controllers.
4. Enter test activity start and end dates.
5. Specify the workload.

Reviewing the work program

The lead controller can proceed with a report on the work program. This report
enables a check that:

• task assignment has been correctly carried out
• the work program covers the appropriate risks and processes

Consulting the work program report

To access work program reports: 
 In the page of a test, select Reports > Work Program.

You can view:
• comparison of resources allocated and resources available: 
• workload (in person/days)
• workload by theme (in person/days)
• activities by theme

Exporting the workload under Excel

The work program under Excel covers themes, sub-themes, activities and
workpapers.

Having the work program available under Excel allows:
• consultation of the complete work program without having to access 

objects individually
• storage of a printed version of the work program
• viewing tasks to be executed at indication of an issue

To export the work program:
 In the test page, Work Program tab, right-click the tree root and select 

Deliverables > Export Work Program (Excel).
 A pop-up window opens at the bottom of the page. If your 
navigator blocks these windows, you cannot see file export. In this case, 
deactivate pop-up blocking in the navigator.
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You can then modify the work program in Excel.

When the work program has been modified, you must create a business document
in HOPEX Internal Control and reimport the modified work program.

To create the business document corresponding to the modified work program: 
1. In the properties of the test, select the Documents tab.
2. Click the New button.
3. Enter the name given to your work program.
4. Select the location where you stored the modified Excel file and click 

Upload.
5. Select the "Work Program" document template.
6. Click OK.

The modified work program is now stored in the HOPEX repository.

Validating work programs

When the lead controller validates the work program via the workflow, an
assessment session is automatically created and connected to the test. Assessment
questionnaires are generated and made available from test activities. Respondents
are owners of test activities.

 For more details, see “Assessing Controls", page 98.

To validate the work program:
 Click the icon of the test and select To Be Validated > Validate.

Executing administrative tasks

Planning resources

Auditors/controllers can be assigned to different audits/tests at the same time. It is
therefore important to enter the time allocated for each auditor/controller to an
audit/test. 

To indicate for each auditor/controller the time to be allocated to an audit/test:
1. In the properties of the audit/test, expand the Users section.
2. Select a user and in the Workload (Hours), enter the time to be spent 

on the audit/test.

Creating general tasks

For controllers, the director can create tasks not directly linked to tests.

To create a general task:
1. Select Testing > Preparation > General Tasks.
2. Specify dates and a comment and connect users to this task.

Users assigned to this task can allocate hours to this task in their time
sheet.
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Validating Vacations

To display vacations in auditor time sheets, you must previously have validated the
vacation.

To validate the vacation:
1. Select Testing > Preparation > Vacations and open the properties of 

the vacation to be validated.
2. Position its status as "Validated".

Initializing expense sheets

The lead auditor can create an expense sheet per auditor/controller for all auditors/
controllers assigned to the audit/test. In this case it consists of initializing expense
sheets. 

To initialize expense sheets:
1. In the audit/test properties window, select the Expenses tab.
2. Click the Initialize button.

An expense sheet is created for each auditor/controller.

To create an expense:
1. In the expense sheet properties, expand the Expenses section and click 

New.
2. Enter for each expense:

• an Amount
• a Date
• the Expense Category: "Lodging", "Food and Beverages", 

"Transportation"
• a Comment if required. 

 The auditor enters the amount in the desired currency. The 
converted amount is calculated automatically.
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EXECUTING TESTS

Preparation of a test work program allows internal controllers to: 
• execute tests on samples using test sheets.

 These test sheets are presented in the form of check-lists. 
Questions are asked for each object present in the constituted sample.

• assess controls in terms of design and efficiency by means of 
questionnaires.

 These are the same questionnaires as those covered in the chapter 
concerning assessment campaigns.

 “Consulting the Work Program", page 95
 “Executing Tests on Samples", page 96
 “Assessing Controls", page 98
 “Managing Time and Expenses", page 99
 “Supervising Tests", page 102
 “Concluding Tests", page 103
 “Test Follow-Up", page 105

Consulting the Work Program

The controller needs to consult:
• his/her work program. 
• the global work program, for a clearer view of tasks to be executed.

To access your work program:
 In the Testing navigation tab, click Test Navigator > My Work 

Program.
In the right pane of the window appears the tree of tests on which you
must intervene.

 You can access the work program of a test by clicking Global Work 
Program. 
 To print the work program you can export it under Excel. For more 
details, see “Exporting the workload under Excel", page 92.
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Executing Tests on Samples

Internal controllers execute the test steps defined on controls on samples.

To be able to complete test sheets, you must first:
• generate or create workpapers 
• specify or modify test sample size
• generate the test sample
• define test sheet questions

Creating workpapers

Workpapers are folders or work documents that serve as a basis for the controller
in execution of the test. 

 Workpapers are created automatically at generation of the work 
program. For more details, see “Work program content", page 89.

To create a workpaper manually:
1. In the properties of a test, select the Work Program tab.
2. Select the activity concerned and display its properties.
3. In the Characteristics page of the activity, Workpapers section, click 

the New button.
 You can also create workpapers from the Work Program tab of a 
test.

The workpaper appears:
• in the test activity page
• in the tree of the test work program

4. In the work program, select the paper to display its Properties.
5. Enter a name and your comments.
6. Click OK.
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Specifying or modifying the sample size

The controller must specify the size of the test sample on the workpaper. This is the
number of elements to be tested.

To specify sample size:
1. From the work program, open the properties of a workpaper.
2. Specify the Sample Size.

This is the size of the sample selected for testing. 
 By default, the value is inherited from the sample size specified on 
the control. For more details, see “Defining Testing Methods", page 41.

Generating the test sample

Test samples are generated directly from information available on the control (test
steps). 

To generate samples:
 From the work program tree, click the icon of a workpaper and select 

Generate Test Sample.
Depending on the previously specified sample size, a message informs
you of the number of elements that will be created in the test sample.
Generated test samples are available in the properties of the workpaper 

Defining test sheet questions

Workpapers contain test sheets, which represent in tabular form the points to be
executed. These test sheets contain:

• in rows, the elements of the sample to be controlled
• in columns, the questions (represented by test steps)

You must define check-list questions before being able to generate test sheets.
 For more details, see “Preparing Control Testing", page 41.

Completing the generated test sheets 

To be able to view test sheets, you must first: 
• define test sheet questions

 See “Defining Test Sheet Questions", page 41.

• generate the test sample
 See “Generating the test sample", page 97.

To view the test sheet:
1. Open the properties of the workpaper from the work program.
2. Select the Test Sheet tab.

This test sheet presents:
• in rows, the elements of the test sheet to be controlled
• in columns, the test steps

You can reply to the questions in the columns provided.
 Test sheet questionnaires are distinguished from assessment 
questionnaires. For more details on assessment questionnaires, see 
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“Assessing Controls", page 98.

Assessing test activities

Having specified test sheets, the controller can globally assess the test activity. 
 This "expert view" assessment can be based on results of test 
sheets, or not.

To assess the test activity:
1. Open the properties of the test activity.
2. In the Test Result field, specify if the test has:

• Failed
• Passed
• Not yet been assessed

Assessing Controls

Internal controllers must assess controls in terms of design and efficiency. 
 This assessment uses standard assessment campaign mechanics. 
Generated questionnaires are distinguished from those corresponding to 
test sheets. 

Generating questionnaires 

The questionnaires are generated at validation of the work program. 
 For more details, see “Validating work programs", page 93.

Replying to questionnaires

You can answer control assessment questionnaires:
• on a test
• on each activity of a test

To view test questionnaires:
1. In the properties of the test, expand the Assessment section.
2. Select a questionnaire and click Display Questionnaires.
3. Select the questions and reply to these in the lower part of the window.
4. Click Save.

To view test activity questionnaires:
1. In the properties of a test, select the Work Program tab.
2. In the pop-up menu of a test activity, select Assessment.
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Managing Time and Expenses

Managing expenses

 Auditors/controllers assigned to an audit/test can create expense sheets on this
audit /test. In this case, they must submit their expense sheet to the lead auditor
via a workflow.

To create an expense sheet:
1. Select Home > My Desktop > Time Tracking > My Expenses.
2. Click New.
3. In the Expense Owner field, select the audit/test concerned.

 You can also create an expense sheet in the Expenses tab of the 
audit/test properties. In this case, you do not need to specify the 
expense owner.

4. Click OK.
An expense sheet is created. You can now create associated expenses.

5. In the expense sheet properties, expand the Expenses section and click 
New.
The audit/test is indicated.

6. Enter an Amount and a Date: you can enter the amount in the currency 
you require (from those you can access). 

 The amount is converted to the currency configured for your user.
7. Specify if required:

• the Expense Category: "Lodging", "Food and Beverages", 
"Transportation"

• a Comment. 
8. Click the icon of the expense sheet and submit it via the workflow.

 The lead auditor does not need to seek approval for his/her 
expense sheets. 
 You can export to Excel the data contained in expense sheets.

Entering vacations

Entering vacations enables to:
• improved planning of test campaigns. 
• pre-filling time sheets.

To enter a vacation:
1. Select Home > My Desktop > Time Tracking > My Vacations.
2. Click New.
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3. Open the properties of the vacation created.
4. Select an attachment Plan.
5. Also specify:

• Vacation Type (holiday, training, other)
• planned and effective begin and end dates
• a comment if required

6. In the Status field, select "Submitted".
 So that the vacation will appear in the time sheet, the lead 
controller must have validated the vacation (by positioning its status 
value on "Validated").
 An auditor/controller can modify or delete a vacation as long as the 
vacation has not been validated.

Completing a Time Sheet

Auditors/controllers can complete time sheets in the framework of their audit/test.

To complete a time sheet:
1. In the Home tab, select My Desktop > Time Tracking > My Time 

Sheets. 
The time sheet displays one line per audit/test.

2. Enter for each day the number of hours spent on each audit/test.
3. Click Submit to save your time sheet.
4. Click Next to enter your hours concerning the next week.

 Messages may appear if the activity report is not consistent. For 
example, if hours have been allocated to an audit/test and the audit/
test has not yet started. You can submit an incomplete time sheet.

The time sheet enables entry for each day and for each week the number of hours
spent on each audit/test.

 Only those audits/tests that have been published are visible in the 
time sheet.

The time sheet also shows:
• vacations that have been validated
• general tasks (meetings, training, team management, administration ...)

management of issues and action plans

The controller completes the work program by entering:
• Issues
• Action Plans
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Managing issues

Creating Issues

Issues are accessible from activities. 

To create an issue:
1. Expand the tree of your work program.
2. Click the icon of the activity concerned and select New > Issue.

The issue appears in the work program tree as well as in the properties of
the activity.

 Issues can be created automatically at assessment of controls. For 
more details, see “Automatic Issue Creation", page 110.

Saving test evidence

You can connect documents to illustrate an issue.

To add a document as an attachment:
1. In the tree of the work program of a test, select an issue to which you 

wish to add a document.
2. Expand the Attachments section.
3. Click New.

The business document creation window opens. 
 A business document is a document whose content is independent 
of the MEGA repository. These documents can be MS Word, MS 
Powerpoint, or other files. A report (MS Word) generated on an object 
can become a business document.

4. Indicate the business document name.
5. In File Location, click the Browse button.

The File Location dialog box appears.
6. Click Browse and select the file.
7. Click Upload.
8. Click OK.

The document appears in the list of documents attached to the issue. It
is owned by the test of the issue. You can therefore also see it appear in
the Documents tab of the test.

Managing action plans

Action plans can be created from issues.

To create an action plan:
 In the properties page of an issue, expand the Action Plans section and 

click New.
The action plan appears in the section.

To define properties of the action plan:
1. Select the action plan and click Property.
2. Modify its Name if required.
3. Select a level of Priority.
4. Specify the Means implemented for the action plan.



102 HOPEX Internal Control

5

5. Modify the Owner if required.
 By default the owner is the action plan creator.

6. Select an Approver.
 By default the approver is the action plan creator.

7. Click OK.

Supervising Tests

The lead controller must validate the work of controllers via the activity workflow.

He/she can then check their work and assure test follow-up. To simplify the task,
reports enabling test check are available on each test.

Test check reports

To access test check reports:
 In the page of the test, select Reports then Supervision.

Three reports appear :
• Issue Objectivity: to ensure objectivity of issues, evidence must be 

provided.
The figure displayed represents the percentage of issues with at least 
one attachment.

• Work progression by controller
• Controller activity Summary Table

Time sheet follow-up reports

Reports enable follow-up of auditor/controller time sheets. 
 These reports are available for Compliance Managers only.

To access the Reports tab:
 Select My Desktop > Time Tracking. 

Three reports are available.

Time sheets by auditor

This report presents auditor time sheets over a given period
• number of hours assigned for the audit
• effective number of hours in week
• number of hours accumulated since start of audit
• number of hours remaining
• last allocation of auditor on audit
• last time sheet of the auditor
• progress of auditor on audit (in progress, completed..)
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Time sheets by audit

This report presents all time sheets for a given audit.

Incomplete days by auditor 

This report presents the list of incomplete days, that is days of which the number of
hours declared is less than daily work duration.

 Press Validate to validate the Time Sheet.

Test expenses reports

To view expenses of an audit/test:
 In the properties of an audit/test, select the Reports tab, then Work 

Mission Expenses.

Pie diagrams present breakdown of expenses:
• by resource (auditor)
• by category:

• Food and Beverages
• Lodging
• Transportation

To view the list of expenses associated with a diagram sector:
 Right-click in a sector.

Corresponding results appear as a list in the lower part of the window.

Concluding Tests

Test assessment reports

Reports allow the lead controller to best assess the test and analyze its action plans.

To access the Reports tab:
 In the page of the test, select Reports then Assessment. 

Several reports are proposed:
• Action plan breakdown by priority (low, medium, high)
• Issues by theme
• Summary table of above elements

Generating test reports

The test report uses test elements. 
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To generate the test report:
1. Display the navigator of your work program.
2. Click the icon of the test and select Deliverables > Test Report.

A message asks if you want to open or save the file. 
3. Save the file to be able to modify and then submit it.

 You can access reports on previous tests in Home >Testing 
Library > Shared Documents.

Assessing tests

To assess the test:
1. In the properties of the test, select the Summary section.
2. You can indicate:

• Test Strengths
• Test Weaknesses

3. In the Assessment field, specify a value from:
• "Good overall level"
• "Can be improved"
• "Improvement needed"
• "At risk"

Terminating tests

When the test is closed:
• the test report is sent to persons interviewed
• action plans are sent to their owner

Closing tests

When the test has been terminated, the internal control director can close it.
 Closing a test closes all objects at a lower level, with the exception 
of action plans and actions. When these objects have been closed you 
can no longer modify them. 
 The administrator can exceptionally reopen these objects if 
necessary.
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TEST FOLLOW-UP

Implementing Action Plans

Accessing action plans

To access action plans:
 Select Home> My Desktop > My Responsibilities > My Action 

Plans. 
This list presents the action plans assigned to you.

Implementing actions

The action plan owner must create actions.

Creating actions

To create an action:
1. Open the properties of a test.
2. In the Action Plans tab, select an action plan and click Properties.
3. In the Actions section, click New.
4. Open the properties of the action created.
5. Modify its name if necessary, enter a date limit and an action owner.
6. Click OK.

Sending or submitting the action plan

Actions created and assigned to appropriate users constitute an action plan. 

To submit the action plan: 
 Right-click the action plan name and select To Be Submitted > 

Submit.

The approver validates the action plan by return.
 By default, the approver is the controller who created the action 
plan.

Action plan implementation follow-up

When the action plan has been validated by the approver, actions are implemented
by persons concerned.

Specifying action plan progress

The action plan owner must inform the approver on progress of his/her actions.
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To indicate progress of an action plan:
1. In the properties of an action plan, expand the Progress Update 

section.
2. Click the New button.

A progress state is created.
3. In the Progress Update Percentage field, specify an action plan 

execution percentage.
4. Enter a comment if required.
5. Click OK.

 Several progress states at different dates can be created.

Following up action plan progress

After a predetermined period, the internal control director or lead controller can
request receipt of information on progress of action plans.

To follow up action plan progress:
 In the action plan properties, select the Progress Report tab.

Action Plan Follow-Up

An analysis report assures follow-up of action plans.

To access an action plan follow-up report:
1. In the Control desktop, select Testing > Decisional Reports.
2. Select Action Plan Reports.

To create an action plan report:
1. Click New and open the report created.
2. In Parameters, connect the objects that interest you:

• Business
• Entities

3. In the Reports tab, you can see:
• breakdown of action plans by entity, process, category

Test Plan Follow-Up

HOPEX Internal Control enables follow-up of test plans according to different
criteria.

Displaying test plan follow-up reports

Reports enable test plan execution follow-up. 

To access test plan reports:
1. Open the properties of the plan.
2. Select the Plan Reports tab.
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Supervision 

This report offers a summary of test plan tests according to different criteria: 
• Origin
• Priority
• Category
• Score
• Status

Workload and resources

This report enables comparison of estimated and effective workloads.

Pie charts show comparison of test design and efficiency.

Resources allocation 

The diagram displayed in this report enables comparison of:
• persons available
• persons required
• persons assigned 

By default, results relate to the current year, but you can display results for a
precise period.

Gantt report 

The Gantt report comprises two parts:
• A Gantt chart of plan tests scheduled between selected dates
• A Gantt chart of occupation of controllers on plan tests between selected 

dates

Expenses

This report shows all expenses linked to a plan, as well as breakdown by expense
category and by controller.

It allows the director to plan future audits.

Closing a test plan

When all test activities have been completed, the internal control director can close
the test plan.

The effect of this action is to close all tests in progress that have not been canceled.

Reports and Dashboard

Reports

Reports allow you to follow up progress of tests.
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For more details, see “Control Testing Reports", page 128.

Dashboard

Your dashboard allows you to access a set of widgets and follow the progress of your
tests in real time.

To customize your dashboard:

1. At top right of the edit area, click Dashboard .
2. At bottom left of the edit area, click Add.

The list of elements you can display in your dashboard appears:
• general widgets
• widgets relating to testing

3. Select an element and drag-and-drop to the dashboard (central area of 
solution).
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MANAGING ISSUES AND ACTION PLANS

Issues are identified from control assessment questionnaires. Their analysis enables
implementation of the appropriate corrective actions in the form of action plans. Action plan follow-
up is simplified by production of reports.

 “Managing issues", page 110
 “Managing action plans", page 112
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MANAGING ISSUES

Issues are created automatically at control assessment when controls are
considered unsatisfactory. They can also be created manually.

Automatic Issue Creation

In the framework of a test activity, if an activity is the subject of a poor assessment,
an issue is automatically proposed to the questionnaire respondent.

The issue is connected to:
• the questionnaire concerned
• the assessed control
• the measurement of the control concerned 

To view the origin of the issue:
1. In the Control desktop, select Remediation > Issues and Action 

Plans > Issues.
2. Select the issue created automatically and expand the Assessment 

Scope section.
This section provides information on the origin of the issue:
• questionnaire
• assessment node: the control and its context object (process or 

entity)
• control

Creating an Issue Manually

You can create issues manually at any time you consider this necessary.

To create an issue manually:
1. In the Control desktop, select Remediation > Issues and Action 

Plans > Issues.
2. Click New.
3. Open the properties of the issue.
4. In the Category field of the issue, specify if it is an issue detected:

• at control assessment
• at testing

Remediating Issues

To remediate the issue, you must create an action plan. 
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The issue is considered as remediated when the action plan is completed.
 For more information on action plans, see “Managing action plans", 
page 112.

Following Up Issues

You can:
• view issues that have been remediated (of which the action plan is 

completed)
• generate an issue follow-up report

Viewing remediated issues

To view remediated issues:
 Select Remediation > Reports > Remediated Issues.

The list of remediated issues appears.

Generating issue follow-up reports

To generate an issue follow-up report:
1. Select Reports > Remediation > Issue Follow-Up.
2. In the Parameters tab, define filter criteria if necessary and select:

• an entity
• a process
• a Begin Date: to obtain issues created after this date
• an End Date: to obtain issues created before this date

 By default the end date is the current date.
3. Select the Reports tab to view the result.

This report shows distribution between issues:
• remediated
• non-remediated
• that do not yet have an action plan
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MANAGING ACTION PLANS

You can set up action plans to improve a control that has been considered
unsatisfactory ("fail").

 For more details on action plans, see also the HOPEX 
Collaboration Manager guide.

Creating Action Plans

To create an action plan from an issue:
1. In the Control desktop, select Remediation > Issues and Action 

Plans > Issues.
2. Select an issue and in its properties, expand the Action Plans section.
3. Click New.

The action plan is created, as well as its associated workflow.
 For more information on action plan workflows, see “Action Plan 
Workflows", page 115.
 The action plan also appears in the Remediation > Issues and 
Action Plans > All Action Plans menu

You can specify action plan characteristics in its properties. See  “Characterizing
Action Plans", page 112.

Characterizing Action Plans

To specify action plan properties:
1. In the Control desktop, select Remediation > Issues and Action 

Plans > All Action Plans.
2. Open the properties of the action plan.
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General characteristics

You can specify the following information:
• Name: action plan name.
• Owner: this field is specified by default by the user who created the 

action plan.
• Owner Entity: entity responsible for action plan implementation. 
• Approver: user responsible for validation of the action plan when all 

actions are completed.
• Means: text description of means required/desired for action plan 

execution.
• Priority: enables indication of a level. Priority can be: 

• "Low"
• "Medium"
• "High" 
• "Critical"

• Organizational Level: final objective of plan; this can be:
• "Global" 
• "Local" 

• Origin: enables definition of the context of carrying out the action plan:
• "Audit"
• "Compliance"
• "Event"
• "Risk"
• "RFC" 
• "Other".

• Category: the action plan can for example be connected to:
• risk impact reduction
• project management
• process improvement
• control performance improvement
• etc.

• Other values are available.
• Nature: enables definition of whether the action plan is:

• Corrective 
• Preventive 

• Comment: supplements information on the action plan and its 
characteristics. 

• Steering Calendar: used for sending reminders to the person 
responsible for an action plan so that they can indicate action plan 
progress. 

 A steering calendar for monthly reminder of progress is supplied by 
default.

Financial assertion
• Forecast Cost: action plan cost estimate.
• Forecast Cost (Man-Days): estimate in man-days of action plan 

implementation workload.
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RACI

The action plan Owner responsible for definition of actions to be carried out and
their execution. 

This field is specified with the name of the action plan creator or with the name of
the action plan approver.

 For more details on the use of RACI, see “Responsibilities", page 
30.

Success factors

In the Success Factors section, you can specify in text the success indicators
enabling assessment of success of the action plan.

Scope

To position an action plan in its environment, you can associate objects with the
action plan in the Scope section.

You can connect objects of the following types:
• Controls
• applications
• risks
• entities
• process
• incidents

Milestones

Milestones are key dates of the action plan.
 The planned end date is mandatory.

Attachments

You can attach business documents to an action plan: 
 For more details on the use of business documents, see the HOPEX 
Common Features guide.

Managing Actions 

The owner of the action plan must define actions enabling execution of the action
plan. The owner can create actions and assign these.

 An action is included in an action plan and represents a 
transformation or processing in an organization or system.
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Creating Actions

To create an action from an action plan:
1. Select Home > My Desktop > My Responsibilities > My Action 

Plans.
 Depending on your profile, you can also access action plans via the 
menu Remediation > Issues and Action Plans > All Action Plans.

2. Select the action plan in question and click Properties.
3. In the Actions section, click New.
4. In the action properties, complete fields:

• Priority: enables indication of a level. Priority can be: "Low", 
"Medium", "High" or "Critical".

• Owner: responsible for the action as specified by the action plan 
creator.

• Owner Entity: entity responsible for action plan implementation. 
5. You can specify milestones, which are important dates of the action. 

• Planned Begin Date 
• Planned End Date

6. Click OK.
The action is created with "Created" status. 

Defining action scope

An action can concern one or several objects of control, risk or application type. 

For example, to define the controls that will be executed in the framework of the
action:

1. Open the properties of the action.
2. Expand the Scope section.
3. Connect the controls you want to install.

Action Plan Workflows

A workflow is automatically created at creation of the action plan.

Depending on  the profile role of the person that created the action plan, two
workflows are available:

• a "top-down" approach
• a "bottom-up" approach

 Commands enabling passage from one workflow status to another 
are available:
• in the pop-up menu of the action plan from an action plans list
• in the properties dialog box of an action plan, by clicking the action 

plan icon at top left

"Bottom-up" approach

In a "bottom-up" approach, the action plan can be created by any user. An approver
must validate the action plan so that it can be implemented. This is the case when
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control assessment questionnaire respondents propose an action plan: they must
submit it via the workflow.

 For the different workflow steps, see “"Bottom-up" Action Plan 
Workflow", page 143

"Top-down" approach

In the framework of a "top-down" approach, the action plan is created by a
responsible. The action plan does not need to be validated in this case.

Internal controllers carrying out tests use this approach:
 For the different workflow steps, see “"Top-down" Action Plan 
Workflow", page 144

Action workflow

When action plan actions have been defined, starting an action plan starts the linked
actions. 

When the action responsible has completed his/her actions, these can be closed.
Closing the action plan automatically closes the linked actions.

 See “Action Workflow", page 145.

Action Plan Follow-Up

Indicating action plan progress

When the action plan has been started, you can create progress states to indicate
its progress.

To specify action plan progress:
1. In the Control desktop, select Remediation > Issues and Action 

Plans.
2. Select an action plan and open its properties.
3. Expand section Action Plan Progress, and in the Progress Update 

frame, click New.
4. Specify a Progress Update Percentage.
5. If required, specify the Progress Assessment.

You can specify if the action plan is:
• On Time
• Delayed

6. Click OK.
The progress state is created. You can create these at regular intervals.

Action plan follow-up reports

Reports allow you to follow up action plans.
 For more details, see “Action Plan Follow-Up", page 130.
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This chapter describes reports present in the Reports navigation tab. This tab groups the main
reports used in each step of internal control. They can provide help in decision-making and allow
you to follow up progress of your work.

 You find these reports in navigation tabs corresponding to the 
different internal control phases. You can also find certain reports in the 
properties dialog boxes of the objects they describe.

 “Creating Reports", page 118
 “Control Library Reports", page 119
 “Control Execution Reports", page 122
 “Control Assessment Reports", page 125
 “Control Testing Reports", page 128
 “Control Remediation Reports", page 130
 “Reports on Environment Objects", page 132



118 HOPEX Internal Control

7

CREATING REPORTS

To create a report:
1. In the Internal control desktop, select the Reports tab.
2. Select the type of report to be created and click New.

The properties dialog box of the report appears.
3. In the Parameters tab, specify the requested parameters, including the 

report name.
 The different parameters requested for each report are described 
later in this chapter.

4. Select the Reports tab.
You can view the report created.

 The report is specific to the user with which you are connected.

 To customize reports, see HOPEX Common Features, 
"Generating Documentation", "Customizing Reports".
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CONTROL LIBRARY REPORTS

Control Identification

This report presents distribution of controls according to several perspectives:
• entities
• process
• control types
• accounts

Access path

Reports > Library > Control Identification

Parameters

Connecting context objects

You can specify context objects enabling display of controls linked to:
• Entities 
• Business 
• Types of control
• Accounts 

Parameters Remarks

Begin Date Optional
All controls created after this date are selected

End date Mandatory 
Initialized with current date
All controls created before this date are selected

Context objects Optional
The context object can be an:
- Entity
- Control type
- Process 
- Account
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To connect context objects:
 In the appropriate frame, click Connect ....

In the dialog box that appears, you can select objects in two ways:
• via a tree: select the objects to be connected in the proposed tree and 

click OK.
• via the query tool: select the required object type in the drop-down 

list, click the Find button, select the objects to be connected and click 
OK.

Results

To obtain the list of controls making up a bar chart bar:
 Click the bar chart bar that interests you.

The list of controls taken into account is presented at the bottom of the
edit area.

Bars of the bar chart distinguish assessed controls from those not yet assessed.

Control Location Matrix

The control location matrix displays links between:
• a controls list
• context objects

Access path

Reports > Library > Control Location Matrix

Parameters

Parameters Parameter type Comment

Begin Date Date Optional
All controls created after this date 
are selected
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Control Map

The control map constitutes the control "identity card". 

Generating the control map

To generate a control map:
 In the Control Library navigation tab, click the icon of the control then 

the Generate Report (MS Word) button.
An MS Word format report opens.

 An intermediate window may ask if you want to authorize pop-ups. 
If this is the case, reply "Yes".

Control map content

For the control concerned, the control map presents:
• control characteristics

• general characteristics
• responsibilities (in the RACI sense)
• scope (context objects)

• data concerning control execution 
• execution method (frequency, associated steering calendar, execution 

procedure, associated controls)
• executions carried out (with respondent and date)

End date Date Optional
All controls created before this 
date are selected

Context type The context can be of type:
- Account
- Business process
- Control type
- Entity 
- Organizational process

Mandatory
The object type determines con-
texts to be displayed in matrix col-
umns 

Localized controls List of controls possibly filtered by:
- Entity
- Process
- Risk type
- Account 

Mandatory
Controls to be displayed in matrix 
rows

Parameters Parameter type Comment
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CONTROL EXECUTION REPORTS

 “Detailed Execution Results", page 122
 “Consolidated Execution Results", page 122
 “Following Up Execution Sessions", page 123

Detailed Execution Results

This report presents results of each execution campaign session.

Access path

Reports > Execution > Detailed Execution Results

Parameters

Result

The report is presented as a table:
• in rows: tree of controls in their context
• in columns: results (control level)

 This report is available only in the Reports navigation tab. 

Consolidated Execution Results

This report presents aggregated results of controls by entity and by month.

Access path

Reports > Execution > Consolidated Execution Results

Parameters Remarks

Campaign Mandatory

Session Mandatory
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Parameters

Result

The matrix comprises:
• a list of entities: by default, all entities are selected. 

 If the "Entity type" parameter is specified, selected entities 
correspond to this specified entity type.

• a Total number of controls: number of controls linked to the entity (or 
its sub-entities).

• a Total number of instances: controls are counted as many times as 
there are contexts for the same control. 

If a control is assessed in the framework of two different 
entities, the control is counted twice: HOPEX Internal 
Control distinguishes two instances of the assessed 
control.

 For more details on control contextualization see “Scoping 
Controls", page 32.

• for each month:
• a Number of assessed instances
• a number of instances considered as satisfactory ("pass")
• a % of instances considered as satisfactory ("pass")

Following Up Execution Sessions

This report enables follow-up of assessment sessions of "Execution" type.

Access path

Reports > Execution > Execution Session Follow-Up

Parameters

calendar

Begin Date

End date

Entity type

Entity



124 HOPEX Internal Control

7

Availability

This report is also available from a particular execution session.

To access this report from an execution session:
1. In the properties of an execution campaign, select the Sessions tab and 

open the properties page of an assessment session.
2. Select the Reporting tab, then Follow-Up.

Parameters

Result

A summary displays general information on the current session.

This report presents charts concerning campaign progress:
• Percentage of completed questionnaires
• Distribution of questionnaires by status
• Distribution of questionnaires delegated/not delegated
• Distribution of questionnaires by status, for each respondent
• Distribution of questionnaires by status, for each assessed object

Parameters

Session
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CONTROL ASSESSMENT REPORTS

Campaign Result Tree

This report presents results of a given execution campaign session. It presents
entities/processes/controls as trees and indicates for each assessed control whether
it is satisfactory or not.

Access path

Reports > Assessment Campaigns > Campaign Results Tree

Parameters

Campaign Result Matrix By Entity

This report presents as a matrix the results of each session of a given assessment
campaign. 

Access path

Reports > Assessment Campaigns > Campaign Results Matrix by Entity

Parameters

Parameters

Campaign

Assessment session

Parameters

Campaign

Entity

Entity type
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Aggregation Report

The aggregation report presents in tree form all objects from the selected root
entity, together with their last assessment.

Access path

Reports > Assessment Campaigns > Aggregation Report

Parameters

 An aggregation schema is a series of steps enabling consolidation 
of assessment results according to specified assessment rules.

Session Follow-Up

This report enables assessment session follow-up.

It is identical to the "Execution Sessions Follow-Up" report, except that it is started
from an assessment session (the campaign not having "Execution" type).

 For more details, see “Following Up Execution Sessions", page 123.

Access path

Reports > Assessment Campaigns > Session Follow-Up

Parameters Remarks

Begin Date

End date By default current date

Context root Tree root entity

Aggregation schema An aggregation schema should be selected from the 
proposed list

Assessed characteristics Assessed characteristics proposed depend on the 
selected aggregation schema.
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Parameters

Session Statistics

This report displays the questionnaire data of a given assessment session and is
used to analyze the distribution of answers.

Access path

Reports > Assessment Campaigns > Session Statistics

Parameters

Result

A tree appears:
• in rows: questions/answers, together with respondents
• in columns: for each question/answer: 

• number of respondents
• controls to which the answer relates 
This tree specifies who has answered what to which question.

Parameters Parameter value

Session Assessment session

Parameters Remarks

Campaign Mandatory

Session Mandatory
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CONTROL TESTING REPORTS

Testing Coverage

The testing coverage report provides help in decision-making when selecting tests.

It enables generation of tests.
 See “Viewing the test coverage report", page 84.

Plan Synthesis 

This report presents an overview of plan indicators.

Access path

Reports > Testing > Plan Synthesis

Result

A summary table presents:
• number of tests (total number, number of tests planned, published and 

completed)
 If you click the figure indicated, the corresponding tests appear at 
the bottom of the window. You can consult the properties of each test 
and modify these from this list.

• estimated and effective workload (in days)
• average duration (days)
• average number of controllers

Charts present the distribution of tests by:
• origin
• priority
• category
• score
• status

Other Reports

Reports allow you to follow up progress of a particular object (test plan, test, action
plan). They are available on each object, in the Testing navigation tab.
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Test plan follow-up reports

Reports enable test plan execution follow-up.
 See  “Displaying test plan follow-up reports", page 106.

Test follow-up report

For more information on possibilities for test follow-up in particular, see: 
• “Planning tests using a Gantt chart", page 86
• “Viewing resource availability", page 87
• “Consulting the work program report", page 92
• “Generating test reports", page 103
• “Test expenses reports", page 103
• “Supervising Tests", page 102
• “Test assessment reports", page 103

Action plan report

To follow up progress of an action plan in particular, see “Following up action plan
progress", page 106.
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CONTROL REMEDIATION REPORTS

Issue Follow-Up

The issue follow-up report is presented in the form of a pie chart.

Access path

Reports > Remediation > Issue Follow-Up

Result

This report distinguishes issues:
• Remediated: issues with an action plan whose status is:

• Completed 
• Closed

• Non-Remediated: issues with an action plan of which status is:
• To send
• To start 
• Under follow-up

• Without action plan
 For more details on generation of this report, see “Generating issue 
follow-up reports", page 111.

Action Plan Follow-Up

To follow up action plans:
 Select Reports > Remediation > Action Plan Follow-Up.

 For more details, see “Action Plan Follow-Up", page 106.

Access path

Reports > Remediation > Action Plan Follow-Up

Result

This report comprises several charts:
• bar charts
• pie charts 

The action plans are represented in their different contexts (processes and entities).
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Action plans by status 

This bar chart presents action plan statuses.

Action plans by progress

This pie chart presents action plan breakdown according to their status. Possible
statuses are the following:

• On Time 
• in progress 
• with due date exceeding 30 days

• Delayed: 
• in progress 
• with due date earlier than current date

• Approaching due date: 
• in progress 
• with due date between 0 and 30 days inclusive

• Canceled
• Closed

Action plan by priority

This pie chart presents action plan breakdown according to their priority.

Possible priorities are the following:
• Critical
• High
• Medium
• Low

Action plans by category

This pie chart presents action plan breakdown according to their category.

Possible categories are as follows:
• Corrections
• Preventive

Action plans by entity

This bar chart presents breakdown of action plans for each entity.
• x-axis: all entities
• y-axis: number of action plans linked to each entity and sub-entity

 If no entity is selected, all root entities are taken by default.

Action plans by process

This bar chart presents breakdown of action plans for each process. 
• x-axis: all processes (business and organizational)
• y-axis: number of action plans linked to each process and sub-process

 If no process is selected, all root processes are taken by default.
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REPORTS ON ENVIRONMENT OBJECTS

Control Report

Access path 

To access this report:
1. Select Control Library > Control Management > Controls > All 

Controls.
2. Select a control, then in its properties select the Report tab.

Results

This report presents the results of control execution/assessment sessions for each
entity over the last twelve months.

Entity Report

To access this report:
1. Select Control Library > Control Trees > Controls by Entity and 

Process.
2. Select an entity.
3. In the properties dialog box of the entity, select the Reporting tab, then 

select the tab in question:
• Controls
• Action plans
• Assessments

Controls

Bar charts present the number of controls (assessed/not assessed) connected to the
selected entity, breaking these down by:

• Sub-entity
• Business
• Account
• Control type

Action plans

Bar charts allow you to follow up progress of action plans connected to the selected
entity.
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Each bar chart displays breakdown of action plans by:
• Category
• Status
• Progression
• Priority
• Nature
• Sub-entity
• Business

Assessments

Two heatmaps present:
• Inherent risk, calculated from the following values:

• Impact 
• Likelihood

• Net risk, calculated from the following values:
• Control level
• Inherent risk

Process Report

This report presents "heatmaps" of aggregated results over the last three years.

To access this report:
1. Select Control Library > Control Trees > Controls by Process.
2. Select a business or organizational process.
3. In the properties dialog box of the process, select the Reporting tab 

then select the sub-tab in question:
• Controls
• Assessments
• Action plans

Controls

Bar charts present the number of controls (assessed/not assessed) connected to the
selected process, breaking these down by:

• Entity
• Sub-process
• Account
• Control type
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Assessments

Two heatmaps present:
• Inherent risk, calculated from the following values:

• Impact 
• Likelihood

• Net risk, calculated from the following values:
• Control level
• Inherent risk

Action plans

Bar charts allow you to follow up progress of action plans connected to the selected
process.

Each bar chart displays breakdown of action plans by:
• Category
• Status
• Progression
• Priority
• Nature
• Sub-process
• Entity connected to process

Account Report

Access path

To access this report:
1. Select Control Library > Control Management > Controls > All 

Controls.
2. Select a control.
3. In the Characteristics tab of the properties page, expand the Scope 

section, then select teh Accounts. 
4. Select an account, then in its properties page select the Reports tab.

Results

This report presents the number of controls connected to the selected account,
breaking these down in the form of a bar chart by:

• Sub-account
• Business
• Entity
• Parent control type
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Control Type Report

Access path

To access this report:
1. Select Control Library > Control Trees > Controls by Control Type.
2. Select a control type, then in its properties select the Reports tab.

Results

This report presents the number of controls connected to the control type, breaking
these down by:

• Entity
• Business
• Account



136 HOPEX Internal Control

7



137

APPENDIX - WORKFLOWS

Progression of internal control activities is via ready-to-use workflows. This appendix presents
workflows of the main internal control phases.

Workflow transitions are available in the pop-up menus of objects  to which the workflow relates.

 “Workflows Linked to Testing", page 138
 “Workflows Linked to Assessments", page 142
 “Workflows Linked to Action Plans", page 143



HOPEX Internal Control

8

WORKFLOWS LINKED TO TESTING

Test Plan/Audit Plan Workflow
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Test Workflow
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Test Activity Workflow
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Expense Sheet Workflow
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WORKFLOWS LINKED TO ASSESSMENTS

For more details on the workflow:
• Of control assessment campaigns, see “Generic Assessment Workflows", page 110.
• Of control execution, see “Automatic Assessment Workflows", page 113.

 These workflows are detailed in the HOPEX Assessment guide.
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WORKFLOWS LINKED TO ACTION PLANS

"Bottom-up" Action Plan Workflow
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"Top-down" Action Plan Workflow
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Action Workflow
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INTRODUCTION TO HOPEX INTERNAL 
CONTROL OFFLINE

HOPEX Internal Control is an internal control management solution covering the different phases
of internal control. This solution enables:

 definition of internal control systems with creation of a control library
 execution of controls
 assessment of controls, directly or by assessment campaigns or tests
 management of issues and action plans

 For complete documentation, see the HOPEX Internal Control 
guide.

The HOPEX Internal Control solution is a secure Web solution. The  HOPEX Internal
ControlOffline application supplements this solution by offering the possibility of executing tests
in offline mode. The  Offline application is intended for internal controllers responsible for checking
suitability and efficiency of controls set up in the enterprise.

 "Offline Application Scope", page 1
 "About This Guide", page 3
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OFFLINE APPLICATION SCOPE

Internal Control Profiles

The internal control process is broken down into different parts:
• Control Library Definition
• Control Execution
• Control assessment 
• Control Testing
• Issue and Action Plan Management

In HOPEX Internal Control, profiles intervene in different steps of this process:
Functional Administrator, Internal Control Director, Internal Controller, Business
User (IC).

The Offline application is used for testing of controls offline. It essentially concerns
the internal controller. 

In the framework of a test, the internal controller:
• completes workpapers 
• assesses controls via creation of questionnaires
• creates issues and action plans

Offline Mode Test Execution Steps

The test is defined in the HOPEX Internal Control Web solution and can be
executed offline in the Offline application. Using export tools, test data is
transmitted from one application to the other.
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Anticipated exchanges are as follows:

Product Profile Action Description

HOPEX Offline Internal Controller Import test content.

Execute activities.

After file import, each control-
ler executes the activities for 
which he/she is responsible.
See "Importing Data in 
Offline", page 16.
Controllers can create workpa-
pers, issues and action plans.

Internal Controller Export test content to 
HOPEX Internal Control

Controllers export their 
updates to integrate these in 
HOPEX Internal Control.
See "Exporting Controller 
Updates to HOPEX Internal 
Control", page 30.

HOPEX Internal 
Control

Lead Controller or 

Control Director

Validate or not the updates 
in HOPEX Internal Con-
trol.

Three cases are possible:
- updates are validated and 
the process stops.
- the lead controller or control 
director completes these and 
asks the internal controller to 
make any additions or 
changes. 
- the lead audit or director 
prepares execution of new 
tasks

HOPEX Offline Internal Controller Refresh content of the test 
in HOPEX Offline or 
import new tasks as 
required.

See "Refreshing Test Data in 
MEGA Offline", page 31.
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ABOUT THIS GUIDE

This guide presents how to execute tests in offline mode.

Guide Structure

This guide comprises the following chapters:
• Chapter "Preparing Workstations", page 11, explains how to install the 

Offline application. It covers workstation configuration and preparation of 
test execution.

• Chapter "Executing Tests in Offline Mode", page 19, explains how to 
execute tests offline: view activities, complete test sheets, create issues, 
etc..

• The "Glossary", page 35 summarizes definitions of the main concepts 
covered in this guide.

Additional Resources

This guide is supplemented by:
• the HOPEX Common Features guide which presents functionalities 

common to allHOPEX products ;
• the HOPEX Internal Control user guide.

Conventions Used in the Guide

Styles and formatting

 Remarque sur les points qui précèdent.

 Définition des termes employés.

 Astuce qui peut faciliter la vie de l’utilisateur.

 Compatibilité avec les versions précédentes.

 Ce qu’il faut éviter de faire.

Remarque très importante à prendre en compte pour ne pas commettre d’erreurs 
durant une manipulation.
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Les commandes sont présentées ainsi : Fichier > Ouvrir.

Les noms de produits et de modules techniques sont présentés ainsi : HOPEX.

Formulating command sequences 

To reference a command in the solution, and with a view to simplification, the
following formulation has been adopted in this guide: 

Example of a command with its formulation in the guide

Application command Formulation adopted in this 
guide

In the Environmentdesktop, click Risk 
Universe > Controls > Control 
Types.
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WEBWORKS

PREPARING WORKSTATIONS

To work in offline mode, test participants must be equipped with a workstation on which the HOPEX
Internal Control application is installed with the Offline environment and Online application access
configuration, as well as the data specific to the planned compliance test. The Web environment
must also have been specifically configured (commands logfile activation).

Applications are installed on workstations by the administrator. Test data is imported  by each of
the internal controllers.

 "Installing the Offline Application", page 12
 "Importing Data in Offline", page 16
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INSTALLING THE OFFLINE APPLICATION

Prerequisite Conditions

Before installing the HOPEX Offline application, you must have:
• a stand-alone installation of HOPEX Windows Front-End 
• A stand-alone license for the product HOPEX Internal Control

To authorize exchange of data between the HOPEX Internal Control Web
application and the Offline application, you must modify certain Web application
parameters. See "Configuring HOPEX Web Front-End", page 14.

Checking Installation of HOPEX Windows Front-End

Check that the x installation that you want to use is defined as the current
installation in the registry.

To check this, you can:
• double-click on the installation administration.exe file.

If this message appears, the installation is not current:

• run a TEST.VB file with the following VBscript code:
Set oMegaApp = CreateObject("Mega.Application")

MsgBox "current installation in registry: " & oMegaApp.Path

A window appears with the current installation path. Check that this is the
installation path that you want to use.

In case of a correction 

In case of a correction, two files must be integrated in the Offline installation:
• File "mj_audit.jar" to be copied in <Installation file>/Java/lib
• File "Hotfix.zip" to be copied in the MEGA_USR folder of the HOPEX site.
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In case of extensions

When a Product Engineer performs extensions for a client, he/she provides
customizations in a file named "Extension.zip". 

A user granted administration rights and in charge of installing the offline application
on a workstation must copy the .zip file to the MEGA_USR folder of the HOPEX site.

The .zip file contains:
• .MG* files containing extensions to be imported to the modeling 

repository (in alphabetical order).
• Other files to be copied in the MEGA_USR folder of the environment.

Starting Installation

To install the Offline Application:
1. In the HOPEX 1.2\Utilities\Solution Pack installation folder, double-click 

MEGA_Audit.exe.
The test environment installation window appears: at a first connection to
the Offline application, you must create an environment and a repository.

2. Indicate the location of the environment to be created and click OK.
Several windows appear during update of the environment and
compilation of the metamodel. When the environment and repository
have been created, a window invites you to open the application.

When you run the Mega_Audit.exe file, the local "AuditOffline" (GBMS) environment
is created. This environment is listed in the HOPEX local installation directory.

At installation, a specific folder is created to save exchange files. A shortcut to this
folder is available on the desktop.

A shortcut to the Mega_Audit.exe file is also created.
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Configuring HOPEX Windows Front-End

From HOPEX Windows Front-End, you must specify the Web application
connection path.

To indicate the Web application connection path:
1. In the HOPEX Windows Front-End installation folder, double-click the 

"Administration.exe" file.
2. Right-click the HOPEX site and select Options > Modify.

The options window appears.
3. In the left pane, click Installation >  Web Application.
4. In the right pane, in the Web Application Path field, enter the URL 

address of HOPEX Web Front-End.
5. Click OK.
6. Close the administration dialog box.

Configuring HOPEX Web Front-End

To log data and enable data exchanges between Web and offline applications, the
administrator must configure installation of HOPEX Web Front-End:

• Enabling the repository log
• Enabling the system repository logfile
• At environment level, select the option "Log all data ignoring 

MetaModel".
 In the HOPEX Windows Front-End installation, this configuration 
is automatic when creating the environment.

To activate the work repository and system repository logfiles:
1. In the HOPEX Web Front-End installation folder, double-click the 

"Administration.exe" file.
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2. Open the environment that contains the test repository. To do this, 
connect with a user that has data administration authorization rights.

 The "System" identifier enables connection with the "Administrator" 
user. This user is created by default, with repository administration 
rights. It has no profile (it has all rights) and no password is assigned at 
installation.

3. Right-click the test repository and select Properties.
4. In the Repository Logfile field, select the "Enabled" value.
5. Enable the environment "SystemDb" repository in the same way.

To select the "Log all data ignoring MetaModel" option:
1. Right-click the desired environment and select Options > Modify.

The options window appears.
2. In the left pane of the window, select Repository.
3. In the right pane, in the Behavior of Log Activation field, select "Log 

all data ignoring metamodel". 
4. Click OK and close the administration console.
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IMPORTING DATA IN OFFLINE

To execute the test in Offline mode, you must extract it from HOPEX Internal
Control and import it in the Offline application.

You must import the test in file mode: a file containing test data is exported from
HOPEX Internal Control and imported in the Offline application.

Importing the Test in File Mode

Extracting the test from HOPEX Internal Control (Web)

Extraction of test activities content is carried out by the internal controller handling
the test and wishing to work Offline.

The test plan should have been previously validated and the test published.

To extract test content from HOPEX Internal Control:
1. In HOPEX Internal Control, open the page of the test work program.



17

Preparing Workstations
Importing Data in Offline

2. Click the icon of the test and select Export Offline (File).
The export dialog box appears. It contains the list of test activities
assigned to you.

3. Select the activities to be imported in MEGA Internal Control Offline. 
Activities already active in HOPEX Offline are not proposed (see 
"Managing Activities Online and Offline", page 18).

 All activities of the test are extracted and imported in the internal 
controller workstation, but only those selected for execution Offline are 
active (Offline attribute has value "Offline").

4. Click Next.
5. Click OK.

On completion of processing, a message proposes that you save the
generated file. Message presentation varies according to the navigator.

6. Click Save as and specify location of the generated file. 
The downloaded.zip is named AuditOffLine_Export.zip, but you can
modify its name. 

Importing the file in HOPEX Offline

To import the test in HOPEX Offline:
1. Double-click HOPEX Audit Offline.
2. In the connection dialog box, click Import Audit (File). 
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3. Select the .zip file containing the test.
If the test already exists in HOPEX Offline, a message asks if you want to
reinitialize the repository. It is also recommended that you back up the
repository.
A window indicates import progress and completion.

4. Click OK.
5. Returning to the connection dialog box, click Start HOPEX.

 All objects (users, workflows, etc.) attached to the test are 
imported. The writing access diagram is automatically compiled.

Managing Activities Online and Offline

So that an activity cannot be modified simultaneously in HOPEX Internal Control
and  HOPEX Offline, an "Offline" attribute is available in its properties. 

This attribute takes value:
• "Online" when the activity is in the course of execution in . HOPEX 

Internal Control 
• "Offline" when the activity is in the course of execution in HOPEX Offline. 

The attribute value changes automatically during data exchanges between the two
applications.
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This chapter covers test execution steps. These steps essentially concern the internal controller.
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MEGA OFFLINE DESKTOP

Desktop Presentation

By default, the MEGA desktop comprises:
• A toolbar.
• A navigation area, on the left, which gives access to the test elements.
• An edit zone, on the right, which displays properties of the object 

selected in the navigation area.

Data Saving

If one does not already exist, a private workspace is created when a user requests
repository access: MEGA saves a view of the state of the repository at the moment
the user connected. 
The user can add his/her own modifications without being disturbed by any
concurrent modifications of other users: in the case of a network installation, each
MEGA user has his/her own view of the repository.

To save your latest modifications at any time, click button  or select File >

Save All.

Dispatching a private workspace

Dispatching consists of making public the updates carried out in a private
workspace.

Dispatching your transaction allows the other users to see the changes you have
made to the repository. They will see these when they open a new private
workspace, either by dispatching, refreshing or discarding work in progress.

It is recommended that you regularly dispatch your data so as not to lose
modifications made to objects. 

To dispatch a private workspace:
 Select File > Dispatch.

For more information on dispatching private workspaces, see the MEGA
Administration - Supervisor, chapter "Managing Private Workspaces".
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Backup logfile

If a problem occurs with your repository, you can restore the last backup and import
the repository backup logfile. 

For more information on backup logfiles, see the MEGA Administration -
Supervisor guide, chapter "Managing Repositories".

Exiting MEGA Offline

To exit your session.
 Select File > Exit.

If MEGA is installed on a network, a dialog box will ask you if you want to
dispatch the modifications you made:

• Yes
Modifications you have made in your private workspace are saved in the
repository. 

 In order to work effectively as a team, it is recommended that you 
dispatch frequently and regularly. Other users can update their own 

Backup logfiles Extension Location

Current private workspace .MGL "…\AuditOffline\Db\Audit\Audit.Transactions" 
directory where \AuditOffline represents the 
folder in which your environment is installed.

Dispatched private 
workspaces

.MGL "…\AuditOffline\Db\Audit\ Audit.Log\"
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private workspace without dispatching their work (menu File > 
Refresh).
 This exit mode also allows the user to select a different repository 
the next time he/she logs in.

• No
All modifications you made since your last dispatch will be lost. You can
use this option if you want to view data quickly and exit without impacting
the repository. 

 Modifications to your desktop are also lost.

• Later
This option allows you to keep your changes without impacting the
repository. You can open your session later and continue working but
other users are not yet seeing the changes you have made. 



23

Executing Tests in Offline Mode
Consulting the Work Program

CONSULTING THE WORK PROGRAM

The work program defines content of the test. In MEGA Offline, the lead controller
can view the work program before executing it.

A controller needs to consult:
• the work program, to understand this in its entirety.
• his assigned activities.

Accessing Tasks to be Executed

To access assigned tasks:
1. In the My Navigator navigation window, click the test. 

The test properties dialog box opens.
2. Select the Work Program tab.

Work Program Elements

Test elements are assembled in the work program.

Test activity

The basic element of the test is the test activity. It enables assignment of
responsibility to the controller. 

 A test activity is part of a test assigned to a controller to check 
implementation of a control in the framework of an enterprise 
department process.

Test theme

A test theme is a grouping of control testing activities of the same process in an
enterprise department. Test themes can be broken down into test sub-themes
according to the hierarchy of enterprise processes.

 The auditor must complete this work program. For more details, 
see "Preparation of a test work program allows internal controllers to:", 
page 24.
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EXECUTING TESTS

Having been informed of the work program, the controller can execute the test.

Preparation of a test work program allows internal controllers to: 
• execute tests on samples using test sheets.
• assess controls in terms of design and efficiency by means of 

questionnaires.

The controller completes the work program by entering: 
• workpapers

 A workpaper comprises points to be checked on a given subject in 
the course of a test activity.

• Issues

 An issue is a problem corresponding to a non-compliance or 
anomaly. It can be detected at assessment of controls by questionnaires 
or during control testing.

• Action Plans

 An action plan comprises a series of actions, its objective being to 
reduce risks and events that have a negative impact on company 
activities.

Completing Workpapers 

Workpapers are folders or work documents that serve as a basis for the controller
in execution of the test. 

They can form the starting point for tests, which contain points to be evaluated
(forms containing questions/answers).

 A workpaper comprises points to be checked on a given subject in 
the course of a test activity.

The controller can:
•
• create tests based on questions/answers created by the lead controller.

Creating Workpapers

To create a workpaper:
1. Open properties of the test activity.
2. Click the Characteristics tab.
3. In  Workpapers section, click the  New button.

The workpaper appears.
4. Enter the workpaper name.
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Viewing and specifying workpapers 

You can access workpapers:
• from the page of an activity. 
• from the Work Program tab of a test.

Internal controllers execute the test steps defined on controls on samples.

To be able to complete test sheets, you must first:
• generate or create workpapers See "Completing Workpapers", page 24.
• specify or modify test sample size See "Specifying or modifying the 

sample size", page 25.
• generate the test sample See "Generating the test sample", page 25.
• define test sheet questions See "Defining test questions", page 25.

Defining test questions

Questions used to generate test sheets have previously been defined at the level of
controls. For more details, see chapter "Managing the Control Library", section
"Preparing Control Tests" of the HOPEX Internal Control guide.

Specifying or modifying the sample size

The controller must specify the size of the test sample on the workpaper. This is the
number of elements to be tested.

To specify sample size:
1. From the work program, open the properties of a workpaper.
2. Specify the Sample Size.

This is the size of the sample selected for testing. 
 By default, the value is inherited from the sample size specified on 
the control. For more details, see chapter "Managing the Control 
Library", section "Defining Test Methods" in the HOPEX Internal 
Control guide.

Generating the test sample

Test samples are generated directly from information available on the control. 

To generate samples:
 From the work program tree, right-click a workpaper and select 

Generate Test Sample.
Depending on the previously specified sample size, a message informs
you of the number of elements that will be created in the test sample.
Generated test samples are available in the properties of the workpaper 
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Completing the generated test sheets 

To view the test sheet:
1. Open the properties of the workpaper from the work program.
2. Select the Test Sheet tab.

This test sheet presents:
• in rows, the elements of the test sheet to be controlled
• in columns, the test steps

You can reply to the questions in the columns provided.
 Test sheet questionnaires are distinguished from assessment 
questionnaires. For more details on assessment questionnaires, see 
chapter "Assessing Controls" in the HOPEX Internal Control guide.

Defining Issues

After assessment of control systems, issues may be identified. These issues should
be recorded and corrected by implementation of action plans.

Issues are accessible from activities. 

To create an issue:
1. Expand the tree of your work program.
2. Right-click the activity concerned and select New > Issue. 

The issue appears in the work program tree as well as in the properties of
the activity.

 Issues can be created automatically at assessment of controls. For 
more details, see "Automatic Issue Creation", page 110.

You can connect business documents to illustrate an issue. 

Business documents are documents initially external to MEGA, but which are stored
and managed by MEGA.

 For more information, see chapter "Using Business Documents" in 
the HOPEX Solutions Common Features guide.

To add a document as an attachment:
1. In the tree of the work program of a test, select an issue to which you 

wish to add a document.
2. Expand the Attachments section.
3. Click New.

The business document creation window opens. 
4. Indicate the business document name.

5. In File Location, click the Browse button. 
The File Location dialog box appears.
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6. Click Browse and select the file.
 The controller should store attachments in the attachments folder 
created at installation of MEGA. A shortcut is placed on the desktop for 
this purpose. 

7. Click Upload.
8. Click OK.

The document appears in the list of documents attached to the issue. It
is owned by the test of the issue. You can therefore also see it appear in
the Documents tab of the test.

Defining Action Plans

Action plans can be created from issues.

To create an action plan:
 In the properties page of an issue, expand the Action Plans section and 

click New.
The action plan appears in the section.

To define properties of the action plan:
1. Select the action plan and click Property.
2. Modifiy its Name if required.
3. Select a level of Priority.
4. Specify the Means implemented for the action plan.
5. Modify the Owner if required.

 By default the owner is the action plan creator.
6. Select an Approver.

 By default the approver is the action plan creator.
7. Click OK.
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ACTIONS POSSIBLE ON OBJECTS

Actions possible on objects and characteristics depend on user rights. Rules follow
those defined in HOPEX Internal Control.

Modifying Objects

Tests

Tests are defined in HOPEX Internal Control. Tests cannot be created in MEGA
Offline, but they can be completed in MEGA Offline.

Test elements

Activities or themes can be created only by lead controllers.
 For more information on themes and activities, see chapter 
"Testing Controls", section "Preparing Tests" in the HOPEX Internal 
Control guide.

Other elements participating in test execution (workpapers, questionnaires, etc.)
can be created by lead controllers and controllers.

Controller 

Controllers are defined in HOPEX Internal Control and accessible in Offline in
read-only mode only. Controllers cannot be created in Offline.

Using Object Text History

1. Right-click the object in question and select Text History.
The Text History appears.

2. In the Selected Text field, select the type of text whose history you 
want to see.

3. In the Text at Previous Date field, select the date of the text you want 
to display.
A first text area displays the text saved on the selected date. A second
text area displays the current text. 

 To modify a current text, you must first select a date.

 The history does not cover "Comment" text of issues and action 
plans.
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Data history and dispatch

For as long as you do not dispatch your data, the history displays each text saved
in the private workspace. When you dispatch your work, only the last text that was
entered in the private workspace is saved. 
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EXPORTING CONTROLLER UPDATES TO HOPEX INTERNAL 

CONTROL

When activities have been executed, the controller must extract the updates
executed Offline to import these in HOPEX Internal Control.

To extract your Offline updates:
1. Select File > Export > Export Auditor Updates.

The export wizard appears.
2. Select the activities to be exported.
3. Indicate the name and  location of the file to be generated.
4. Click Next.

A green bar indicates export progress. On completion of export, a report
appears indicating exported objects.

5. Click Finish.
A Web application connection dialog box appears. 

6. Enter your login and connect.
An import wizard appears, enabling direct import in HOPEX Internal
Control of the previously generated file.

7. In the File Location field, click button  and select the file to be 
imported.

8. When the file has been indicated, click Next.
A message will inform you when import is completed.

9. Click OK.
10. Click Log out to exit the Web application , and save your updates.

The connection dialog box remains available, you can:
• connect to HOPEX Internal Control to check that your updates have 

been successfully imported.
• close the connection dialog box by clicking the arrow in the top right 

corner.
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REFRESHING TEST DATA IN MEGA OFFLINE

After import in HOPEX Internal Control of activities carried out Offline, the
internal control director or lead controller can make modifications and ask the
controller to carry out new updates Offline. To carry out these updates, the
controller must refresh the activities concerned in his/her Offline environment.

There are two ways of refreshing activities in Offline: 
• In file mode: a file containing test activities is exported from the HOPEX 

Internal Control application on the Web then imported in Offline.
• In Online mode: transfer of test activities is directly from one application 

to the other.

Refreshing Data in Online Mode

To refresh data in  Offline:
1. In the Offline application, select File > Import > Refresh Auditor 

Activities (Online). 
A connection window to HOPEX Internal Control appears in the edit
area.

2. In the Login field, enter your identifier.
3. (If you have a password) In the Password field, enter your password.
4. In the Environment field, select your work environment.

 If you can access one environment only, this is automatically taken 
into account and the environment selection field does not appear.

5. Click LOGIN.
• If you have access to several repositories, a dialog box asks you to 

select one of these. 
• If you have access to a repository with a unique role, this second 

dialog box does not appear.
Once you are connected to MEGA Web Front-End, the update wizard
appears. It allows you directly select in the HOPEX Internal Control
repository the test to be exported.

 The "Audit Offline" application presenting the update wizard in 
MEGA Web Front-End serves only to exchange data between HOPEX 
Internal Control andMEGA Offline.

6. In the Mission field, select a compliance test. The list contains tests 
validated or in progress for which you are controller.
When the test has been selected, the list of activities assigned to you and
that are not already "Offline" appears.

 For more details on activities online and offline, see "Managing 
Activities Online and Offline", page 18.

7. Select the activities to be updated offline. 
8. Click Next.

A window indicates activity extraction progress. A report is displayed on
completion of extraction.
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9. Click OK.
A window indicates progress of activity updates in MEGAOffline. 

When update is completed, you can exit connection to MEGA Web Front-End. The
selected activities are updated and are now "offline". 

Refreshing Data in File Mode

Extracting activities to be updated from HOPEX Internal Control 

To extract the activities from HOPEX Internal Control:
1. Connect to HOPEX Internal Control.
2. Open the page of the test work program.
3. Right-click the test and select Refresh Offline (File).

The export dialog box appears. It contains the list of test activities
assigned to you and that are not "Offline". 

4. Select the activities to be refreshed and click Next.
The "Offline" attribute of the selected activities takes value "Offline".

5. Click OK.
On completion of processing, a message proposes that you save the
generated file. Message presentation varies according to the navigator.

6. Click Save as and specify location of the generated file. 
The downloaded.zip is named AuditOffLine_Export.zip, but you can
modify its name. 

Importing the updates file in MEGA Offline

To import the file of activities to be updated in MEGA Offline:
1. Connect to MEGA Offline.
2. In the connection dialog box, select File > Import > Refresh Auditor 

Activities (File).
3. In the window that appears, select the .zip file that contains the 

activities.
4. Click OK.

The updates are imported. The activities are marked "Offline".
 For more details on activities online and offline, see "Managing 
Activities Online and Offline", page 18.
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