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HOPEX COLLABORATION MANAGER 
INTRODUCTION

The following is detailed hereafter:

Communicating in MEGA

MEGA simplifies team working and makes available different means of communication in your
MEGA desktop. You can:

• work on objects with certain users without other users seeing your work.
• create and participate in threads of posts on objects.
• create alerts on objects to follow their ongoing modifications.
• participate in chats, independently of the MEGA desktop (MEGA Web 

Front-End) in which you are working.

Workflows

Workflows enable automation of collaboration between the different participants
during modeling work phases. The use, configuration and administration of
workflows as well as transfers between repositories are covered here.

Action plans

This action plan management function consists of defining, executing and following
up a certain number of actions in a project framework. 

Repository Snapshots

A repository snapshot identifies an archived state of the repository. They are
necessary for use of various functionalities.
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INTRODUCTION TO  WORKFLOWS

HOPEX enables coordination of modeling work in a multi-user environment in order to obtain
coherent and stable models.

 "Overview of Workflow Features", page 6
 "Presentation of this Guide", page 7
 "Prerequisites", page 8
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Introduction

OVERVIEW OF WORKFLOW FEATURES

Main phases of modeling activity are:
• modeling work
• validation of this work
• publication for consultation of completed models

Features
HOPEX Collaboration Manager enables automation of collaboration between the different
participants during modeling work phases. 

Workflow engine
Orchestration of these different functions is supported  by a workflow engine, of which specificities
are the following:

• Possibility of configuring existing workflows or creating new workflows
• Workflow administration
• Sending e-mails/notifications

 Creation and configuration of workflows is available with the HOPEX Power Studio 
option. 
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PRESENTATION OF THIS GUIDE

This guide comprises the following chapters:

 "Using Workflows", page 11, presents functions available to the end user.
• workflow
• request for change
• design task
• validation request
• unlocking request

 "Configuring Workflows", page 31, presents functions enabling workflow creation 
and configuration.

 "Managing Workflows", page 65, is intended for the functional administrator and in 
particular presents how to access options, stop a workflow, view workflows in 
progress and manage permissions.

 "Managing Repository Transfers", page 77, presents features available to the 
administrator HOPEX.

• Compare and align use case
• Modes of transfer to a production repository
• transfer of objects via the  HOPEX Collaboration Manager option.

 "Glossary", page 99, summarizes concepts used.
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Introduction

PREREQUISITES 

To be able to use workflow functions you must fulfill a certain number of prerequisites.
Below is a summary of functions available with each product or option.

You must work in a single environment. Additional conditions are necessary to be able to use the
following functions:

Design Tasks
To be able to use design tasks, you must:

• Activate task management.
• Activate the logfile of the repository and/or the system repository for which you want to 

keep history of modifications associated with tasks.
• have HOPEX Collaboration Manager product,

 For more details on repository log activation, see the HOPEX Administration-
Supervisor guide, "Managing Repositories", "Managing Logfiles".

To activate task management:
1. From the administration application, open the desired environment.
2. Right-click the environment and select Options > Modify.
3. In the Collaborative Environment  options group, select value "Enabled" for the 

Associate modifications with a design task option.
Task management is activated.

 The option can also be defined at user level.

The Associate modifications with a design task, option has three values:
• if task management is Disabled, the user cannot dispatch his/her private workspace as 

a task
• if task management is Enabled, the user can use tasks, and can choose whether or not 

to associate a task with the work dispatched
• if task management is Mandatory, the user can only dispatch his/her work by 

associating it with a task.

When dispatching the private workspace as a task, the user associates all dispatched modifications
with the assigned task.

Product/Option Features

HOPEX Collaboration 
Manager

- Requests for change
- Design tasks
- Validation
- Transfers
- Unlocking
- Triggering scheduled processing

HOPEX Power Studio - Workflow definition
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Workflows

Instant notification
To be able to use instant notification, you must:

• Have a repository stored in RDBMS format
 For more details on creation of an RDBMS format repository, see the technical article 
"Repository - RDBMS Installation Guide".

• Activate the option "Activate notification pop-up window" in the "Collaborative 
environment" options group.

Electronic mail
So that e-mails can be sent automatically following creation of workflow actions triggered by a
transition, you must configure electronic mail options at site level in HOPEX Administration
(Installation options group). An e-mail address must also be specified on each user.

Transfer of Objects
To be able to use the transfer of objects function, you must have available the HOPEX
Collaboration Manager option.

Scheduler
The scheduler enables triggering of planned processing operations. It is used in the framework of
workflows and alignment.
If you do not have HOPEX Collaboration Manager available, you must modify options so that
actions requiring the presence of this option are ignored.

To modify scheduler options:
1. Start the  Administration.exe" program.
2. Open an environment.
3. Right-click the site name and select Options > Modify.
4. In the tree, expand the "Installation" folder and select Scheduler.
5. In the right pane, in the Scheduler client connection mode field, select "No 

connection".
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USING WORKFLOWS

This chapter describes how to participate in a workflow.

It describes different workflows available as standard. Other workflows are supplied with HOPEX
solutions. See the corresponding guide for further details.

 "Using Workflows", page 12: describes how to participate in a workflow. 
 "Examples of Workflows Supplied as Standard", page 17 : describes some of the 

workflows supplied as standard.
 To create your own workflow, see "Configuring Workflows", page 31.
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USING WORKFLOWS

In HOPEX, workflows manage expected actions as well as roles of the different participants involved
in execution of these actions. 

Consulting Workflows 

Consulting Workflows in HOPEX Windows Front-End
HOPEX proposes several modes for consulting workflows:

• from a tree in the Collaboration navigation window.
• from a list via the workspace edit area
• from an object

From the navigation window
To list workflows:

1. In the HOPEX desktop, open the Collaboration navigation window.
  To access this window, select View > Navigation Windows > Collaboration.

2. Expand the folders:
• My Workflows.
This folder contains the workflows with which you are involved.
• Workflows of All Users.

 This folder is available if you have the necessary authorization (menu Tools >  
Options > Collaborative Environment, option View workflows of all users).

Workflows in progress appear in the tree. They are classified according to different criteria (waiting
for x months or x weeks).
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From the workspace edit area

To list workflows in progress:
 At the top of the Collaboration navigation window, click button Workflows > List 

Workflows .

 You have to distinguish between two workflow instances:
• single-repository workflow instances, which are stored in data repositories (for 

instance, workflows associated to HOPEX solutions.)
• multiple-repository workflow instances, which are stored in the system repository.

Workflows in progress appear in the workspace edit area.
From this page, you can:

• sort workflows according to your own criteria, and modify the order of appearance of 
columns.

• export the list of requests for change in the form of an Excel or PDF file.
 You can also use this page to participate in a workflow (Next Status button). For 
more details, see "Participating in a Workflow", page 15.

From an object

To consult workflows in progress on an object:
 In the properties dialog box of the object, select the Workflows tab.

Workflow history appears.
 The Workflows tab only appears if the selected object is subject of a workflow 
instance.
 Only those objects that are subjects of a workflow include this Workflows tab.

Consulting Workflows in HOPEX Web Front-End
You can use functions linked to HOPEX Collaboration Manager from the Web via a dedicated
desktop.

 You must work in an RDBMS environment to be able to access this.

To connect to the desktop enabling workflow management on the Web:
1. Start the HOPEX application from its HTTP address.

See  "Accessing HOPEX Web Front-End", page 22.
2. In the Profile field, select Teamwork User profile.
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3. Click LOGIN.
The Teamwork desktop Home Page appears. 

 After a certain period of inactivity, you are disconnected. To reconnect, repeat the 
steps of the procedure above. This inactivity period is configured by the administrator.

You will find here the functionalities linked to workflows.
From the navigation tree on the left, you can access:

• Your notifications
• Collaborative tools to execute your tasks:

• design tasks
 See "Using Design Tasks", page 20.

• requests for change
 See "Using Requests For Change", page 17.

• validation requests
 See "Using the Validation Request Workflow", page 26.

• unlocking requests
 see "Using the Unlocking Request Workflow", page 28.

At top left, a Collaboration options group allows you to start any type of workflow:

Consulting Notifications

As a workflow progresses, the user(s) assigned to the next status can receive a notification warning
of the existence of a request needing attention.

 To benefit from notifications, see "Prerequisites", page 8. 

Display of the notification dialog box in HOPEX Windows Front-End
In HOPEX Windows Front-End notifications are displayed automatically:

 To no longer display the notification window, select option Deactivate notification 
pop-up window. 

Consulting notifications in HOPEX Windows Front-End

To consult notifications in HOPEX Windows Front-End:
1. In the HOPEX desktop, open the Collaboration navigation window.
2. In the My Notifications folder, expand the Unread Notifications sub-folder. 

Notifications that concern you are contained in this folder.

 You can also list notifications from the workspace edit area. To do this, in the 

Collaboration navigation window, click button  Notifications > List Notifications. 
A window opens in the desktop edit area.
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Consulting notifications in HOPEX Web Front-End
In HOPEX Web Front-End, notifications are sent each time you dispatch your work.

To consult notifications in Teamwork desktop:
 In the Collaborative Tools navigation window, select the To-Do List.

 See  "Consulting Workflows in HOPEX Web Front-End", page 13.
This list gives access to the workflows you have to take part in.

 In HOPEX solutions, notifications are often displayed in the form of widgets in the 
home page.

Starting a Workflow

To access workflows:
• From HOPEX Windows Front-End: see "Consulting Workflows in HOPEX Windows Front-

End", page 12
• From HOPEX Web Front-End: see "Consulting Workflows in HOPEX Web Front-End", page 

13
 You must have the HOPEX Collaboration Manager option to be able to start a 
workflow.

To start a new workflow:
1. Click the Start Workflow button.

• (HOPEX Windows Front-End) at the top of the Collaboration navigation window 

through .
• (HOPEX Web Front-End) in the Collaboration tool group.

2. Click the workflow that interests you then OK.
 Only those workflows that you are authorized to start are displayed.

3. In the first dialog box of the wizard that appears, enter the workflow name.
4. In the Workflow Subject field, click Create then select an object to connect.
5. Click OK.
6. Enter a comment for the workflow if required and click Next.
7. Select the Users assigned to the next workflow status then click Finish.

 A workflow status corresponds to a step in progress of a workflow defined by a 
workflow definition.
 When you take part in a workflow, remember to dispatch work made in your 
private workspace.

Participating in a Workflow

After initiation of a workflow, only those users assigned to the next workflow status can intervene
in this workflow.

 Any HOPEX user can participate in a workflow, whatever the product used. The 
HOPEX Collaboration Manager option is not required.
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Triggering a transition from a list of workflows

To take part in a workflow:
1. Access the workflows which are of interest to you.

 For more details, see "Consulting Workflows", page 12.
If you are assigned to the next workflow status, the workflow appears:
• in the "All waiting workflows" sub-folder in HOPEX Windows Front-End. 
• In the "To-Do List" of Teamwork desktop in   HOPEX Web Front-End.

 The Teamwork desktop is also available when you connect directly with the 
"Teamwork User" profile.

2. To pass the workflow to the next status, right-click the workflow and click Next Status.
3. In the dialog box that appears, select the transition that you wish to trigger and click 

Next.
4. Enter a comment for this transition and click Finish.

 You can also pass to the next status from the properties dialog box of an object 
subject of a workflow.

Triggering a transition from an object in a solution
HOPEX solutions are based largely on workflows to manage interactions between different
stakeholders.

To trigger a workflow transition from an object list:
 Select an object in the list and in its pop-up menu select the appropriate workflow 

command.

To trigger a workflow transition from the properties dialog box of an object:
1. Open the properties dialog box of the object concerned.
2. Click the icon of the object and select the appropriate workflow command.

The worflow progresses: the object passes to another workflow status and a new
participant can take part in the workflow.
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EXAMPLES OF WORKFLOWS SUPPLIED AS STANDARD

Find below examples of workflows supplied as standard with HOPEX Collaboration Manager
product. 

 Other customizable workflows are supplied with  solutions. See the corresponding 
guide for more details.

Using Requests For Change

Requests for change allow users that have the HOPEX Collaboration Manager option to request
a modification on one or several repository objects. 
Depending on workflow configuration, users receive an e-mail or a notification to inform them of
the request for change.
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Request For Change Workflow
The diagram that illustrates this workflow is shown below.

In this workflow, a requester makes a new request for change. The request then passes to status
Submitted Request. 
An administrator of requests for change analyzes the request, with three possible decisions:

• accept request for change.
• reject request for change.
• request investigation from a modeler.

In this last case, the request for change passes to status Request Under Evaluation.
Following evaluation, the modeler submits the outcome to the request for change
administrator (the request returns to Submitted Request status). 

When the request has been accepted, the requests for change administrator can decide to complete
or abort it. The request for change then passes to final status Completed Request or Aborted
Request.

 You can customize behavior of requests for change. To do this, seek assistance of a 
MEGA product engineer if necessary.



Using Workflows
Examples of Workflows Supplied as Standard

19

Accessing Requests for Change

In HOPEX Windows Front-End
 Click View > Navigation Windows > Collaboration. 

In HOPEX Web Front-End
1. Open the Teamwork desktop using the “Teamwork User” profile.
2. Expand the My Collaboration Tools folder.

Creating a Request For Change 

To create a request for change:
1. See  "Accessing Requests for Change", page 19.

2. Click the Send RFC  button: 
3. In the dialog box that appears, enter the name of the request for change.

4. In the Related Objects frame, create or connect objects concerned by the RFC, then 
click OK.

5. In the next dialog box, enter a comment and click Next.
 The comment allows you to enter the content of your request and motivate it if 
necessary.

Creation of a request for change also triggers creation of a request for change workflow;
this enables sending of a notification and e-mail concerning the request for change.

6. In the next dialog box, select the recipients of the request for change, then click Finish.

You can also create a request for change from an object. 
1. Right-click the object concerned and select Manage > Send RFC.
2. Enter the comment of the request for change and associate it with recipient users.
3. Click Finish.

Passing to the Next Request for Change Workflow Step
To intervene in the workflow, you must execute a workflow transition, the effect of which is to pass
from one status to another.

To pass to the next request for change workflow step:
1. See "Accessing Requests for Change", page 19.
2. Right-click the request for change.
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3. In the pop-up menu that appears, select RFC State, then the desired state.

 This action executes a workflow transition.
4. In the dialog box that appears, enter a comment for the triggered workflow transition, 

then click Finish.

Using Design Tasks

A design task enables assignment of execution of work to be done in the modeling repository. The
design task assures traceability and check of work carried out by modelers by associating
dispatched modifications with a motive.

 A motive is an object connected to a design task that justifies or explains why the 
design task has been created. The request for change is an example of task motive.

Management of design tasks integrated in HOPEX improves control and analysis of repository
modifications. In particular it offers:

• check of user dispatch rights (the user can be obliged to associate private workspace 
modifications with a design task).

• identification of modifications to be transferred from one repository to another.
 For prerequisites of use of design tasks, see "Design Tasks", page 8. 
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Design Task Workflow
HOPEX delivers a design task management workflow as standard. This workflow enables
management of the life cycles of the different assigned design tasks. 

According to this standard workflow:
• A design task is created.
• It can be:

• assigned to a user responsible for its execution (the executor): it passes from status 
New Task to status Assigned Task.

• assigned later
• The executor can:

• complete the design task:: it passes to status Completed Task
• request its reassignment. 
The creator of the design task can reassign it to another user.

• A reviewer can decide to reassign a design task to another user.
The design task then passes from status Completed Task to status Assigned Task.

• A design task in Completed Task status can be:
• approved: it passes to status Approved Task.
• refused: it passes to status Refused Task.

 You can customize behavior of design tasks. To do this, seek assistance of a MEGA 
product engineer if necessary.
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Possible statuses for design tasks
HOPEX Collaboration Manager enables you to view:

• tasks to complete: these are tasks assigned to the current user
• tasks to validate: these are tasks that the current user must validate, or not
• requested tasks: these are all design tasks assigned to the current user

Accessing Design Tasks

In HOPEX Windows Front-End
To access design tasks:

1. Click View > Navigation Windows > Collaboration. 
2. In the Collaboration navigation window, select one of the task categories mentioned 

above.

To view design tasks connected to a project:
 In the Projects navigation window, expand the Projects folder, then the sub-folder 

corresponding to the project concerned.
The project sub-folder includes tasks connected to the project.

In HOPEX Web Front-End

To access design tasks:
1. Open Teamwork desktop using the “Teamwork User” profile.
2. Expand the My Collaboration Tools folder then My Design Tasks.

Creating Design Tasks

To create a design create:
1. See  "Accessing Design Tasks", page 22.

2. Click Assign Task using the  button.
The dialog box for creating a design task appears.

3. Enter the name of the design task.
4. Indicate the task motive and due date, the project connected to the design task, then 

click OK.
 A motive is an object connected to a design task that justifies or explains why the 
design task has been created. The request for change is an example of task motive.

5. In the dialog box that appears, specify if you want to:
• create the task and assign it
• create the task and assign it later

6. In the next dialog box, enter a comment and click Next.
7. Select the user who must execute the task and click Finish.

The design task is created and if specified, assigned to the selected user.
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Specifying design task motive
Design tasks can be created from:

• a request for change

 A request for change enables expression of a comment concerning change to be 
made to an object.

• a requirement 

 A requirement is a need or expectation explicitly expressed, imposed as a constraint 
to be met within the context of a project. This project can be a certification project or an 
organizational project or an information system project.

These two object types constitute the motive of a design task.
It can be useful, from a request for change, to create and assign a design task to the person
responsible for its execution.

To create a design task from its motive (here, a request for change):
1. See  "Accessing Requests for Change", page 19.
2. Expand the navigation folder corresponding to the request for changes.
3. Right-click the desired request for change and select New > Design Task.
4. In the dialog box that appears, enter the name of the design task and indicate the task 

due date.
5. Click OK.
6. In the dialog box that appears, specify if you want to:

• create the task and assign it
• create the task and assign it later

7. Enter a comment for the design task, then click Next.
8. Select the design task assigned user if required, then click Finish.

The design task is created.

Creating a design task from a project
Design tasks can be created in the framework of a project.

 We can define users with authorization to create tasks in the framework of a project. 
For more details, see "Workflow Participants", page 35 and "Associating persons with 
participants", page 36.

To create a design task from a project:
1. In the Projects navigation window of the Enterprise Architecture desktop, right-click a 

project and select New > Design Task.
2. In the dialog box that appears, enter the name of the design task.
3. Enter the design task motive and due date if required.
4. Click OK.
5. In the wizard that appears, indicate if you want to assign the design task or not to a 

person responsible for its execution.
6. Enter a comment and click Next.

The design task is created and connected to the project.
A design task workflow instance is triggered.

Assigning and Aborting a Design Task

Assigning a design task later
When you created the design task, you were able to create it without immediately assigning it.
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To assign a design task after creation:
 In the list of requested tasks, right-click the unassigned task and select Assign.

Discarding a design task
If a design task has been created but not immediately assigned, it can be aborted.
To abort an unassigned task:

 In the list of requested tasks, right-click the unassigned task and select Abort.

Consulting Design Task Properties
To consult design task properties:

 Right-click a design task and select Properties.
The Characteristics tab allows you to view:

• in the Standard subtab: the design task assigned user.
• in the Advanced subtab:

• the assigner
• the project with which the design task is associated
• the design task motive (requirement or request for change)
• the assignment date
• the completion date (date on which task is completed)
• the resolution date (date on which task is validated)
• the design task due date

The Workflows tab lets you consult the history of triggered workflow transitions:
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Passing to the Next Design Task Workflow Step
To intervene in the design task workflow, you must execute a workflow transition, which enables
passage to the next workflow status.

To pass to the next design task workflow step:
1. Right-click the design task.
2. In the pop-up menu that appears, select Task State, then the desired task.

 This action executes a workflow transition.
3. In the dialog box that appears, enter a comment for the triggered workflow transition, 

then click Finish.
 You can also trigger the workflow transition from the design task properties dialog 
box.
 To view the different possibilities of action on a design task, see "Using Design 
Tasks", page 20.

Selecting a Design Task
From the start of a private workspace, you can also select the design task with which modifications
to the current private workspace will be associated.

To select the design task associated to the current private workspace:
 In the HOPEX Windows Front-End desktop, select the desired task in the Current 

Task drop-down list.

Dispatching as a Design Task
A user can dispatch work in a private workspace as an assigned design task if the task management
function is activated.
When dispatching work in the private workspace as a task, the user associates all dispatched
modifications with the assigned task.
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To dispatch work in a private workspace as a design task:
1. In the following desktop:

• HOPEX Windows Front-End, select File > Dispatch.
• HOPEX Web Front-End, save and quit while dispatching.

2. In the dialog box that appears, select the required design task if you have not already 
done so.

3. If this dispatch contains all the modifications necessary for resolution of the design task, 
select the Complete Task check box.

 You can dispatch work from several private workspaces as the same design task. 
However, you cannot group several design tasks in the same private workspace.

4. Select Yes.

Using the Validation Request Workflow

The diagram that illustrates this validation request workflow is shown below.
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In this workflow, a requester makes a request for validation. The request then passes to status
Validation in Progress. 
A reviewer analyzes the request for validation. He can:

• validation
• invalidate

 This workflow proposes simple implementation of validation requests. You must 
configure it so that it responds to the requirements of your enterprise.
 When validated, the object can be transferred to another repository if required. For 
more details, see "Transfering Objects", page 84.

Requesting validation

To request validation of an object:
1. Right-click the object of interest and select Manage > Validation > Request 

Validation.
 The location of the menu can vary if it has been customized. For more details, see 
"Customizing the Validation Workflow", page 68.

2. In the dialog box that appears, enter a comment to accompany your request and click 
Next.

3. Select a person to be assigned if your workflow requires this and click Finish.
The object subject of a request fro change can no longer be modified. A padlock appears alongside
the object.

 If you are in metamodel expert mode in HOPEX Windows Front-End, the 
Immutability value of the object to validate properties dialog box, General sub-tab, is 
"Protected".

Validating the object 

To validate the object subject of a request for change:
1. Right-click the object and select  Manage > Validation (Validation in Progress) > 

Validate.
 The location of the menu can vary if customized. For more details, see "Customizing 
the Validation Workflow", page 68.

2. In the dialog box that appears, enter a comment if required and click Finish. 
 You can also associate a transfer at this stage. For more details, see "Transfering 
Objects", page 84.

The object is protected. If you want to modify it, you must first unlock it.
 Right-click the object and select Manage > Unlock Object. If you do not have the 
necessary rights to unlock the object, you can request unlocking. For more details, see 
"Making an unlocking request", page 28. 

Refusing object validation

To refuse validation of the object subject of a validation request: 
1. Right-click the object and select Manage > Validate > Invalidate.

 The location of the menu can vary if customized. For more details, see "Customizing 
the Validation Workflow", page 68.

2. In the dialog box that appears, enter a comment if required and click Finish. 
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Using the Unlocking Request Workflow

When an object becomes the subject of a request for change, the object is locked. It can no longer
be modified.

 For more details on the validation process, see "Using the Validation Request 
Workflow", page 26.

After validation of the object, if you want to modify the object you must unlock it. 
 If you do not have the necessary rights to do this, you must make an unlocking 
request. 

The diagram that illustrates this workflow is shown below.

Making an unlocking request
To be able to modify the object after its validation, and if you do not have rights to unlock the object,
you must make an unlocking request.

To make an unlocking request:
1. Right-click the validated object to be modified and select Manage > Unlocking 

Request.
2. In the next dialog box, enter a comment and click Next.
3. Select a person to be assigned if your workflow requires this and click Finish.

A notification is sent to the person responsible for object unlocking.
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Consulting unlocking requests

To consult unlocking requests addressed to you:
1. In the following desktop:

• HOPEX Windows Front-End, select the  Repository Activity navigation window.
• HOPEX Web Front-End, opens Teamwork desktop using the “Teamwork User” 

profile and expand the My Collaboration Tools folder.
2. Expand the My Unlocking Requests folder. 

The unlocking requests that have been addressed to you appear in the "To Evaluate" sub-
folder.

Accepting an unlocking request

To accept an unlocking request:
1. See  "Consulting unlocking requests", page 29.
2. Right-click the unlocking request and select (Object Unlocking Request) > Accept 

Unlocking Request.
The object for which you have accepted the request is no longer protected. It is unlocked
and you can modify it.

 The validation state of the object has become "Not validated".

Refusing an unlocking request
To refuse an unlocking request:

 Right-click the unlocking request and select (Object Unlocking Request) > Refuse 
Unlocking Request.
The object remains protected. It cannot be modified.

 To be able to accept or refuse unlocking requests, you must be authorized to unlock 
protected objects (see repository option Authorize unlocking of protected objects in 
Tools > Options).
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CONFIGURING WORKFLOWS

HOPEX proposes different workflows as standard, which you can customize to suit your
requirements using HOPEX Power Studio.

You can create a workflow and completely configure it, notably using implementation macros. These
macros are used on all object types making up a workflow definition diagram.

Sending e-mails and notifications can also be customized.

You can configure workflows from  HOPEX Windows Front-End.

 You must have MEGA APIs to be able to implement macros. 
See the HOPEX Power Studio - All about starting with APIs guide for more information on 
using HOPEX APIs.

 "Defining a Workflow", page 32
 "Workflow Advanced Configuration", page 52
 "Managing E-mails and Notifications", page 56
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DEFINING A WORKFLOW

To create a workflow, you must create a workflow definition and its associated diagram.
The different objects in the workflow definition diagram and their configuration are presented here.
For more details on workflow configuration, see:

• "Workflow Advanced Configuration", page 52
• "Managing E-mails and Notifications", page 56

Overview of Workflow Definitions

 A workflow definition enables definition of a sequence flow of operations executed by 
persons. When executed, the workflow assures management of the sequence of 
operations and notification of the persons involved. The workflow can be applied to a 
repository object known as the workflow subject. In this case, expected operations are 
related to this object.

Creating a Workflow Definition

To create a workflow definition in HOPEX Windows Front-End:
1. In the Utilities navigation window, right-click the Workflow Definition folder and 

select New > Workflow Definition.

2. In the dialog box that appears, enter the name of the workflow definition and click OK.
The new workflow definition is created.
A workflow must relate to an object type. You can therefore associate an object type with the
workflow definition you have just created.

To define the object type to which the workflow relates:
1. In the properties dialog box of the workflow definition, select the Characteristics tab.
2. In the  Subject MetaClass section, click the Connect button.
3. In the Select Query dialog box, select "Workflow Subject MetaClasses" and click OK.
4. Select a MetaClass and click OK.

 The connected MetaClass must be a sub-class of the "Workflow Subject" or "System 
Workflow Subject" abstract MetaClass.

 A subject MetaClass is a MetaClass to which a workflow definition can be applied. 
Workflows defined by this workflow definition can be executed on instances of this 
MetaClass.
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Several options are available in the workflow definition properties:
• Allow Subject MetaClass Creation: allows the user to create the object to which the 

workflow relates at the moment the workflow is started.
• Allow Subject MetaClass Listing: enables the user to list workflow subjects available 

at the moment the workflow is started.
• Allow Subject MetaClass Query: allows the user to start the query tool to select a 

workflow subject at the moment workflow is started.
• Subject Mandatory: obliges the user when executing the workflow to select the object 

to which the workflow relates.
• Activate Workflow : enables workflow activation or deactivation. 

Users should not access workflows which are in course of definition. For this reason, it is
useful to be able to deactivate a workflow. 

 If the workflow is deactivated, it can no longer be started. The Start Workflow 
menu of the workflow definition is grayed.

For each subject MetaClass you can specify in the corresponding columns:
• Workflow Condition: a condition enables filtering of workflows that can be instanced 

from a subject MetaClass.
It is for example possible to start a workflow on an object type that has a particular characteristic.

 A condition can be used on workflows instanced at creation of the subject when 
several workflow definitions exist for a MetaClass.

• Unique Instancing: enables indication that for a subject instance you can have only a 
single workflow instance in progress.

• Instance at Creation: enables creation of a workflow instance at workflow creation 
that manages the life cycle of the object.

• Main Workflow: enables specification, for a given subject MetaClass, that this workflow 
gives or does not give the main current status. 

 Several workflow definitions can be defined for the same MetaClass. 
However, a MetaClass can only have one main workflow definition.
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To be able to specify the workflow, you must then create the workflow definition diagram.

Accessing workflow definitions

To access workflow definitions:
1. In the Enterprise Architecture desktop, select View > Navigation Windows > 

Utilities.
2. Expand the Workflow Definitions folder.

For each workflow definition, contained elements are displayed in sub-folders:
• workflow definition diagram

see "Creating a workflow definition diagram", page 34.
• workflow statuses

see "Workflow Statuses", page 35.
• workflow transitions

see "Workflow Transitions", page 38.
• workflow participants

see "Workflow Participants", page 35.
• workflow actions

see "Workflow Actions", page 50.

Creating a workflow definition diagram

To create a workflow definition diagram:
1. See  "Accessing workflow definitions", page 34.
2. Right-click the workflow definition and select New > Diagram.
3. In the dialog box that opens, select Create.

The diagram is created.
In a workflow definition diagram, you must:

• create a workflow status of Initial type. 
• create the different workflow statuses and connect these by means of workflow 

transitions. 
• create the last workflow status or statuses of Final type.

 See  "Workflow Statuses", page 35.

• specify persons that trigger transitions: to do this you connect workflow participants to 
the different transitions. 
Persons must be associated with workflow participants.

 See  "Workflow Transitions", page 38.
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Workflow Statuses

To create a workflow status:
1. In the workflow definition diagram, click one of the three workflow status buttons in the 

diagram insert toolbar to create a workflow status:
• Default
• Initial
• Final

 A workflow status corresponds to a step in progress of a workflow defined by a 
workflow definition.

2. Click on the diagram.
3. In the dialog box that opens, enter the name of the workflow status and click OK.

The new workflow status appears in the diagram.

Workflow Participants

Creating workflow participants enables definition of the persons associated with a workflow
transition. 

 A workflow participant enables definition of the set of persons that can be assigned to 
a workflow transition in the framework of execution of a workflow instance.

 A workflow transition connects a source workflow status to a target workflow status. 
A person associated with a workflow transition for a given workflow status can trigger the 
workflow transition, passing the workflow instance from the current source workflow 
status to the target workflow status, which then becomes the current status. By this 
action, the person informs that the operation expected of them has been executed.

This set of persons can be defined at workflow configuration or calculated at workflow execution.
You can create a workflow participant:

• directly in the workflow definition diagram. 
 For more details, see "Creating a participant in a workflow definition diagram", page 
35.

• in the properties of the workflow transition.
 For more details on workflow definitions, see "Workflow Transitions", page 38.

• in the properties of the workflow status.
 For more details on workflow statuses, see "Creating a participant from a workflow 
status", page 36.

Creating a participant in a workflow definition diagram

To create a workflow participant:
1. In the workflow definition diagram, click the Workflow Participant button in the 

diagram insert toolbar, then click in the diagram.
2. In the dialog box that opens, enter the participant name and click Finish.

The workflow participant appears in the diagram.
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Creating a participant from a workflow status
Specifying participants on the workflow status enables:

• factorization and avoiding specification of participants on each output transition of the 
same workflow status.

• on an initial workflow status, indication of who has the right to start the workflow

Associating persons with participants
When the participant has been created, you can connect it to persons. The persons associated with
a participant can trigger transitions between two workflow statuses.

To connect persons to a workflow participant:
 In the properties page for the workflow participate, specify an implementation macro.

 An implementation macro on a workflow participant enables calculation of a set of 
persons at workflow execution.

When creating a macro, a wizard will help you initialize its content. Macro content is initialized with
the list of parameters that can be used to determine the list of persons.
HOPEX Collaboration Manager supplies different macros enabling definition of the set of persons
likely to trigger workflow transitions.

To use a macro in the framework of a participant:
1. In the properties dialog box of the participant, select a macro from the drop-down list.
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2. Click Apply.

A new dialog box appears, depending on the selected macro.
• All users: all persons are selected.
• Specific users: this macro enables explicit specification of a list of persons. You can 

connect roles, persons or profiles.

• Users linked to the subject: this macro enables listing of users via a query applied 
to the workflow subject.
If the workflow subject is a design task, you can define a query that will find project managers of the project 
associated with the design task.

The query must be specified in the _Parameterization text, under section [UsersSet], as
in the example below:

[UsersSet]

QueryFromSubject = ~llC2RbmyELaC[Action Plan Approvers]

• Users having triggered a previous transition: this macro enables specification of 
person(s) who triggered the previous transition.

The previous transition must be specified in the _Parameterization text, under section
[UsersSet], as in the example below:

[UsersSet]



38

2

ProvidingTransition = ~n1uG9GqiBD60[Approve]

Workflow Transitions

Creating a workflow transition

To create a workflow transition:
1. See  "Accessing workflow definitions", page 34.
2. In the workflow definition diagram, click the Workflow Transition button  in the 

diagram insert toolbar, then draw a link between the two workflow statuses concerned.
3. In the dialog box that appears, enter the name of the transition and click OK.

The transition appears in the diagram. 
You must now define certain properties.

 A workflow transition connects a source workflow status to a target workflow status. 
A person associated with a workflow transition for a given workflow status can trigger the 
workflow transition, passing the workflow instance from the current source workflow 
status to the target workflow status, which then becomes the current status. By this 
action, the person informs that the operation expected of them has been executed.

Person selection mode
 Participants can also be specified on the workflow status, in the Participation tab. 

The Participants tab of a workflow transition enables definition of how persons are selected at
assignment of persons to the next workflow status.
Several values are proposed in the User Selection Mode field when configuring the workflow:

• Some Users: one or more persons can be selected in a list. This is a list of users 
authorized to trigger the next workflow transition.

• All Users: all the users associated with the corresponding workflow participant are 
assigned to the next status. No list is proposed.

• One Person: only one person can be selected in the list and assigned to the next status 
(if you select several persons in the list, you cannot trigger the workflow transition).

Information associated with workflow transition
You can allow the user who triggers the workflow transition to specify additional information.
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You can allow the user to:
• add a comment
• specify one or several properties in the form of fields
• attach objects 

 This information can be made mandatory via permissions. For more details on 
configuration of permissions, see "Configuring Permissions on Objects", page 73.

Example of information that can be added on a transition
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To enable entry of additional information on workflow transitions:
 In the properties dialog box of the workflow transition, select the Associated 

Information tab.

Example of configurations on a transition

Enabling comment entry

To offer the user the possibility of entering a comment when triggering a workflow transition:
 Select the Propose a Comment check box.

Adding properties on transitions
To offer the possibility of specifying properties when triggering a workflow transition:

 Create TaggedValues in the Additional Information frame.
At triggering of the corresponding workflow transition, the dialog box proposed to the user
will display the TaggedValues value specified here.

Opening a help tooltip in the transition dialog box
You can display a help tooltip to guide your users at triggering of the workflow transition.

To enter the text to appear in the help tooltip:
 Enter the text to be presented to users in the Warning of Transition frame.

Transition attachments
To offer the user the possibility of attaching HOPEX objects at workflow transition triggering:
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1. Create a motive in the Workflow Transition Attachment Motive frame, for example 
"Items to provide". 

 An object attachment motive specifies the reason for which the objects are used in 
the framework of a workflow transition. 

2. Select the motive, and in its properties dialog box select a collection type, which 
corresponds to a MetaClass.

 The same MetaClass can appear in several motives.
Motives are used particularly:

• in the framework of sending e-mails 
• to list attachments
• to include objects in the form of attachments in the case of documents

 MetaClasses that can be the subject of attachments in e-mails are: documents, 
reports, books, external references.

• to associate objects with a notification
 For more details on configuration of notifications or e-mails, see:
• "Managing objects in notifications", page 58.
• "Managing attachments in e-mails", page 58

When the user triggers a transition, a dialog box proposes connection of objects to be attached. 

Multiple triggering transitions

Reminder of general case concerning workflow transitions
When a transition has been triggered by a user, the workflow instance passes to the next status. 
By default, no other user can now trigger this transition.

Multiple triggering
When the multiple triggering option is activated for a transition, several users can trigger the
transition.
When a user triggers multiple triggering, the workflow instance passes to the next status. Workflow
status properties enable identification of:

• users who have triggered the transition
• users who have not yet triggered

To activate the multiple triggering option:
1. In the workflow transition properties dialog box, select the Participant tab.
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2. Select the Multiple Participation option.

 The multiple transition should not be connected to initial or to final status.

Await user intervention 
You can arrange that intervention of users of a multiple transition is mandatory for the workflow to
continue and pass to the next status.

To do this:
1. On the workflow transition that follows the multiple transition, implement the macro 

"Check Multiple Transition Condition".
 You can duplicate and customize this macro to indicate for example that at least 50% 
of users must have intervened to be able to pass to the next workflow status.

2. Modify the value by default for the Condition Kind and specify that it is a 
"Precondition".

With implementation of this macro, and if all users have not yet intervened, the Next Status
command of the workflow definition pop-up menu is grayed for the user authorized to trigger the
next workflow.
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Viewing users contributing a workflow

To view contributors awaited in the workflow who have not yet triggered a transition:
 In the properties dialog box of the workflow instance, select the Status tab and the 

Status of Contributors subtab.

You can view in this subtab:
• users who have already participated in the workflow (Performed Contributions frame)
• users whose contribution is awaited preventing workflow progress (Expected 

Contributors frame)

Progressing the workflow
HOPEX Collaboration Manager allows to bypass the "Check Multiple Transition Condition" macro
and authorizes progress without awaiting intervention of other users.

To continue the workflow despite the fact that some users have not yet triggered a transition:
1. In the properties dialog box of the workflow instance, select the Status tab.
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2. In the Status of Contributors subtab, click the Allow the workflow to proceed 
button.

The Next Status command of the workflow instance is no longer grayed. The workflow can
continue. Other contributors no longer intervene in the workflow.

Mass transitions
You may need to trigger several transitions simultaneously, that is to pass several workflow
instances from one status to another.

To be able to authorize transition mass triggering:
 In the properties dialog box of a workflow transition, select the value "Yes" in the Mass 

Transition field.

When the workflow is instanced, you can trigger mass transition from:
• subject objects
• workflow instances

To trigger a transition simultaneously on several workflow subjects in the same current status:
 Right-click the subject objects, for example in a navigation tree, and select command 

Mass Transition.
 The instances must be in the same workflow status to enable a mass transition.

Implementing scheduled transitions
Workflow transitions can be triggered on a given date without user intervention.

Example: a workflow transition can be triggered if the workflow remains in the same status for more than ten 
days.
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The triggering date can be relative to a reference date, for example the triggering date of a workflow
transition or instancing of a workflow.

Example: a reminder is sent one week after passage to a particular workflow status.

To define a transition with relative triggering date:
1. In the dialog box of creation of an action, select "Scheduled" execution kind.

 To be able to use the scheduled triggering functionality, you must use the HOPEX 
Collaboration Manageroption. 

2. Click Next.
3. In the Reference Date field, two macros are proposed:

• "Reference date from Subject property"
Macro configuration text can be specified as follows:

[SchedulingDate]

MetaAttribute = [Planned End Date]

 Configuration data entry help is available. To do this, enter the character "[" then 
simultaneously press keys Ctrl + Space.

• "Reference date is transition triggering" 
 This macro does not require additional configuration, since it takes the transition 
triggering date as reference date.

4. In the Start section, specify recurrence conditions and hourly planning.

Conditioning a transition

To condition a workflow transition:
1. In the properties dialog box of a workflow transition, select the Conditions tab.
2. Create a condition and select a Macro.
3. In the Condition Kind field, specify if it is a:

• Precondition
• Post-condition

Precondition
The pre-condition first checks that pre-conditions are met for the transition to be proposed. 
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If conditions are not met, the menu corresponding to the transition is not proposed to the user.
 Specifying a condition on the first workflow transition of a workflow definition is 
equivalent to defining a condition on the subject. For more details, see "Overview of 
Workflow Definitions", page 32 (paragraph concerning workflow conditions).

Post-condition
Possible transition choices are presented to the user. 
if required conditions are not met, a message warns that the transition will not be executed.

 In batch mode, conditions are systematically assessed.

Configuring the workflow transition triggering menu
Workflow subject objects can propose a pop-up menu enabling workflow transition triggering. 

 The "Design Task" MetaClass for example has this configuration as standard.
This pop-up menu comprises a set of menus:

• a menu displaying the state of the object
• several sub-menus presenting the list of workflow transitions that the user can trigger

To create a menu enabling triggering of a transition on an object:
1. In the properties dialog box of the MetaClass concerned, select the User Interface tab, 

Menu Commands subtab. 
2. Create a Command and click its name.
3. In the Macro field, associate the "Workflow Subject Command" macro.
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4. Configure menu display in the _Parameterization section.

 Detailed help  is available at the bottom of the properties dialog box after clicking in 
the configuration area.

Naming the menu 
The "WorkflowState" key enables menu naming. It can be defined via:

• code templates 
• tags [@StatusName@] and [@WorkflowName@]. 

This configuration enables structuring of all menus in the same way.
WorkflowState = ~8bjDw1bEFTtR[Task State] ([@StatusName@])
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Naming the menu for a given workflow definition
The key "WorkflowState%n" enables naming of a menu for a given workflow definition. You must
specify the workflow definition. 

WorkflowState1 = ~9nWjkOxmE95G[Action Plan Workflow], [@StatusName@]

Associating an image with a workflow transition

To associate an image with a workflow transition:
 With the key "Picture%n", specify a workflow transition and an image.

Picture1 = ~X0O81(okB5S2[Reconsider],~Zimg8ZhWBrn0[Design Task]

Picture2 = ~R3O827okB550[Assign],~(f3u5nUnBvH1[Design Task Assigned]

Hiding the menu of a workflow definition
The key "FilterMode" enables hiding of the menu of a workflow definition. Two values are possible:

• "All"
The value "All" is default behavior. All workflow menus are presented.

• "List"
The value "List" enables display of only those menus associated with the workflow
definitions you want to propose. Only those menus for which the key " WorkflowState%n
" was specified are presented.

The configuration below enables proposal of only the menu for the "Action Plan Workflow" workflow
definition. No menus are proposed for other possible workflows.

WorkflowState1 = ~9nWjkOxmE95G[Action Plan Workflow], [@StatusName@]

FilterMode = List

Hiding the state of the object
The first level in the menu concerns the state of the object. You can choose to hide it and display
only the workflow transitions.

Managing transitions at reassignment
When a transition is triggered, the responsible of the next transition is calculated.
If assignment of a person is modified, it may be necessary to re-trigger the previous workflow
transition to update the next transition responsible.
Two cases can arise:

• case of back transitions
• case of loop transitions

 In workflows supplied as standard, back and loop transitions are not used in normal 
workflow processing. They are reserved for the administrator to process exceptional 
cases.

Back transition
When assignment modification infrequent, it may be sufficient to use back transitions.
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In the example below on the Recommendation workflow, if the recommendation is in status “Action
Plan to be submitted” and the recommendation owner changes, the administrator can:

• execute the “Ask for recommendation to be resent (Admin)” transition, and 
• re-execute the “Send out recommendation” transition to update the recommendation 

responsible of the next transition

Loop transition
When person assignment changes are frequent, you can add a loop workflow transition on the
status of the workflow concerned.
For example, in the "Top-Down Action Plan" workflow, a loop transition has been added on the "To
be sent" state. In this way the action plan creator can easily reassign the action plan approver.
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Workflow Actions

 A workflow action enables association of a processing execution with triggering of a 
workflow transition (processing execution can be postponed until dispatch or a later 
scheduled date).

You can create a workflow action:
• on a workflow transition

 For more details, see "Workflow Transitions", page 38.

• on a workflow status 
 For more details, see "Workflow Statuses", page 35.

Configuring a workflow action on a workflow status
It can be useful to specify a workflow action on a workflow status:

• to trigger a scheduled transition 

Example: an action is triggered 10 days after the arrival of a workflow transition in the status

 For more details, see "Implementing scheduled transitions", page 44.

• to factorize and avoid avoid specifying the same action on various workflow transitions
 When a transition is triggered, it is the action specified on the target (and not source) 
status that is implemented.

Creating a workflow action
Execution of a workflow action is by implementation of a macro. The macros proposed as standard
enable execution of different types of action.

To create a workflow action:
1. See  "Accessing workflow definitions", page 34. 
2. In the workflow definition diagram, click the Workflow Action button in the diagram 

insert toolbar, then click in the diagram.
The action creation wizard opens.

3. Create an implementation macro or select a macro corresponding to the required action:
• "Automatic triggering of a transition": when the transition is triggered, you can 

automatically trigger another transition
 For more details, see "Implementing scheduled transitions", page 44.

• "Automatic triggering of a transition with interaction"
 For more details on macros with workflow interaction, see "Implementing Workflow 
Interactions", page 54.

• "Send mail"
• "Send mail with interaction workflow"
• "Send notification"
• "Send notification with interaction workflow"

 For more details on macros for sending notifications or e-mails, see "Configuring 
Actions with Message or Notification", page 56.

• "Update attribute for subject"
 For more details, see "Managing object status with a specific attribute", page 53.
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4. Select the execution type:
• Immediate
• Scheduled

 For more details on scheduling transitions, see "Implementing scheduled transitions", 
page 44.

• At dispatch
Depending on the implementation macro selected and the execution type, different dialog
boxes appear.

5. Click Finish.
6. In the diagram, connect the action you have just created to the workflow transition (or 

status) required.
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WORKFLOW ADVANCED CONFIGURATION

Managing Workflow Object Statuses

In HOPEX Collaboration Manager, the status of an object can be specified in two ways:
• with a generic attribute
• with a specific attribute 

Managing object status with the generic attribute 
The workflow engine supplies the generic attribute "Current Workflow Status". 
It appears in the Characteristics tab of the properties dialog box of the workflow subject (or
system workflow subject). 

 This attribute is a calculated attribute of identifier type. It contains the identifier of a 
workflow status.

Several workflow definitions can be associated with an object. Among these workflow definitions
however, only one can supply the object status. 

To specify the workflow definition to be taken into account for object status calculation:
1. See  "Accessing workflow definitions", page 34.
2. Open the properties dialog box of the workflow definition.
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3. In the Main Workflow field, select value "Yes".

 Several workflow definitions can be defined for the same MetaClass. 
However, a MetaClass can only have one main workflow definition.

 This is the link between the workflow definition and the subject MetaClass.

Managing object status with a specific attribute 
In certain cases, it can be useful not to use a generic attribute defined at workflow engine level to
manage object state. This can be the case when certain workflow statuses are considered too
technical and the end user does not wish them to be visible. Here it consists of displaying a workflow
state independent of workflow status.
HOPEX Collaboration Manager enables establishment of mapping between a specific attribute
and the workflow status.
The generic macro Updating Attribute for Subject enables execution of an attribute update
according to the current workflow status.
To carry out this configuration, you must:

• define an action.
• associate this action with the generic macro "Updating Attribute for Subject".
• establish mapping between the attribute and the workflow statuses.

This configuration is carried out in the "_Parameterization" text.
• connect the action to each transition on which you want to update the attribute.

To establish mapping between the specific attribute and the workflow statuses:
1. See  "Accessing workflow definitions", page 34.
2. In the action properties dialog box, select the Characteristics tab.
3. In the _Parameterization frame, insert a section [MappingSet].
4. Indicate the identifier of the specific attribute you previously created.

<MappingAttribute>=<AttributId>
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5. Create the link between:
• a MetaAttributeValue of the attribute
• a workflow status

<Mapping%i%>=<MetaAttributeValueId>,<WorkflowStatutId> 

Implementing Workflow Interactions

Workflow interactions principle
From a workflow instance you can act on one or several other workflow instances: this is a workflow
interaction.
The workflow interaction calls:

• A source workflow: workflow from which the transition is triggered.
• A target workflow: workflow called from the source workflow.

Example: in the framework of a workflow on action plans, when a workflow is triggered, actions owned by 
the action plan must be triggered.

You can configure workflow interactions on:
• a workflow action
• a workflow condition

Configuration of a workflow interaction is carried out in two stages. You must use and configure:
• a workflow action macro
• a workflow interaction macro

 Configuration of macros delivered as standard is explained in the HOPEX interface, 
in the tooltip describing the macro. 

Workflow interaction macros
Workflow action macros call workflow interaction macros, which indicate how to access target
workflow instances from the source workflow instance. 

to create a workflow interaction macro:
 Implement the following method: 

String getWorkflowInstanceTarget

)

Context as WorkflowContextAction,

mgcollWorkflowInstanceTarget as MegaCollection
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where:
• Context is the workflow interaction execution context. This context uses the 

WorkflowContextAction interface.
• mgcollWorkflowInstanceTarget is the collection of target workflow instances. It is empty: 

you must fill it.

Workflow interaction examples 

With e-mail sending
A user triggers a final workflow transition from a design task. An e-mail is sent to the person
responsible for the request for change (if there is a request for change). The e-mail is to be sent
only if the request for change is in course of processing.

To configure this workflow interaction:
1. Create an action with the macro "Send mail from transition with interaction workflow", 

with the following configuration:
"Workflow=Target"

2. Use the workflow interaction macro "Interaction workflow defined with the Subject link 
on workflow action" with the following configuration:

[WorkflowInteraction]

SubjectLink = ~WceoJb1gEz7R[Motive system of task]  

 The link used is [Design task.Motive of task]
[WorkflowTargetCondition]

WorkflowStatus = ~AwMZq391FDML[Request in progress]  

The e-mail is sent if the request for change is in "Request in progress" status.

With notification sending
As standard, an interaction exists between:

• the workflow definition of design tasks 
• the workflow definition of requests for change 

When the last task corresponding to a request for change is completed, a notification is sent to the
owner of the request for change.

 For more details on requests for change, see "Using Requests For Change", page 17.
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MANAGING E-MAILS AND NOTIFICATIONS

You can parameterize emails and notifications sent within the framework of workflows.

Configuring Actions with Message or Notification

When you create an action to configure e-mail and notification sending, you can configure fields
defining:

• recipients
• subject
• the message body or the notification sent to persons concerned

 For more details on actions, see "Workflow Actions", page 50.

Defining text 
The text of a message or notification can be defined in their properties dialog boxes, or in the
workflow action creation dialog box (message or notification).

 See  "Workflow Actions", page 50.
To define the text displayed in a mail or notification, you can:

• enter free text
• use tags 

These tags can be used :
• in the subject of the message or notification

 The subject corresponds to the first line of the message or notification comment.

• in the body of the message or notification

Defining recipients
Tags also enable definition of message or notification recipients. 
In the case of a message, an e-mail address can be entered directly.
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Help on tags
Help on tags used is available in the properties dialog box of a workflow action.

 See also "Workflow Actions", page 50.

 Enlarge the context-sensitive help pane at the bottom of the dialog box to improve 
view of the tag description. 

Managing Languages

You can specify the language in which you want to send workflow notifications and messages.

Notification languages
All languages specified in the body of the notification are taken in the notification.
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E-mail language
E-mails sent following triggering of workflow transitions are:

• in the language of the enterprise specified in options and
• in the language of the user if different from language of the enterprise

To specify the language of the enterprise regarding workflow e-mails:
1. In HOPEX Windows Front-End select Tools > Options.
2. In the left pane of the window, select Collaborative Environment.
3. In the right pane, Language of e-mails field, select the required language and click 

OK.

Managing Objects and Attachments

Managing objects in notifications
The objects you have added on a workflow transition can be added to the notification in the form of
a link.

 Object types that can form a link in the notification must be associated with the 
abstract MetaClass "Notification Related Object".
 For more details on objects added on a workflow transition, see "Transition 
attachments", page 40.

To add objects to the notification in the form of a link:
1. See  "Accessing workflow definitions", page 34.
2. Define a workflow action on a transition or a workflow status and select a macro enabling 

sending of a notification.
 For more details, see "Creating a workflow action", page 50.

3. In the properties dialog box of the workflow action on the transition, select according to 
your requirements:
• the Attach the Subject check box, to add to the notification a link to the workflow 

subject
• a macro, in which you must implement the following method: 

Void getAttachments (ActionContext, AttachmentObjectCollection)

• a query: relating to the subject, if present
• a motive: all objects corresponding to the motive are added to the notification.

When you execute the workflow, the notification received contains a link to the objects indicated.

Managing attachments in e-mails
In an e-mail, objects you have added on a workflow transition can be the subject of an attachment.

 For more details on objects added on a workflow transition, see "Transition 
attachments", page 40.

To be able to transform the object into an attachment:
1. See  "Accessing workflow definitions", page 34.
2. Define a workflow action on a transition or a workflow status and select a macro enabling 

sending of an e-mail.
 For more details, see "Creating a workflow action", page 50.
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3. In the properties dialog box of the workflow action on the transition, connect according 
to your requirements:
• a macro 
• a query
• a motive: all objects corresponding to the motive are added to the e-mail.

Indicating a URL in an E-mail

To be able to add the URL to the HOPEX Web Application in an e-mail, you must previously specify
access to HOPEX  in user options. 

 For more details, see HOPEX Administration - Supervisor, chapter "Managing 
users", paragraph "Managing Users from the Administration Desktop (Web)".

You must specify the URL in the body of the message. To do this, you can select an object:
• directly via an absolute identifier (IdAbs=), 
• by using a query (Query=)

The query relates to the workflow subject or to the repository root (GetRoot)
• by using a Macro(Macro=) 

The macro must implement the function getUrlObject(WorkflowContextAction) which
returns an object.

• by using a workflow subject (Subject).

Adding a URL
To add a URL:

1. Open the properties dialog box of the workflow action corresponding to sending of the e-
mail.



60

2

2. In the Characteristics tab, configure the body of the message as indicated in Help.
  To access help, click the Mail Body field. The detail of configuration of body 
of the message appears at the bottom of the dialog box.

This configuration returns the text of a link of URL type, enabling access to an object from
an e-mail.

Opening the application on a specific tab
To allow the user to directly access the appropriate tab in the application, you must carry out an
additional configuration, which consists of:

• create an affinity and connect it to the appropriate Desktop Container.
see "Creating an affinity and connecting it to a Desktop Container", page 61. 

 A Desktop Container corresponds to a tab in the application.

• configure the workflow action concerned.
see "Configuring the workflow action", page 61.

 For more details on affinities and Desktop Containers in general, see technical article 
HOPEX Power Studio - Versatile Desktop.
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Creating an affinity and connecting it to a Desktop Container

To create an affinity and connect it to a Desktop Container:
1. In the MetaStudio navigation tab, expand the folders to reach the desktop for which 

you wish to configure access.
2. Select the target Desktop Container.

 The Desktop Container concerned must be at the lowest level in the desktop tree.

3. In the properties of the Desktop Container, select the Candidates & Affinities tab.
4. Create an affinity, and in the Affinity Behavior field, select the value "Replace".

In the example above, an affinity is connected to the "Audit Home" desktop, which
corresponds to the Home navigation tab of the HOPEX audit solution. 

This affinity will serve to complete the URL specified in the workflow action corresponding
to message sending.

This configuration is supplied by default. If you have customized the standard workflow, you must
also perform this customization. 

 For your own workflows, you must create and connect an affinity to the appropriate 
"Desktop container" in the same way.

Configuring the workflow action
You must now configure the workflow action concerning e-mail sending by referencing the
previously created affinity.
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To configure the corresponding workflow action:
1. In the workflow definition diagram of the workflow to be modified, right-click the 

workflow action to be configured and select Properties.

2. In the properties of the workflow action, select the Texts tab and in the drop-down list 
select Mail Body.
In the message configuration  text, you must complete URL configuration by adding a a
string of this type:

,Affinity=~OhiFhJ5eJXd9[Audit Home Affinity]

Example of text to be inserted in body of message 
[@DisplayName=~htNzOjVgGHTM[To access the application and execute your task,]@] 
[@Url,Subject,Tool=PropertyPage,Application=~2zopd2TnFDcL[GRC 
Solutions],Desktop=~2hrUiL8DGX58[Audit],Name=~w7LgEpROGXPB[Click 
here],Affinity=~OhiFhJ5eJXd9[Audit Home Affinity]@]. 
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Result obtained
When the user clicks a link in the e-mail received, the application opens on the Home tab, as below:
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MANAGING WORKFLOWS

This chapter is intended for the HOPEX administrator. It describes how to manage workflows. 

An administrator needs to carry out a certain number of administration tasks concerning workflows.
Examples: stopping a workflow in progress or deactivating workflow options.

 "Workflow Administration Options", page 66
 "Configuring Standard Workflows", page 67
 "Stopping a Workflow Instance", page 70
 "Viewing Workflows in Progress", page 71
 "Managing Workflow Users", page 72
 "Managing Permissions on Workflows", page 73



66

3

WORKFLOW ADMINISTRATION OPTIONS

Accessing Workflow Options

To access the option enabling workflow administration:
1. In HOPEX Administration, open the desired environment.
2. Expand the User management folder of the environment.
3. Right-click the Users folder and select Manage.
4. In the user management dialog box, select the Persons tab.
5. Right-click the desired person and select Options.
6. In the left pane of the window that opens, select Collaborative Environment

Workflow Display RIghts
To give a user the rights to display workflows:

7. Access the workflow options as described in the section "Accessing Workflow Options", 
page 66.

8. Expand the Collaborative Environment and in the right pane, select the "See the ... 
of all users" options in question.

 You can authorize display of all:
• requests for change
• design tasks
• validations
• unlocking requests
• workflows
• notifications

Workflow Administration Rights

To give a user the rights to manage workflows:
1. Access the workflow options as described in the section "Accessing Workflow Options", 

page 66.
2. Expand the Collaborative Environment folder, and in the right pane, select the 

Workflow Administrator checkbox.
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CONFIGURING STANDARD WORKFLOWS

When configuring a workflow supplied as standard, you may need to:
• add MetaClasses to extend the list of object types to which validations and requests for 

change apply.
• configure the Collaboration tree, for example by adding folders in the Collaboration 

navigation window (in the case of adding new workflow statuses).
To do this, see the HOPEX Power Studio - Studio technical article, chapter 
"Configuring Navigation Trees".

 Configuring a workflow requires expertise in MEGA APIs. You can if necessary seek 
the assistance of a product engineer. For more details, see "HOPEX APIs", page 33.

Customizing Workflows

Adding a MetaClass 
You can add MetaClasses that might be the subject of validation requests and requests for change. 

To add a MetaClass to be validated:
1. Open the properties dialog box of the MetaClass you wish to add.
2. Select the Characteristics tab, then the Advanced subtab.
3. In the SuperMetaClass frame, click the Connect button to select abstract MetaClass 

"Validation Candidate Object".

To add a new MetaClass that could be associated with a request for change:
1. Open the properties dialog box of the Request for Change MetaClass.
2. Select the Characteristics tab, then the Advanced subtab.
3. In the SuperMetaClass frame, click the Connect button to select abstract MetaClass 

"Request for Change Related Object".
 The operations described above do not require prior duplication of the workflow 
definition.
 For more details on abstract MetaClasses, see the Studio guide.

Duplicating a workflow definition
You can initialize a new workflow definition by duplicating an existing workflow definition. Similarly,
when you wish to configure a workflow supplied as standard, you must duplicate the corresponding
workflow definition.

 Do not modify the workflow definitions proposed by HOPEX to avoid loosing 
modifications when updating to a new version of HOPEX.

To duplicate a workflow definition:
1. From the Utilities navigation window, expand the "Workflow Definitions" folder.
2. From the pop-up menu of the workflow definition, for example "Request For Change", 

select Duplicate.
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3. Enter the name of the new workflow definition, as well as the prefix or suffix used to 
name duplicated objects.
The new workflow definition is displayed in the "Workflow Definitions" folder.

When the workflow definition has been duplicated, you must:
• deactivate the obsolete workflow definition
• activate the duplicate of the workflow definition when you have completed specification

To activate or deactivate a workflow definition:
 In the workflow definition dialog box, select or clear the Active Workflow Definition 

check box.
 If the workflow definition is deactivated the workflow cannot be started. 

Customizing the Validation Workflow

It is possible tp modify the location of the valdiation request command in an object pop-up menu.
For more details on the validation process, see "Using the Validation Request Workflow", page 26.
The menu command is by default located in the “Manage” group:
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To change the location of the command in the object pop-up menu:
 Select the following MetaCommandManager and in the property page Settings tab enter 

a text as follows:

The above syntax enables you to position the command in the “Action” section, as follows:

Possible categories are as follows:

Command 
group

Description of the 
command group Command examples

Action Action / Activation on 
an object

Generate, Derive, Prototype, 
Quantify

Description Object description Open, Zoom, Flowchart

Entry Object characteristics Attributes, Operations, Navigabi-
lity >, Cardinality >

Documentation Publication / Docu-
mentation

Document, Reference

Display Presentation Display, Format, Drawing

Clipboard Clipboard Copy, Paste, Disconnect

Container Applicable to a collec-
tion of objects

Add to Favorites, Delete

Explore Exploration Explore, Compare

Manage Administration Manage > 
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STOPPING A WORKFLOW INSTANCE

You may need to stop a workflow instance at all times.

To stop a workflow instance in progress:
1. From:

• HOPEX Windows Front-End: In the Collaboration navigation tree, expand the My 
Workflows folder.

• HOPEX Web Front-End: In the Teamwork desktop, expand the My Collaborative 
Tools navigation pane. 

2. In the list of workflows in progress, right-click the workflow concerned.
3. In the pop-up menu that appears, select Stop Workflow.

The workflow is stopped.
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VIEWING WORKFLOWS IN PROGRESS 

To view the user assigned to the next workflow status:
1. From:

• HOPEX Windows Front-End: In the Collaboration navigation tree, expand the My 
Workflows folder.

• HOPEX Web Front-End: In the Teamwork desktop, expand the My Collaborative 
Tools navigation pane. 

 To access the Teamwork desktop, see "Consulting Workflows in HOPEX Web Front-
End", page 13.

2. In the list of workflows in progress, right-click the workflow concerned and select 
Properties.

 In HOPEX Web Front-End, the properties dialog box appears when you click the 
workflow instance.

3. Select the Status tab, then the Current Status subtab. Persons are displayed in the 
Assigned Persons frame.

 To stop and view workflows in progress, the View workflows of all users option 
must be activated (see "Workflow Administration Options", page 66).
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MANAGING WORKFLOW USERS

To manage the users of workflow instances you must have administration rights for workflows.
 For more details, see "Workflow Administration Rights", page 66.

In this context, "workflow user" corresponds to the list of users that can trigger a workflow
transition.

To manage workflow users:
1. Right-click the on the workflow instance or the subject object of the workflow and select 

Manage Participants.
The users who can trigger the next workflow transition appear.

 If different workflow transitions are possible and different participants were defined 
for each of them in the workflow definition, HOPEX provides a list of transitions.

2. Click on a transition to modify the assigned users.
The users currently assigned appear.
You can remove a user and add another in the list provided for this purpose.

Example of how to use this functionality
Mrs. White was assigned to perform a particular transition (Request Evaluation, for example). If she is on 
holiday and the workflow must take place in her absence, you can add or remove another user here.

This user can connect to MEGA and perform the transition on behalf of Mrs. White.
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MANAGING PERMISSIONS ON WORKFLOWS

Configuring Permissions on Objects 

You can configure permissions on objects according to:
• user profile
• current workflow status.

To configure permissions:
1. In HOPEX Administration, open the desired environment.
2. Expand the User management folder of the environment.
3. Right-click the UI Access folder and select Manage.
4. In the UI access management dialog box, select the Object UIs tab.
5. In the Profile field, select the Profile you want to configure.
6. In the MetaClass frame, select the workflow subject MetaClass.

Example: "Action plan"

7. In the Workflow Definition section, select the workflow for which you want to define 
permissions.

8. Configure permissions on the MetaClass subject of the workflow according to the status 
reached by the workflow.

Example: The permission "R" (=Read) in status "Closed" means that you cannot modify the action plan 
when it is in this status.



74

3

9. Similarly configure attributes and links available on this MetaClass. 

Several values are possible on workflow statuses or transitions:
• indicates that the field (attribute or link) is mandatory in this workflow status.

The user must specify this field to trigger the next workflow transition.
• " RU" (R=Read, U=Update): on a workflow transition, means that the field is proposed in 

edit mode in the user interface proposing the transition. 
 "RUM" means that the user must specify the field when triggering the workflow 
transition.

Different permissions can be specified for workflow participants and non-participants:
• Values of permissions in upper-case, for example "RU" concern workflow participants.
• Values of permissions in lower-case, for example "ru" concern persons not participating 

in the workflow.
 In theTransition Attributes frame, you can specify permissions on TaggedValues 
created on your workflow transitions. For more details, see "Information associated with 
workflow transition", page 38.

Specifying Persons Authorized to Start a Workflow

To specify persons authorized to start a workflow, see "Associating persons with participants", page
36.

Generating a Report of Permissions by Workflow Definition

A report allows you to detail permissions for a given workflow.
This report is available with HOPEX Administration.
You have the choice of main parameter:

• a workflow definition
• a profile
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Generating the report from a profile

To generate this report:
1. In the menu bar, select Tools > Manage Profiles and Permissions > Workflow 

Definition Permissions Reports.
A wizard opens.

2. (Optional) In the Report File field, modify the location in which to save the report. By 
default this is your user folder.

3. Select By profile for report configuration.
4. Select the Profile that interests you.

The list of workflow definitions in which the workflow can intervene appears.
You have two possibilities:
• you do not select any workflow definition: the report displays permissions of the 

profile on all workflows in the list.
• you select one or several workflow definitions: the report displays permissions of the 

profile on the selected workflows.
5. Click OK.

The report is generated.

Generating the report from a workflow definition

To generate this report:
1. In the HOPEX Windows Front-End desktop, select Tools > Manage Profiles and 

Permissions > Workflow Definition Permissions Reports.
2. Select By workflow definition for report configuration.
3. Select the workflow definition that interests you.

The list displays profiles that can intervene in the workflow.
You have two possibilities:
• you do not select any profile: the report displays permissions relating to the workflow 

for all profiles in the list.
• you select one or several profiles: the report displays permissions relating to the 

workflow for all selected profiles.
4. Click OK.

The report is generated.

Report content
For each workflow given as parameter, the wizard queries the MetaClass to which the workflow
relates.
The generated Excel worksheet includes all permissions on each MetaClass:

• for each profile 
• workflow status /workflow transition. 

 For improved readability, missing permissions are replaced by _.
For example: *RU is replaced by *_RU_. 
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MANAGING REPOSITORY TRANSFERS 

Presented here are use cases of the alignment functionality, as well as modes of  transfer to a
production repository.

HOPEX Collaboration Manager enables transfer of objects from their original repository (source)
to a destination repository (target). 

 For more details on the Compare and Align feature underlying the alignment feature, 
see the HOPEX Administration - Supervisor guide.

 "Alignment Use Case", page 78
 "Modes of Transfer to a Production Repository", page 80
 "Transfering Objects", page 84
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ALIGNMENT USE CASE

In teamworking, it can be difficult to work on a single repository, projects and diagrams not all
having the same production cycles. Certain diagrams are in course of creation, while others can be
already validated or requiring update.

Implementing a Production Repository

It may be necessary to install a production repository so as to have permanently available models
ready for dispatch.
This production repository is supplied by work carried out in the work repository when it is ready
for dispatch.

Transfering Objects Between Repositories

It can sometimes be necessary to transfer objects between repositories in a context other than that
of the production repository.

 In these contexts, it can be necessary to define strict modeling rules to avoid 
conflicts.
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Some examples:
• Distinct projects and integration repository

Modeling projects are initiated in distinct repositories. They are then transferred to an 
integration repository.

• Shared models
Models are created in a single repository. They are then used in projects, each of which 
results in creation of a repository.
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MODES OF TRANSFER TO A PRODUCTION REPOSITORY

There are several possible modes of transfer of objects to a production repository.

Organizational and Technical Choices

Organizational choices impose constraints and influence the choice of transfer mode. Certain
questions should be asked:

• Are modelers responsible for dispatch of their work?
• Is validation necessary before dispatch of models? 

Large teams generally require a validation step, which is not necessarily required by 
small teams.

• Which event triggers object transfer or validation?
• Who triggers transfer (modeler or validator)? From which repository (source repository 

or target repository)?
Depending on the selected organization, use of Compare and Align can be supplemented by:

• design tasks
• validation workflow
• definition of perimeters, using the HOPEX Power Studio technical module.

 For more details, see the technical article "Customizing Perimeters".

• import/export files

Transfering Objects in Push Mode

"Push" mode allows the user to transfer modifications from the work repository. It is not necessary
to connect to the production repository. 

"Push" mode without validation
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Variants are possible:
• transfer triggered at dispatch
• transfer with simultaneous dispatch

"Push" mode with validation 
Data transfer by compare and align can be automatically triggered with installation of a
validation workflow

Transfering Objects in Pull Mode

"Pull" mode requires connection to the production repository. Modifications are imported in a private
workspace from the target repository. 
If transfer is under the responsibility of users working in the source repository, this mode can prove
to be restrictive. In this context, users connected to the source repository must:

• dispatch their private workspace in the work repository (source repository) and exit 
HOPEX

• open a private workspace in the target repository
• import objects from the target repository
• dispatch the private workspace in the target repository
• open a new private workspace in the work repository (source repository) to continue 

modeling work
If however the transfer is under the responsibility of users controlling the transfer result before
dispatch, "pull" mode has the advantage of allowing private workspace discard if necessary.
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"Pull" mode with validation

• A model cannot be modified while it is awaiting validation
• These modifications are saved in the private workspace. The private workspace is 

dispatched if the model is validated.

"Pull" mode with use of design tasks

It may be necessary to check dependencies between tasks before export/import of the logfile.

Automatic alignment
The production repository is updated at the time of dispatch (1). 
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A "job" macro (2) automatically triggers alignment (3)
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TRANSFERING OBJECTS

The HOPEX Collaboration Manager option allows you to transfer validated objects from one
repository to another.
By default, only libraries can be transferred.

 Other object types can however be transferred. To do this, you must first connect the 
corresponding MetaClass to the "Transfer Candidate Object" abstract MetaClass.

Principle

Validated objects can be automatically transferred to another repository.
 For more details on validation, see "Using the Validation Request Workflow", page 
26.

To be able to automatically transfer validated objects, you must first:
• create a transfer
• add the object to the transfer

Creating a Transfer

To create a transfer:
1. In the Repository Activity navigation window, expand the Transfer Management 

folder then the Transfer Folder sub-folder.
2. Right-click the Not Scheduled Transfers sub-folder and select New  Transfer.
3. In the creation of transfer dialog box, select a transfer template if required and click 

Next.
4. In the transfer definition dialog box, enter the necessary elements if the transfer 

template has not already specified these.
• source repository
• target repository
• transferred object

5. Click Next.
6. If required, select a person to be informed in the Informed User frame.
7. Click Finish.
8. In the final dialog box, select the transfer execution mode:

• Execute at scheduled date (specifying date/time in the Scheduled Transfer Date 
Time field)

• Execute as soon as possible
 You can schedule transfer later. See  "Scheduling a Transfer", page 85.

9. Click OK.
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Scheduling a Transfer

When the transfer has been created, you must schedule it.

To schedule a transfer (if not scheduled at the time of its creation):
1. In the Repository Activity dialog box, expand the sub-folder Transfer Management 

> Transfer Folder > Not Scheduled Transfers.
2. Right-click the transfer concerned and select Schedule Transfer.
3. In the dialog box that appears, select:

• execution mode "Execute at Scheduled Date and Time"
• the date and time concerned

4. Click Finish.
When scheduled, the transfer appears under the Scheduled Transfers  sub-folder.

Adding an Object to a Transfer

To add an object to a transfer:
1. Right-click the object to be transferred and select Add to Transfer.
2. In the list that appears, select the required transfer and click OK.

 You can schedule the transfer at object validation. 

Transfering the Object

The object can be transferred:
• if it has been validated
• if it has been added to a transfer

The object is transferred:
• immediately if the transfer has not been scheduled
• at a time specified in transfer scheduling

 The transfer is executed in the name of the person who saved the transfer.

Managing Transfers and Transfer Templates

To view the transfers:
1. In the Repository Activity navigation window, expand the Transfer Management 

folder.
2. In the Transfer Folder sub-folder, you can view:

• not scheduled transfers
• scheduled transfers
• executed transfers
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To create a transfer template:
1. In the Repository Activity navigation window, expand the Transfer Management 

folder.
2. Right-click the Transfer Templates folder and select New > Transfer Template.
3. Indicate:

• a source repository
• a target repository
• the object to be transferred

4. Click Finish.
 You can now use this transfer template when creating a transfer.
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REPOSITORY SNAPSHOTS

A repository snapshot identifies an archived state of the repository. The repository administrator or
functional administrator may need to create snapshots to record important states in the repository
life cycle.

Repository Snapshots are necessary for use of certain functionalities such as the comparison of
diagrams, the transfer of objects and the view of the repository at an earlier date.

 "Managing Repository Snapshots", page 2
 "Repository Snapshots Use Case", page 6
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MANAGING REPOSITORY SNAPSHOTS

See:
• "Prerequisites", page 2
• "Creating Repository Snapshots", page 2

Prerequisites

To be able to use repository snapshots, you must:
• have an RDBMS format repository

 For more details on creation of an RDBMS format repository, see 
"Repository - RDBMS Installation Guide".

The repository log must be activated (default case for an RDBMS
repository).

 For more details on repository log activation, see the administrator 
guide, "Managing Repositories", "Consulting and Modifying Repository 
Properties".

• select the "Authorize management of repository snapshots in the 
workspace" (Options > Collaborative Environment)

 This option is not necessary if you have used the Administration 
application to create repository snapshots.

• set up a procedure for taking account of repository snapshots before 
deletion of historical data.
A repository snapshot identifies an archived state of the repository. When
an archived state of the repository has been deleted, it is no longer
possible to create a repository snapshot corresponding to this state. It is
therefore important to take management of repository snapshots into
account when deleting historical data (in the repository contextual menu,
RDBMS Administration > Deletion of historical data for
repository).

 For more details, see "Repository - RDBMS Installation Guide", 
"HOPEX Historical Data Cleanup". 
 You do not require the Administration application to create 
repository snapshots. Your associated profile must have the option 
"Enable repository snapshots management in the workspace" (Options 
> Collaborative Environment).

Creating Repository Snapshots

 You can create a repository snapshot for RDBMS format 
repositories.
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You can create repository snapshots from:
• Administration applications (Windows Front-End and Web Front-End)
• HOPEX (Windows Front-End) 

The "Authorize management of repository snapshots in the workspace" 
option must be selected (Options > Collaborative Environment)

Creating a repository snapshot from the Administration application

Windows Front-End

To create a repository snapshot from HOPEX Administration:
1. Launch HOPEX Administration application ("Administration.exe").
2. Connect to the environment with a user that has an Administrator 

profile.
 See the "Connecting to an Environment" procedure in the HOPEX 
Administration - Supervisor guide.

3. Expand the Repositories folder.
4. Expand the repository folder concerned (RDBMS format).
5. Right-click the Repository Snapshots folder and select Manage.
6. In the repository snapshots management window, click New .

A creation wizard appears.
7. Select the criterion to be used to find the state of the repository to be 

captured:
• Design tasks
• Dispatches

8. Click Next.
9. In the Local Name field, enter the repository snapshot name.
10. Select the task/dispatch
11. Click Finish. 



4 1

1

12. (Optional) Add other repository snapshots, repeat steps 6 to 11.
You obtain a list of snapshots, irrespective of the criterion selected for
snapshot creation (design task or dispatch).

 In all cases, repository states correspond to the moment data is 
dispatched.
 In the snapshot management dialog box, you can delete snapshots 
or view their properties.

Web Front-End

To create a repository snapshot from the HOPEX Administration desktop:
1. Connect to the HOPEX Administration desktop.

 See the "Connecting to the Administration desktop" procedure in 
the HOPEX Administration - Supervisor Web guide.

2. Click Repository Management> Snapshot Management > 
Snapshots.

3. In the edit area, in the Snapshots tab, click New .
A creation wizard appears.

4. Select the criterion to be used to find the state of the repository to be 
captured:
• design tasks
• Dispatches

5. Click Next.
6. In the Local Name field, enter the repository snapshot name.
7. Select the task/dispatch
8. Click Finish. 

Creating a repository snapshot from HOPEX
 To create a repository snapshot, the "Authorize management of 
repository snapshots in the workspace" option must have been selected 
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(Options > Collaborative Environment) It is recommended that this 
option be selected at profile level.

To create a repository snapshot from  HOPEX:
1. Connect to HOPEX.

 See the "Accessing HOPEX Windows Front-End in the HOPEX 
Common Features guide.

2. In the HOPEX menu bar, select Tools > Manage > Manage 
Snapshots.
In the dialog box that appears, you can create and delete repository
snapshots as explained in the procedure "Creating a repository snapshot
from the Administration application", page 3.
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REPOSITORY SNAPSHOTS USE CASE

Repository snapshots are used in::
• Comparison of diagrams

 For more details, see "Comparing Two Diagram States", page 6.

• The Compare-Align function
 For more details, see "Comparing and Aligning Two Objects States 
Over Time", page 8.

• Time Machine  to view the repository at an earlier date (Time Machine). 
 For more details see the HOPEX Common Features guide, 
"Handling Repository Objects" chapter.

• Transfer of objects
 For more details, see the guide concerning use of workflows.

Comparing Two Diagram States

HOPEX Collaboration Manager allows you to compare several states of the same
diagram in time. The diagram has been photographed at different moments at
creation of repository snapshots.

 This functionality is available with an RDBMS format repository 
only. You must first have created repository snapshots. For more 
details, see "Managing Repository Snapshots", page 2.

 A repository snapshot identifies an archived state of the repository.

This functionality provides an interface enabling, for example, viewing of certain
objects that have been added or deleted in a diagram since a given repository state.
It consists of time navigation applied to diagrams.

To run diagram comparison:
1. In the pop-up menu of a diagram, select Manage > Compare with an 

archived state.
The repository archived state selection tool opens.
You must select a repository state associated with an object of one of the
following types:
• a repository snapshot
• a dispatch
• a design task
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2. Click Next then Finish.
A comparison dialog box opens:
• The left pane presents the archived version of the diagram
• The right pane presents the current version of the diagram

 You can modify arrangement of panes (position them at the side or 
at the bottom).
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3. Double-click a difference title
Example: double-click the title indicating that an object 
has been created between two repository states.

Modifications carried out in the diagram blink (in this example, the object
created).

 You can zoom in/zoom out or request view of the complete diagram 

in a window by clicking one of the following buttons: .

 If you wish to return to an earlier diagram state, you must use the 
"Compare and Align" functionality (see  "Comparing and Aligning Two 
Objects States Over Time", page 8).

Comparing and Aligning Two Objects States Over Time

Repository snapshots also enable determination of what has changed on an object,
other than a diagram, related to an earlier state of the same object.

 The compare and align functionality allows you to reverse certain 
object modifications. 

To compare and align two versions of the same object:
1. Right-click the object and select Manage > Compare and Align.

 You can also access this functionality from menu Tools > Manage 
> Compare and Align.

2. In the Select the comparison method dialog box, select Two 
archived states from the current repository.

3. Click Next.
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4. In the Source Repository Archived State field, click the arrow and 
select Archived State.

 The source repository serves as reference for comparison and 
alignment.

5. Using the archived state selection mode wizard, select a repository state 
associated with an object of the following type:
• repository snapshot
• dispatch
• design task

6. In the Target Repository Archived State field, select Current State.
 You can also select Current Transaction Initial Archived State 
to select the repository state at the moment you opened the 
transaction.
 To compare all objects of a repository, select the Compare All 
Repository Objects check box.

7. Click Next until reaching Finish.

The destination state is aligned with the archived origin state: the object has
returned to its earlier state.

Using Repository Snapshots for the Time Machine

The time machine which enables to view earlier states of the repository relies on
repository snapshots. 

For more details on the time machine, see HOPEX Common Features, "Handling
Repository Objects", "Consulting Repository State at an Earlier State".

If there is no repository snapshot for the selected date, the previous one is taken
into account.

Example of view of the repository
A snapshot is created twice a week, for instance:

• Snapshot 1: March 26
• Snapshot 2: March 30

On July 2 (current date), a date is selected in the time machine calendar.
Below are the repository views obtained as a function of the snapshots created
previously:

Selected date (at Time Machine level) Repository view obtained

March 24 July 2

March 25 July 2

March 26 Snapshot 1
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March 30 Snapshot 2

July 1 Snapshot 2

July 2 Last view (baseline) of the reposi-
tory

Selected date (at Time Machine level) Repository view obtained
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INTRODUCTION TO ACTION PLANS

This action plan management function consists of defining, executing and following up a certain
number of actions in a project framework. This function is transverse to the different HOPEX
solutions (HOPEX Enterprise Risk Management, HOPEX LDC, etc.), but is also available in the
HOPEX Collaboration Manager product; this is the product described by this user guide. 

The following points are covered in this chapter are:

 "Action plan implementation process", page 6
 "Accessing action plans of HOPEX Collaboration Manager", page 7
 "Desktops linked to Action Plans", page 9
 "About This Guide", page 11
 "Conventions Used in the Guide", page 12
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ACTION PLAN IMPLEMENTATION PROCESS

Associated with all HOPEX Suite products, and more specifically HOPEX
Enterprise Risk Management, HOPEX LDC enables identification, assessment
and remediation of incidents.

Creating the action plan

When the action plan is created, it is in "To submit" state.

By default, the action plan creator is the action plan Owner. 
Having specified the characteristics of a new action plan, the creator can: Propose
the action plan. 

Validating the action plan

The action plan "Responsible" user can Validate or Cancel the action plan.
• Validate: the action plan, which then takes status can be executed. 
• Cancel: the action plan which takes status "Canceled".

Executing the action plan

Having executed actions relating to the action plan, the "Owner" can: Terminate
the action plan which takes status "Closed". To do this, all action plan actions must
be terminated. 

Closing the action plan

After having consulted action plan follow-up reports, the "Approver" user can Close
and then Reopen the action plan.

• Close: the action plan, which retains "Closed" status and disappears 
from the task lists of creator, approver and owner. 

• Reopen: additional actions can then be created. The action plan again 
takes status "In Progress". 
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ACCESSING ACTION PLANS OF HOPEX COLLABORATION 

MANAGER

Prerequisites for using action plans module

Below is a summary of functions available with each product or option.

Connecting to HOPEX Collaboration Manager

Pour connect to HOPEX, see HOPEX Common Features, "HOPEX desktop",
"Accessing HOPEX (Web Front-End)".

Profiles Linked to Action Plans

Presentation of the solution interface depends on the profiles selected by the user
at connection to the application; the tree of menus and functions can vary from one
profile to another.

Before organizing work with HOPEX, appropriate teams must be set up and roles
and responsibilities assigned. To do this, a set of tools enables creation and
management of the different participants.

 For more details on management of profiles, see the HOPEX 
Administration - Supervisor guide.

Action Plan Manager
Has authorizations for creation of action plans and their associated actions. He/she
can access all follow-up reports. The action plans created by the Action Plan
Manager respect top-down workflow.

Product/Option Features

HOPEX Collaboration Man-
ager

- Creating and executing action plans and actions

HOPEX Studio - Creating and modifying workflow definitions
- Adding objects on which to execute action plans
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Action Plan Owner
Has authorizations for modification of action plans and creation of associated
actions. He/she can only access action plans of which he/she is the owner. He/she
cannot access follow-up reports of all action plans.

Action Owner 
Has authorizations to access their assigned actions. The "Action Owner" can also
consult the action plans containing his actions.

Action plan approver

This is the person who can approve starting an action plan. 

It is not a connection role, since it is not associated with a profile. User of a HOPEX
solution, the approver has another role elsewhere.

Action plan creator

This role can be used by a user to modify his action plans and to create new ones.
However, the new action plans must be validated by an approver before being
implemented (workflow Bottom-Up). An Action plan creator can also create or
modify the actions of his action plans.
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DESKTOPS LINKED TO ACTION PLANS

This section presents desktops proposed to the different profiles concerned by
action plans.

Desktop proposed to the action plan manager

This profile accesses the same commands as profiles "Action Owner" and "Action
Plan Owner". It has an additional command to access follow-up reports of all action
plans: Action Plan > Reports.

 For more details, see "Action Plan Follow-Up Reports", page 25.

Desktop proposed to the action plan owner

The "Action Owner" can only access action plans of which he/she is owner, and their
actions.

To access the list of action plans, the "Action Plan Owner" must:
 Select the command Action Plan > My Responsibilities > My Action 

Plans.

The "Action Plan Owner" can also access the list of his/her action plans and the
actions he/she has created.

To access these lists, the "Action Plan Owner" must:
 Select Action Plan > My Responsibilities >Action Plans.

Folders displayed concern:
• All action plans created
• All action plans created by the connected person
• Actions created by the connected person.

 For more information on the different action plan steps, see "Action 
Plan Workflows", page 32.
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Desktop proposed to the action owner

To access the list of action plans, the "Action Owner" must:
 Select Action Plan > My Responsibilities > My Action Plans.

The list of action plans concerning actions placed under the responsibility
of the connected person is displayed in the edit area.

To access action plan properties: 
1. Select the action plan.
2. Click Properties.

 For more information on action plans, see "Supplementing Action 
Plan Information", page 16.
 For more details on action properties, see "Creating an Action", 
page 20.
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ABOUT THIS GUIDE

Guide Structure

This guide presents the functionalities of HOPEX Collaboration Manager linked to
action plans. The  guide comprises the following chapters:

• "Action Plans", page 15
• "Glossary", page 29.
• "Appendices", page 31

Additional Resources

This guide is supplemented by:
• the HOPEX Common Features Common Features guide, which 

describes the Web interface and tools specific to MEGA solutions.
 It can be useful to consult this guide for a general presentation of 
the interface.

• HOPEX Studio article, for more details on steering calendars 
configuration

• the administration guide HOPEX Administration - Supervisor, HOPEX 
Administration - Supervisor,, for management of profiles and roles of 
your users.
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CONVENTIONS USED IN THE GUIDE

 Remark on the preceding points.

 Definition of terms used.

 A tip that may simplify things.

 Compatibility with previous versions.

 Things you must not do.

Commands are presented as seen here: File > Open.
Names of products and technical modules are presented in bold as seen here:
HOPEX.

Very important remark to avoid errors during an operation.
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Command formulation convention 

To reference a command in the solution, and with a view to simplification, the
following formulation has been adopted in this guide: 

Example of a command with its formulation in the guide

Application command Formulation adopted in this 
guide

Select Action Plan> My Respon-
sibilities > My Action Plans.
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ACTION PLANS

This chapter describes operation of action plans and their customization.

 "Using Action Plans", page 16
 "Managing Actions", page 20
 "Assure follow-up of Action plan", page 23
 "Action Plan Follow-Up Reports", page 25
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USING ACTION PLANS

This chapter introduces the operating principles of action plans proposed as
standard in MEGA. 

 An action plan comprises a series of actions. Its objective is to 
reduce the risks or events that have a negative impact on enterprise 
activities, or to improve efficiency of a process or organization. 

Two workflows are proposed to manage steps of two types of action plan
progression:

• A Bottom-Up workflow, which corresponds to the case where an action 
plan is created by any user. The new action plan must then be validated 
by an approver before being implemented.

• A Top-Down workflow, which corresponds to the case where an action 
plan is created by a responsible user (action plan manager or action plan 
owner). The validation step of the new action plan is not necessary in 
this case.

 For more information on action plan standard workflows, see 
"Appendices", page 31.

Creating Action Plans

To create an action plan:
1. Select Home > My Desktop > My Responsibilities > My Action 

Plans. 
2. In the edit area, click the New button.

The action plan is created and added to the list of action plans. The action
plan is created with status "Open".

Supplementing Action Plan Information

Before submitting the action for approval, the action plan requester can complete
information on the action plan. 

To update fields that characterize an action plan:
 Open the properties of the action plan that interests you.

In the Characteristics tab, the following sections appear:
• "General characteristics", page 17
• "Action plan statuses", page 17
• "Managing Actions", page 20
• "Success factors", page 18
• "Scope", page 18
• "Milestones", page 18
• "Attachments", page 18
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General characteristics

In the Characteristics section, you can specify action plan fields, for example:
• Name: action plan name.
• Owner: this field is specified by default by the user who created the 

action plan.
• Owner Entity: enables restriction of the list of owner entities. 
• Approver: user responsible for validation of the action plan when all 

actions are completed.
• Means: text description of means required/desired for action plan 

execution.
• Priority: enables indication of a level. Priority can be: "Low", 

"Medium", "High" or "Critical".
• Organizational Level: final objective of plan; this can be "Global" or 

"Local". 
• Origin: enables definition of the context of carrying out the action 

plan: "Audit", "Compliance", "Event", "Risk", "RFC" or "Others".
• Category: enables specification of the action undertaken, for 

example: "Process Improvement". 
• Nature: enables definition of the action plan undertaken: "Preventive" 

or "Corrective". 
• Comment: supplements information on the action plan and its 

characteristics. 

Action plan statuses
• To Send: proposed by the action plan creator.
• To Start: accepted by the person designated as "approver" in the 

properties of an action plan.
• Canceled: the action plan responsible user has refused the action 

plan, which will not be implemented. 
• In Progress: accepted by the action plan responsible user, actions 

are defined or being executed. 
• Completed: all action plan actions have been executed. The 

responsible user has submitted a closing request to the approver, who 
can accept or refuse it. 

• Closed: the action plan is completed and approved. 

Financial assertion
• Forecast Cost: estimate of action plan cost expressed in Currency.
• Real Cost: action plan real cost expressed in Currency.
• Forecast Cost (Man-Days): estimate in man-days of action plan 

implementation workload. 
• Real Cost (Man-Days): cost of action plan implementation 

expressed in man-days . 
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Success factors

In the Success Factors section, you can specify in text the success indicators
enabling assessment of success of the action plan.

• Key Success Factors: text information on action plan success 
factors.

• Success: information on action plan final success. "None", "True" or 
"False"

• Comments on Success: text information on action plan results.

Scope

To position an action plan in its environment, you can associate objects with the
action plan in the Scope section.

You can connect objects of risk, business and organizational process, control, entity
or application type. 

Milestones

Milestones are important dates of the action plan. You can specify these dates later.
• Effective Begin Date and Planned Begin Date 
• Effective End Date and Planned End Date

Attachments

You can attach business documents to an action plan: 
 For more details on the use of business documents, see the HOPEX 
Common Features guide.

Action Plan Progress Steps

Creating the action plan

When the action plan is created, it is in "To submit" state.

By default, the action plan creator is the action plan Owner. Having specified the
characteristics of a new action plan, the creator can:

• Propose the action plan. 
In this case, the user defined as "Approver" receives a notification mail,
and the new action plan appears with status "To Begin" in his/her tasks
list.

Preparing the action plan

The action plan "Responsible" user can Validate or Cancel the action plan.
• Validate: the action plan, which then takes status "In Progress". Actions 

can then be created. 
• Cancel: the action plan which takes status "Canceled".
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Executing the action plan

Having executed actions relating to the action plan, the "Owner" can:
• Terminate the action plan which takes status "Closed". To do this, all 

action plan actions must be terminated. 
The "Approver" user is notified of the action plan termination request.

Closing the action plan

After having consulted action plan follow-up reports, the "Approver" user can Close
and then Reopen the action plan.

• Close: the action plan, which retains "Closed" status and disappears 
from the task lists of creator, approver and owner. 

• Reopen: additional actions can then be created. The action plan again 
takes status "In Progress". 

 For more information on action plan workflow, see "Action Plan 
Workflows", page 32.
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MANAGING ACTIONS

The action plan Responsible User must define actions enabling execution of the
action plan. The Responsible User can create actions and assign these.

Creating an Action

To create an action from an action plan:
1. Select Home > My Desktop > My Responsibilities > My Action 

Plans.
2. In the page that appears, select the action plan that interests you and 

click Property.
3. In the Actions section, click New.

The action appears in the list of action plan actions.
4. Open the properties of the action and specify its Name.
5. Specify the following fields:

• Priority: enables indication of a level. Priority can be: "Low", 
"Medium", "High" or "Critical".

• Action Responsible: responsible for the action as specified by the 
action plan creator.

• Owner Entity: owner organization unit enabling restriction of the list 
of action owners. 

6. You can specify milestones, which are important dates of the action. 
• Effective Begin Date  and Planned Begin Date. 
• Effective End Date  and Planned End Date.

7. Click OK.
The action is created with "Created" status.

8. Connect the controls you want to implement.
 These fields are accessible when the action has taken "Open" 
status.

Action statuses
• Created: the action is created.
• Project: the created action awaits opening by the "action owner".
• In Progress:action is accepted by its owner.
• To Close: the action is completed and must be approved by the 

"action plan owner or approver".
• Closed:the action is completed and approved.

Defining Action Scope

An action can concern one or several objects of control, risk or application type. 
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For example, to define the controls that will be executed in the framework of the
action:

1. Open the properties of the action.
2. Expand the Scope section.
3. Connect the controls you want to implement.

 These fields are accessible when the action has taken "Open" 
status.

Action Management Steps

 For more details on an action workflow, see the, chapter "Le 
workflow d’une action" in the HOPEX Collaboration Manager guide.

When an action has been created, the action creator can declare the action as being
in "Project" status. 

When all actions of an action plan have been published and accepted, the action plan
can be implemented.

Command proposed to creator

Having specified the characteristics of a new action, the "action plan owner or
approver" can use the commend:

• Project. 
In this case the user defined as "Responsible User" receives a notification
by mail and the new action takes status "Project".

Command proposed to entities concerned by an action in "Project" status

When an action has been proposed by the user the "action plan owner or approver"
and the "Responsible" user can:

• Open the action, which takes status "Open".

Command proposed to "Open" action responsible user

Having studied action execution possibilities, the "Responsible User" can:
• Terminate the action.

A notification is sent to the user defined as "action plan owner or
approver".

Commands proposed to the "action plan owner or approver" of a terminated 
action

After studying characteristics of the action he/she created, the action plan owner or
approver" creator can:

• Close. 
In this case the user defined as "Responsible" receives a notification and
the action takes status "Closed".

• Return to responsible user, for supplementary actions.
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ASSURE FOLLOW-UP OF ACTION PLAN

Action plan progress is specified at periodic dates by the action plan responsible
user. For more details, see "Specifying action plan progress rate", page 23.

So that a reminder e-mail can be automatically sent to the action plan responsible
user, you can connect a Steering Calendar to the action plan. For more details,
see "Using a steering calendar", page 23.

Specifying action plan progress rate

The action plan progress rate can be specified if the action plan is in the status "In
progress", that is it has been validated.

To indicate progress of an action plan:
1. Open the properties of the action plan and expand the Action Plan 

Progress section.
2. In the Progress Rate table, click New.

The Progress Rate creation page appears.
3. Specify the Name of the progress rate.
4. Specify the Updated Progress Percentage and add a percentage 

Comment, if required.
5. Verify the Progress Date.
6. Specify the Progress Assessment:

• Delayed
• On Time

7. In the progress rate properties page, click OK.
The progress rate appears in the list.
The Last Progress Percentage and Last Progress Percentage
Comment fields are updated.

Using a steering calendar

Creating a steering calendar

You can connect a Steering Calendar to the action plan so that the action plan
responsible user can indicate a progress percentage at dates defined in this
calendar. A message is sent to the user on these dates.

 For more details on managing steering calendars, see the technical 
article HOPEX Studio - Steering calendar.

To create a steering calendar for an action plan:
1. Open the properties of an action plan.
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2. In the Characteristics section, click the arrow at the right of the 
Steering Calendar field.

3. Select Create a steering calendar.
The steering calendar creation page appears.

4. Specify the Name of the steering calendar.
5. In the Steering Calendar Type field, leave the default value "Action 

Plan".
6. In the Scheduler Configuration field, leave the default value "Steering 

Calendar - Configuration scheduler".
7. In the Reminder field, leave the default value "Steering Calendar - 

Emailing SchedulerJob".
8. Click OK.

You must then create Steering Dates.

Creating steering dates
 A steering date is a date defined in a steering calendar on which a 
reminder will be sent to the person responsible for an element. This can 
be an initial date, reminder date or final due date. 

To create a steering date for an existing steering calendar:
1. Open the properties of the steering calendar that interests you.
2. In the Steering Date section, click New.

The new steering date appears in the list.

To define steering date characteristics:
1. Open the steering date properties dialog box and select the 

Characteristics tab.
2. Specify the Name of the date, to enable its reuse in another steering 

calendar if required.
3. Specify the Date Type.

• "Initial" - to signify start of an action plan
• "Remind" - to remind the responsible user of progress rate update
• "Last" - to signify close of an action plan

4. Specify messages that will be addressed as notification and as E_mail.
You must then plan the dates of actions execution.

To schedule a steering date:
 Open the steering date properties dialog box and select the Scheduling 

tab.
You must define the Start date (absolute ou Relative) and the
Recurrence Type.

 The start hour is defined in UTC format.

• The Start date may be specified by Start date (absolute) or by 
Relative Date.

 The Relative Date is defined related to the Effective Begin Date 
of the action plan.

• The Recurrence Type defines the frequency at which reminders are 
sent: daily, weekly, monthly, once only.

 For details on scheduler configuration, see "Scheduling" chapter in 
the HOPEX Studio - Steering calendar technical article
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ACTION PLAN FOLLOW-UP REPORTS

Dynamic reports enable repository data analysis according to different perspectives.

To get a more detailed view of the information regarding the action plans, you can
use the Drill-Down Analyses facilities.

 For more details, see the HOPEX Common Features guide, 
chapter "Launching Drill-Down Analyses (Instant Reports).

Accessing Action Plan Standard Reports

To generate an action plan follow-up report:
1. Select Action Plans > Action Plan Reports > Action Plan Follow-

Up.
2. Specify:

• the action plans concerned.
• the period, defined by begin date and end date.

3. Click Calculate.

Action plan reports enable a user to plan his/her action plans and follow their
progress. Proposed action plan report types are:

• "Action Plan Follow-Up", page 25
• "Action Plan Gantt Chart", page 26
• "Action Plan Progress", page 26

Action Plan Follow-Up

This report presents distribution of action plans according to criteria such as
priorities or categories.

To generate a report in the form of action plan follow-up:
 Select Action Plans > Reports > Action Plan Follow-Up.
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Report example

The upper part of the report presents distribution of action plans on the following
criteria:

• Distribution by priorities
• Distribution by organizational level
• Distribution by status
• Distribution by origin
• Distribution by category
• Distribution by execution

 To obtain a list of action plans making up a sector or a bar chart 
bar:, click the sector (or bar chart bar) that interests you. For more 
information, see HOPEX Common Features.

Action Plan Gantt Chart

This report enables comparison of action plan begin and end dates defined in
parameters. 

 For more details, see "Milestones", page 18.

To generate a report in the form of a Gantt chart:
 Select Action Plans > Reports > Action Plan Gantt.

Action Plan Progress

This report enables follow-up of progress of action plans defined in parameters.
Action plan progress is defined by responsible users.

 For more details, see "Managing Actions", page 20.
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To generate a report in the form of a Gantt chart:
 Select Action Plans > Reports > Action Plan Progress.
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This chapter presents:

 "Action Plan Workflows", page 32
 "Action Workflow", page 37
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ACTION PLAN WORKFLOWS

Two workflows are proposed to manage different steps of an action plan:
• A Bottom-Up workflow, which corresponds to the case where an action 

plan is created by any user. The new action plan must then be validated 
by an approver before being implemented.

• A Top-Down workflow, which corresponds to the case where an action 
plan is created by an "action plan manager". The validation step of the 
new action plan is not necessary in this case.

With the exception of the action plan validation step, these two workflows are
identical. The Bottom-Up workflow is described here, since it is more
comprehensive.

Action Plan Progress Steps Defined as Bottom-Up

Creating the action plan

When the action plan is created, it is in "To submit" state.

By default, the action plan creator is the action plan Owner. Having specified the
characteristics of a new action plan, the creator can:

• Propose the action plan. 
In this case, the user defined as "Approver" receives a notification mail,
and the new action plan appears with status "To Begin" in his/her tasks
list.

Preparing the action plan

The action plan "Approver" user can:
• Validate the action plan, which then takes status ""In Progress". Actions 

can then be created. For more details, see "Managing Actions", page 20.
• Cancel the action plan which takes status "Canceled".

Executing the action plan

Having executed actions relating to the action plan, the "Owner" can:
• Terminate the action plan which takes status "Closed". To do this, all 

action plan actions must be terminated. For more details, see "Managing 
Actions", page 20.
The "Approver" user is notified of the action plan termination request.
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Closing the action plan

After having consulted action plan follow-up reports, the "Approver" user can:
• Close the action plan, which retains "Closed" status and disappears from 

the task lists of creator, approver and owner. 
• Reopen, for additional actions. The action plan again takes status "In 

Progress". 

Action Plan Workflows

Steps in the action plan management process are described in "Action Plan Progress
Steps Defined as Bottom-Up", page 32.

The workflow diagram introduces:
• participants 

• "Creator", who also validates action plan closure
• "Owner", who is responsible for carrying out actions of the action plan.
• "Approver", who is responsible for scope covered by the action plan.

• Workflow statuses of the action plan, and planned transitions between 
statuses.

• Planned notifications on certain transitions.

Top-down action plan workflow 
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Bottom-up action plan workflow 
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Action Plan Workflow Mails

Action plan to be validated

Action plan to be reviewed

Action plan validated

From Creator

To Approver

Subject Action plan to validate - [Action plan name]

Content Dear Sir, Madam,

Please validate the action plan submitted by [Action plan creator name]

To enter the application and perform your task, click here.
Comment: [Comment]

This e-mail has been sent automatically by MEGA HOPEX.

From Approver

To Creator

Subject Action plan to review - [Action plan name]

Content Dear Sir, Madam,

The following action plan must be reviewed - [Action plan name]

Please enter the application for details by clicking here.
Comment: [Comment]

This e-mail has been sent automatically by MEGA HOPEX.

From Approver

To Owner

Subject Action plan validated - [Action plan name]

Content Dear Sir, Madam,

The action plan [Action plan name] is validated.
Thank you for your collaboration
Comment: [Comment]

This e-mail has been sent automatically by MEGA HOPEX.
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Close action plan

Action Plan Reopened

Action plan closed

From Owner

To Approver

Subject Action plan to close - [Action plan name]

Content Dear Sir, Madam,

The following action plan has been completed for closure [Action plan name].
Please enter the application for details by clicking here.
Comment: [Comment]

This e-mail has been sent automatically by MEGA HOPEX.

From Approver

To Owner

Subject Action Plan reopened - [Action plan name]

Content Dear Sir, Madam,

The following action plan must be re-completed [Action plan name].
Please enter the application for details by clicking here.
Comment: [Comment]

This e-mail has been sent automatically by MEGA HOPEX.

From Approver

To Owner

Subject Action plan Closed - [Action plan name]

Content Dear Sir, Madam,

The action plan [Action plan name] has been closed.
Thank you for your collaboration
Comment: [Comment]

This e-mail has been sent automatically by MEGA HOPEX.
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ACTION WORKFLOW

Action Workflow Steps

Action Workflow Notifications

No mail is provided for actions, only notifications are sent by the creator to the
responsible user:

• when the action is assigned to a user,
• when the action is closed.
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